BATTERY-MIB
47 objects
This MIB module defines a set of objects for monitoring batteries of networked devices and of their components. Copyright (c) 2015 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 7577; see the RFC itself for full legal notices.
Imported Objects
| ENTITY-MIB | -- RFC 3411 entPhysicalIndex |
| SNMP-FRAMEWORK-MIB | -- RFC 2580 SnmpAdminString |
| SNMPv2-CONF | -- RFC 2579 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP |
| SNMPv2-SMI | Integer32 mib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 2578 DateAndTime |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.233 | IdentitybatteryMIB | This MIB module defines a set of objects for monitoring batteries of networked devices and of their components. Copyright (c) 2015 IETF Trust and the persons i… | ||
| 1.3.6.1.2.1.233.0 | NodebatteryNotifications | |||
| 1.3.6.1.2.1.233.0.1 | NotificationbatteryChargingStateNotification | current | This notification can be generated when a charging state of the battery (indicated by the value of object batteryChargingOperState) is triggered by an event ot… | |
| 1.3.6.1.2.1.233.0.2 | NotificationbatteryLowNotification | current | This notification can be generated when the current charge (batteryActualCharge) or the current voltage (batteryActualVoltage) of the battery falls below a thr… | |
| 1.3.6.1.2.1.233.0.3 | NotificationbatteryCriticalNotification | current | This notification can be generated when the current charge of the battery falls so low that it cannot provide a sufficient power supply function for regular op… | |
| 1.3.6.1.2.1.233.0.4 | NotificationbatteryTemperatureNotification | current | This notification can be generated when the measured temperature (batteryTemperature) rises above the threshold defined by object batteryAlarmHighTemperature o… | |
| 1.3.6.1.2.1.233.0.5 | NotificationbatteryAgingNotification | current | This notification can be generated when the actual capacity (batteryActualCapacity) falls below a threshold defined by object batteryAlarmLowCapacity or when t… | |
| 1.3.6.1.2.1.233.0.6 | NotificationbatteryConnectedNotification | current | This notification can be generated when it has been detected that a battery has been connected. The battery can be identified by the value of object batteryIde… | |
| 1.3.6.1.2.1.233.0.7 | NotificationbatteryDisconnectedNotification | current | This notification can be generated when it has been detected that one or more batteries have been disconnected. | |
| 1.3.6.1.2.1.233.1 | NodebatteryObjects | |||
| 1.3.6.1.2.1.233.1.1 | TablebatteryTable | not-accessible | current | This table provides information on batteries. It contains one conceptual row per battery in a managed entity. Batteries are indexed by the entPhysicalIndex of … |
| 1.3.6.1.2.1.233.1.1.1 | RowbatteryEntry | not-accessible | current | An entry providing information on a battery. |
| 1.3.6.1.2.1.233.1.1.1.1 | ColumnbatteryIdentifier | read-only | current | This object contains an identifier for the battery. Many manufacturers deliver not only simple batteries but battery packages including additional hardware and… |
| 1.3.6.1.2.1.233.1.1.1.2 | ColumnbatteryFirmwareVersion | read-only | current | This object indicates the version number of the firmware that is included in a battery module. Many manufacturers deliver not pure batteries but battery packag… |
| 1.3.6.1.2.1.233.1.1.1.3 | ColumnbatteryType | read-only | current | This object indicates the type of battery. It distinguishes between primary (not rechargeable) batteries, rechargeable (secondary) batteries, and capacitors. C… |
| 1.3.6.1.2.1.233.1.1.1.4 | ColumnbatteryTechnology | read-only | current | This object indicates the technology used by the battery. Numbers identifying battery technologies are registered at IANA. A current list of assignments can be… |
| 1.3.6.1.2.1.233.1.1.1.5 | ColumnbatteryDesignVoltage | read-only | current | This object provides the design (or nominal) voltage of the battery in units of millivolt (mV). Note that the design voltage is a constant value and typically … |
| 1.3.6.1.2.1.233.1.1.1.6 | ColumnbatteryNumberOfCells | read-only | current | This object indicates the number of cells contained in the battery. A value of 0 indicates that the number of cells is unknown. |
| 1.3.6.1.2.1.233.1.1.1.7 | ColumnbatteryDesignCapacity | read-only | current | This object provides the design (or nominal) capacity of the battery in units of milliampere hours (mAh). Note that the design capacity is a constant value and… |
| 1.3.6.1.2.1.233.1.1.1.8 | ColumnbatteryMaxChargingCurrent | read-only | current | This object provides the maximum current to be used for charging the battery in units of milliampere (mA). Note that the maximum charging current may not lead … |
| 1.3.6.1.2.1.233.1.1.1.9 | ColumnbatteryTrickleChargingCurrent | read-only | current | This object provides the recommended average current to be used for trickle charging the battery in units of mA. Typically, this is a value recommended by the … |
| 1.3.6.1.2.1.233.1.1.1.10 | ColumnbatteryActualCapacity | read-only | current | This object provides the actual capacity of the battery in units of mAh. Typically, the actual capacity of a battery decreases with time and with usage of the … |
| 1.3.6.1.2.1.233.1.1.1.11 | ColumnbatteryChargingCycleCount | read-only | current | This object indicates the number of completed charging cycles that the battery underwent. In line with the Smart Battery Data Specification Revision 1.1, a cha… |
| 1.3.6.1.2.1.233.1.1.1.12 | ColumnbatteryLastChargingCycleTime | read-only | current | The date and time of the last charging cycle. The value '0000000000000000'H is returned if the battery has not been charged yet or if the last charging time ca… |
| 1.3.6.1.2.1.233.1.1.1.13 | ColumnbatteryChargingOperState | read-only | current | This object indicates the current charging state of the battery. Value unknown(1) indicates that the charging state of the battery cannot be determined. Value … |
| 1.3.6.1.2.1.233.1.1.1.14 | ColumnbatteryChargingAdminState | read-write | current | The value of this object indicates the desired charging state of the battery. The real state is indicated by object batteryChargingOperState. See the definitio… |
| 1.3.6.1.2.1.233.1.1.1.15 | ColumnbatteryActualCharge | read-only | current | This object provides the actual charge of the battery in units of mAh. Note that the actual charge needs to be measured and is typically an estimate based on o… |
| 1.3.6.1.2.1.233.1.1.1.16 | ColumnbatteryActualVoltage | read-only | current | This object provides the actual voltage of the battery in units of mV. A value of 'ffffffff'H indicates that the actual voltage cannot be determined. |
| 1.3.6.1.2.1.233.1.1.1.17 | ColumnbatteryActualCurrent | read-only | current | This object provides the actual charging or discharging current of the battery in units of mA. The charging current is represented by positive values, and the … |
| 1.3.6.1.2.1.233.1.1.1.18 | ColumnbatteryTemperature | read-only | current | The ambient temperature at or within close proximity of the battery. A value of '7fffffff'H indicates that the temperature cannot be determined. |
| 1.3.6.1.2.1.233.1.1.1.19 | ColumnbatteryAlarmLowCharge | read-write | current | This object provides the lower-threshold value for object batteryActualCharge. If the value of object batteryActualCharge falls below this threshold, a low-bat… |
| 1.3.6.1.2.1.233.1.1.1.20 | ColumnbatteryAlarmLowVoltage | read-write | current | This object provides the lower-threshold value for object batteryActualVoltage. If the value of object batteryActualVoltage falls below this threshold, a low-b… |
| 1.3.6.1.2.1.233.1.1.1.21 | ColumnbatteryAlarmLowCapacity | read-write | current | This object provides the lower-threshold value for object batteryActualCapacity. If the value of object batteryActualCapacity falls below this threshold, a bat… |
| 1.3.6.1.2.1.233.1.1.1.22 | ColumnbatteryAlarmHighCycleCount | read-write | current | This object provides the upper-threshold value for object batteryChargingCycleCount. If the value of object batteryChargingCycleCount rises above this threshol… |
| 1.3.6.1.2.1.233.1.1.1.23 | ColumnbatteryAlarmHighTemperature | read-write | current | This object provides the upper-threshold value for object batteryTemperature. If the value of object batteryTemperature rises above this threshold, a battery h… |
| 1.3.6.1.2.1.233.1.1.1.24 | ColumnbatteryAlarmLowTemperature | read-write | current | This object provides the lower-threshold value for object batteryTemperature. If the value of object batteryTemperature falls below this threshold, a battery l… |
| 1.3.6.1.2.1.233.1.1.1.25 | ColumnbatteryCellIdentifier | read-only | current | The value of this object identifies one or more cells of a battery. The format of the cell identifier may vary between different implementations. It should uni… |
| 1.3.6.1.2.1.233.2 | NodebatteryConformance | |||
| 1.3.6.1.2.1.233.2.1 | NodebatteryCompliances | |||
| 1.3.6.1.2.1.233.2.1.1 | CompliancebatteryCompliance | read-only | current | The compliance statement for implementations of the BATTERY-MIB module. A compliant implementation MUST implement the objects defined in the mandatory groups b… |
| 1.3.6.1.2.1.233.2.2 | NodebatteryGroups | |||
| 1.3.6.1.2.1.233.2.2.1 | GroupbatteryDescriptionGroup | current | A compliant implementation MUST implement the objects contained in this group. | |
| 1.3.6.1.2.1.233.2.2.2 | GroupbatteryStatusGroup | current | A compliant implementation MUST implement the objects contained in this group. | |
| 1.3.6.1.2.1.233.2.2.3 | GroupbatteryAdminGroup | current | A compliant implementation does not have to implement the object contained in this group. | |
| 1.3.6.1.2.1.233.2.2.4 | GroupbatteryAlarmThresholdsGroup | current | A compliant implementation does not have to implement the objects contained in this group. | |
| 1.3.6.1.2.1.233.2.2.5 | GroupbatteryNotificationsGroup | current | A compliant implementation does not have to implement the notifications contained in this group. | |
| 1.3.6.1.2.1.233.2.2.6 | GroupbatteryPerCellNotificationsGroup | current | A compliant implementation does not have to implement the object contained in this group. |