ENERGY-OBJECT-CONTEXT-MIB
38 objects
Copyright (c) 2015 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This MIB is used for describing the identity and the context information of Energy Objects.
Imported Objects
| ENTITY-MIB | -- RFC 4001 entPhysicalIndex |
| IANA-ENERGY-RELATION-MIB | -- RFC 6933 IANAEnergyRelationship |
| INET-ADDRESS-MIB | -- RFC 3411 InetAddressType InetAddress |
| SNMP-FRAMEWORK-MIB | -- RFC 2580 SnmpAdminString |
| SNMPv2-CONF | -- RFC 2579 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | Integer32 mib-2 MODULE-IDENTITY OBJECT-TYPE |
| SNMPv2-TC | -- RFC 2578 TEXTUAL-CONVENTION MacAddress RowStatus StorageType TruthValue |
| UUID-TC-MIB | -- RFC 6933 UUIDorZero |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.231 | IdentityenergyObjectContextMIB | Copyright (c) 2015 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with o… | ||
| 1.3.6.1.2.1.231.0 | NodeenergyObjectContextMIBNotifs | |||
| 1.3.6.1.2.1.231.1 | NodeenergyObjectContextMIBObjects | |||
| 1.3.6.1.2.1.231.1.1 | TableeoTable | not-accessible | current | This table lists Energy Objects. |
| 1.3.6.1.2.1.231.1.1.1 | RoweoEntry | not-accessible | current | An entry describes the attributes of an Energy Object. Whenever a new Energy Object is added or an existing Energy Object is deleted, a row in the eoTable is a… |
| 1.3.6.1.2.1.231.1.1.1.1 | ColumneoEthPortIndex | read-only | current | This variable uniquely identifies the power Ethernet port to which a Power over Ethernet device is connected. If the Power over Ethernet MIB in RFC 3621 is sup… |
| 1.3.6.1.2.1.231.1.1.1.2 | ColumneoEthPortGrpIndex | read-only | current | This variable uniquely identifies the group containing the port to which a power over Ethernet device PSE is connected (RFC 3621). If the Power over Ethernet M… |
| 1.3.6.1.2.1.231.1.1.1.3 | ColumneoLldpPortNumber | read-only | current | This variable uniquely identifies the port component (contained in the local chassis with the LLDP agent) as defined by the lldpLocPortNum in the LLDP-MIB and … |
| 1.3.6.1.2.1.231.1.1.1.4 | ColumneoMgmtMacAddress | read-only | current | This object specifies a Media Access Control (MAC) address of the Energy Object. |
| 1.3.6.1.2.1.231.1.1.1.5 | ColumneoMgmtAddressType | read-only | current | This object specifies the eoMgmtAddress type, i.e., an IPv4 or IPv6 address. This object MUST be populated when eoMgmtAddress is populated. |
| 1.3.6.1.2.1.231.1.1.1.6 | ColumneoMgmtAddress | read-only | current | This object specifies the management address as an IPv4 address or IPv6 address of Energy Object. The IP address type, i.e. IPv4 or IPv6, is determined by the … |
| 1.3.6.1.2.1.231.1.1.1.7 | ColumneoMgmtDNSName | read-only | current | This object specifies a DNS name of the eoMgmtAddress. This object can be used as an alternate key to help link the Energy Object with other keyed information … |
| 1.3.6.1.2.1.231.1.1.1.8 | ColumneoDomainName | read-write | current | This object specifies the name of an Energy Management Domain for the Energy Object. By default, this object should be an empty string. The value of eoDomainNa… |
| 1.3.6.1.2.1.231.1.1.1.9 | ColumneoRoleDescription | read-write | current | This object specifies an administratively assigned name to indicate the purpose an Energy Object serves in the network. For example, we can have a phone deploy… |
| 1.3.6.1.2.1.231.1.1.1.10 | ColumneoKeywords | read-write | current | This object specifies a list of keywords that can be used to group Energy Objects for reporting or searching. The value is the zero-length string if no keyword… |
| 1.3.6.1.2.1.231.1.1.1.11 | ColumneoImportance | read-write | current | This object specifies a ranking of how important the Energy Object is (on a scale of 1 to 100) compared with other Energy Objects in the same Energy Management… |
| 1.3.6.1.2.1.231.1.1.1.12 | ColumneoPowerCategory | read-only | current | This object describes the Energy Object category, which indicates the expected behavior or physical property of the Energy Object, based on its design. An Ener… |
| 1.3.6.1.2.1.231.1.1.1.13 | ColumneoAlternateKey | read-write | current | The eoAlternateKey object specifies an alternate key string that can be used to identify the Energy Object. Since Energy Management Systems (EnMS) and Network … |
| 1.3.6.1.2.1.231.1.1.1.14 | ColumneoPowerInterfaceType | read-only | current | This object describes the Power Interface for an Energy Object. A Power Interface is an interface at which an Energy Object is connected to a power transmissio… |
| 1.3.6.1.2.1.231.1.2 | TableeoRelationTable | not-accessible | current | This table describes the relationships between Energy Objects. |
| 1.3.6.1.2.1.231.1.2.1 | RoweoRelationEntry | not-accessible | current | An entry in this table specifies the Energy relationship between Energy objects. Energy relations between two Energy objects are defined in RFC 7326. |
| 1.3.6.1.2.1.231.1.2.1.1 | ColumneoRelationIndex | not-accessible | current | This object is an arbitrary index to identify the Energy Object related to another Energy Object. |
| 1.3.6.1.2.1.231.1.2.1.2 | ColumneoRelationID | read-create | current | This object specifies the Universally Unique Identifier (UUID) of the peer (other) Energy Object. The UUID must comply with the specifications of UUID in UUID-… |
| 1.3.6.1.2.1.231.1.2.1.3 | ColumneoRelationship | read-create | current | This object describes the relations between Energy Objects. For each Energy Object, the relations between the other Energy Objects are specified using the bitm… |
| 1.3.6.1.2.1.231.1.2.1.4 | ColumneoRelationStatus | read-create | current | The status controls and reflects the creation and activation status of a row in this table to specify energy relationship between Energy Objects. An entry stat… |
| 1.3.6.1.2.1.231.1.2.1.5 | ColumneoRelationStorageType | read-create | current | This variable indicates the storage type for this row. |
| 1.3.6.1.2.1.231.2 | NodeenergyObjectContextMIBConform | |||
| 1.3.6.1.2.1.231.2.1 | NodeenergyObjectContextMIBCompliances | |||
| 1.3.6.1.2.1.231.2.1.1 | ComplianceenergyObjectContextMIBFullCompliance | current | When this MIB is implemented with support for read-write, then such an implementation can claim full compliance. Such devices can then be both monitored and co… | |
| 1.3.6.1.2.1.231.2.1.2 | ComplianceenergyObjectContextMIBReadOnlyCompliance | current | When this MIB is implemented without support for read-write (i.e., in read-only mode), then such an implementation can claim read-only compliance. Such a devic… | |
| 1.3.6.1.2.1.231.2.2 | NodeenergyObjectContextMIBGroups | |||
| 1.3.6.1.2.1.231.2.2.1 | GroupenergyObjectContextMIBTableGroup | current | This group contains the collection of all the objects related to the EnergyObject. | |
| 1.3.6.1.2.1.231.2.2.2 | GroupenergyObjectOptionalMIBTableGroup | current | This group contains the collection of all the objects related to the Energy Object. | |
| 1.3.6.1.2.1.231.2.2.3 | GroupenergyObjectRelationTableGroup | current | This group contains the collection of all objects specifying the relationship between Energy Objects. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| EnergyObjectKeywordList | OCTET STRING (SIZE (0..2048)) | current | A list of keywords that can be used to group Energy Objects for reporting or searching. If multiple keywords are present, then this string will contain all the keywords separated by the ',' character. All alphanumeric c… |
| LldpPortNumberOrZero | Integer32(0..4096) | current | This textual convention is an extension of the LldpPortNumber convention specified in the LLDP MIB, which defines a greater than zero value used to uniquely identify each port contained in the chassis (that is known to … |
| PethPsePortGroupIndexOrZero | Integer32 (0..2147483647) | current | This textual convention is an extension of the pethPsePortGroupIndex convention from the Power Over Ethernet MIB in RFC 3621, which defines a greater-than-zero value used to identify the group containing the port to whi… |
| PethPsePortIndexOrZero | Integer32 (0..2147483647) | current | This textual convention is an extension of the pethPsePortIndex convention, which defines a greater- than-zero value used to identify a power Ethernet Power Sourcing Equipment (PSE) port. This extension permits the addi… |