MIB Viewer

ENTERASYS-RADIUS-AUTH-CLIENT-ENCRYPT-MIB

22 objects
The Enterasys Networks Proprietary MIB module for entities implementing the client side of the Remote Access Dialin User Service (RADIUS) authentication protocol (RFC2865). N O T I C E Use of this MIB in any product requires the approval of the Office of the CTO, Enterasys Networks, Inc. Permission to use this MIB will not be granted for products in which SNMPv3 is now, or will soon be, implemented. Permission to use this MIB in products that are never scheduled to implement SNMPv3 will be granted on a case-by-case basis, depending on what other suitable, secure means of RADIUS client configuration are available in the product. The standard RADIUS Authentication Client MIB (RFC2618) does not have any writable objects, and is missing key objects needed for configuration. Use of this MIB requires encryption/decryption for security during transmission, using SNMPv1. Therefore, there are two separate processes needed to use this MIB. 1) The standard processes for SNMP gets and sets. 2) The encoding/encryption or decryption/decoding of objects. The encryption/decryption algorithm, as presented herein, is taken from the RADIUS protocol, and is the method specified for encryption of Tunnel-Password Attributes in RFC 2868. For a detailed discussion of the encoding/decoding and encryption/decryption of applicable objects, refer to the definition of RadiusEncryptionString defined in the Textual Conventions section of this MIB. Note that the encryption/decryption method makes use of an agreed-upon Secret and an Authenticator which are shared between the RADIUS Client SNMP interface and the management entity implementing the MIB. The reason that the shared secret and authenticator are algorithmically derived in the RADIUS Client / SNMP Agent and in the SNMP Management Station is to permit plug-'n-play remote installation, configuration and management of the device. An object is included to allow remote management of the Authenticator portion of the encryption key. It is suggested that this value be changed by the network administrator after initial configuration of the system. On receipt, the process is reversed to yield the plain-text String.
Imported Objects
ENTERASYS-MIB-NAMESetsysModules
SNMPv2-CONFMODULE-COMPLIANCE OBJECT-GROUP
SNMPv2-SMIMODULE-IDENTITY OBJECT-TYPE
SNMPv2-TCRowStatus TEXTUAL-CONVENTION
OIDNameAccessStatusDescription
1.3.6.1.4.1.5624.1.2.5IdentityetsysRadiusAuthClientEncryptMIBThe Enterasys Networks Proprietary MIB module for entities implementing the client side of the Remote Access Dialin User Service (RADIUS) authentication protoc…
1.3.6.1.4.1.5624.1.2.5.1NodeetsysRadiusAuthClientEncryptMIBObjects
1.3.6.1.4.1.5624.1.2.5.1.1ScalaretsysRadiusAuthClientRetryTimeoutEncryptread-writeobsoleteThe number of seconds to wait for a RADIUS Server to respond to a request. This parameter value is maintained across system reboots. This object's true data ty…
1.3.6.1.4.1.5624.1.2.5.1.2ScalaretsysRadiusAuthClientRetriesEncryptread-writeobsoleteThe number of times to resend an authentication packet if a RADIUS Server does not respond to a request. This parameter value is maintained across system reboo…
1.3.6.1.4.1.5624.1.2.5.1.3ScalaretsysRadiusAuthClientEnableEncryptread-writeobsoleteThis indicates whether or not the RADIUS Client is or is to be, enabled or disabled. This parameter value is maintained across system reboots. This object's tr…
1.3.6.1.4.1.5624.1.2.5.1.4ScalaretsysRadiusAuthClientAuthTypeEncryptread-writeobsoleteThis indicates which method is being used for authentication. The authentication type is an Integer32 object that maps to the following enumeration constants: …
1.3.6.1.4.1.5624.1.2.5.1.5ScalaretsysRadiusAuthClientManageAuthKeyEncryptread-writeobsoleteThe Authenticator used, in part, to form the key to encrypt/decrypt the objects of type RadiusEncryptedString. This object's true data type is OCTET STRING. Th…
1.3.6.1.4.1.5624.1.2.5.1.6TableetsysRadiusAuthServerEncryptTablenot-accessibleobsoleteThe (conceptual) table listing the RADIUS authentication servers with which the client shares a secret.
1.3.6.1.4.1.5624.1.2.5.1.6.1RowetsysRadiusAuthServerEncryptEntrynot-accessibleobsoleteAn entry (conceptual row) representing a RADIUS authentication server with which the client shares a secret. All created conceptual rows are non-volatile and a…
1.3.6.1.4.1.5624.1.2.5.1.6.1.1ColumnetsysRadiusAuthServerIndexEncryptnot-accessibleobsoleteA number uniquely identifying each conceptual row in the etsysRadiusAuthServerEncryptTable. In the event of an agent restart, the same value of etsysRadiusAuth…
1.3.6.1.4.1.5624.1.2.5.1.6.1.2ColumnetsysRadiusAuthClientServerAddressEncryptread-createobsoleteThe dotted-decimal IPv4 address of RADIUS authentication server. This parameter value is maintained across system reboots. This object's true data type is 2, O…
1.3.6.1.4.1.5624.1.2.5.1.6.1.3ColumnetsysRadiusAuthClientServerPortNumberEncryptread-createobsoleteThe UDP port number (0-65535) the client is using to send requests to this server. This parameter value is maintained across system reboots. This object's true…
1.3.6.1.4.1.5624.1.2.5.1.6.1.4ColumnetsysRadiusAuthClientServerSecretEncryptread-createobsoleteThis object is the secret shared between the RADIUS authentication server and RADIUS client. This parameter value is maintained across system reboots. This obj…
1.3.6.1.4.1.5624.1.2.5.1.6.1.5ColumnetsysRadiusAuthClientServerSecretEnteredEncryptread-onlyobsoleteThis object indicates the existence of a shared secret. This object's true data type is 1, Integer32.
1.3.6.1.4.1.5624.1.2.5.1.6.1.6ColumnetsysRadiusAuthClientServerClearTimeEncryptread-createobsoleteThis value indicates the date and time since server counters were last cleared. On a write, the server counters will be cleared and the clear time will be set …
1.3.6.1.4.1.5624.1.2.5.1.6.1.7ColumnetsysRadiusAuthClientServerStatusEncryptread-createobsoleteLets users create and delete RADIUS authentication server entries on systems that support this capability. Rules 1. When creating a RADIUS Authentication Clien…
1.3.6.1.4.1.5624.1.2.5.2NodeetsysRadiusAuthClientEncryptMIBConformance
1.3.6.1.4.1.5624.1.2.5.2.1NodeetsysRadiusAuthClientEncryptMIBCompliances
1.3.6.1.4.1.5624.1.2.5.2.1.1ComplianceetsysRadiusClientEncryptMIBCompliancecurrentThe compliance statement for authentication clients implementing the RADIUS Authentication Client MIB.
1.3.6.1.4.1.5624.1.2.5.2.2NodeetsysRadiusAuthClientEncryptMIBGroups
1.3.6.1.4.1.5624.1.2.5.2.2.1GroupetsysRadiusAuthClientEncryptMIBGroupobsoleteThe basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. This proprietary MIB allows secure SETs to key RADIUS Clie…
Type Definitions
NameSyntaxStatusDescription
RadiusEncryptedStringOCTET STRING (SIZE(0..255))currentBefore encryption, the 'native' objects must be encoded into a formatted Octet String. After decryption, the Octet String must be decoded to obtain the 'native' objects. Fields which contain integers must be in network …