ENTITY-STATE-MIB
24 objects
This MIB defines a state extension to the Entity MIB. Copyright at The Internet Society 2005. This version of this MIB module is part of RFC 4268; see the RFC itself for full legal notices.
Imported Objects
| ENTITY-MIB | entPhysicalIndex |
| SNMPv2-CONF | MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP |
| SNMPv2-SMI | mib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE |
| SNMPv2-TC | DateAndTime TEXTUAL-CONVENTION |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.131 | IdentityentityStateMIB | This MIB defines a state extension to the Entity MIB. Copyright at The Internet Society 2005. This version of this MIB module is part of RFC 4268; see the RFC … | ||
| 1.3.6.1.2.1.131.0 | NodeentStateNotifications | |||
| 1.3.6.1.2.1.131.0.1 | NotificationentStateOperEnabled | current | An entStateOperEnabled notification signifies that the SNMP entity, acting in an agent role, has detected that the entStateOper object for one of its entities … | |
| 1.3.6.1.2.1.131.0.2 | NotificationentStateOperDisabled | current | An entStateOperDisabled notification signifies that the SNMP entity, acting in an agent role, has detected that the entStateOper object for one of its entities… | |
| 1.3.6.1.2.1.131.1 | NodeentStateObjects | |||
| 1.3.6.1.2.1.131.1.1 | TableentStateTable | not-accessible | current | A table of information about state/status of entities. This is a sparse augment of the entPhysicalTable. Entries appear in this table for values of entPhysical… |
| 1.3.6.1.2.1.131.1.1.1 | RowentStateEntry | not-accessible | current | State information about this physical entity. |
| 1.3.6.1.2.1.131.1.1.1.1 | ColumnentStateLastChanged | read-only | current | The value of this object is the date and time when the value of any of entStateAdmin, entStateOper, entStateUsage, entStateAlarm, or entStateStandby changed fo… |
| 1.3.6.1.2.1.131.1.1.1.2 | ColumnentStateAdmin | read-write | current | The administrative state for this entity. This object refers to an entities administrative permission to service both other entities within its containment hie… |
| 1.3.6.1.2.1.131.1.1.1.3 | ColumnentStateOper | read-only | current | The operational state for this entity. Note that unlike the state model used within the Interfaces MIB [RFC 2863], this object does not follow the administrati… |
| 1.3.6.1.2.1.131.1.1.1.4 | ColumnentStateUsage | read-only | current | The usage state for this entity. This object refers to an entity's ability to service more physical entities in a containment hierarchy. A value of 'idle' mean… |
| 1.3.6.1.2.1.131.1.1.1.5 | ColumnentStateAlarm | read-only | current | The alarm status for this entity. It does not include the alarms raised on child components within its containment hierarchy. A value of 'unknown' means that t… |
| 1.3.6.1.2.1.131.1.1.1.6 | ColumnentStateStandby | read-only | current | The standby status for this entity. Some entities will exhibit only a subset of the remaining standby state values. If this entity cannot operate in a standby … |
| 1.3.6.1.2.1.131.2 | NodeentStateConformance | |||
| 1.3.6.1.2.1.131.2.1 | NodeentStateCompliances | |||
| 1.3.6.1.2.1.131.2.1.1 | ComplianceentStateCompliance | read-only | current | The compliance statement for systems supporting the Entity State MIB. |
| 1.3.6.1.2.1.131.2.2 | NodeentStateGroups | |||
| 1.3.6.1.2.1.131.2.2.1 | GroupentStateGroup | current | Standard Entity State group. | |
| 1.3.6.1.2.1.131.2.2.2 | GroupentStateNotificationsGroup | current | Standard Entity State Notification group. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| EntityAdminState | INTEGER { unknown (1), locked (2), shuttingDown (3), unlocked (4) } | current | Represents the various possible administrative states. A value of 'locked' means the resource is administratively prohibited from use. A value of 'shuttingDown' means that usage is administratively limited to current in… |
| EntityAlarmStatus | BITS { unknown (0), underRepair (1), critical(2), major(3), minor(4), warning (5), indeterminate (6) } | current | Represents the possible values of alarm status. An Alarm [RFC 3877] is a persistent indication of an error or warning condition. When no bits of this attribute are set, then no active alarms are known against this entit… |
| EntityOperState | INTEGER { unknown (1), disabled (2), enabled (3), testing (4) } | current | Represents the possible values of operational states. A value of 'disabled' means the resource is totally inoperable. A value of 'enabled' means the resource is partially or fully operable. A value of 'testing' means th… |
| EntityStandbyStatus | INTEGER { unknown (1), hotStandby (2), coldStandby (3), providingService (4) } | current | Represents the possible values of standby status. A value of 'hotStandby' means the resource is not providing service, but it will be immediately able to take over the role of the resource to be backed up, without the n… |
| EntityUsageState | INTEGER { unknown (1), idle (2), active (3), busy (4) } | current | Represents the possible values of usage states. A value of 'idle' means the resource is servicing no users. A value of 'active' means the resource is currently in use and it has sufficient spare capacity to provide for … |