MIB Viewer

ISNS-MIB

207 objects
This module defines management information specific to internet Storage Name Service (iSNS) management. Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4939; see the RFC itself for full legal notices.
Imported Objects
ENTITY-MIB-- From RFC 4133 PhysicalIndex
FC-MGMT-MIB-- From RFC 4044 FcNameIdOrZero FcAddressIdOrZero
INET-ADDRESS-MIB-- From RFC 4001 InetAddressType InetAddress InetPortNumber
SNMP-FRAMEWORK-MIB-- From RFC 3411 SnmpAdminString
SNMPv2-CONF-- From RFC 2580 OBJECT-GROUP MODULE-COMPLIANCE NOTIFICATION-GROUP
SNMPv2-SMI-- From RFC 2578 MODULE-IDENTITY Gauge32 Integer32 mib-2 NOTIFICATION-TYPE OBJECT-TYPE Unsigned32
SNMPv2-TC-- From RFC 2579 TEXTUAL-CONVENTION TimeStamp TruthValue
OIDNameAccessStatusDescription
1.3.6.1.2.1.163IdentityisnsMIBThis module defines management information specific to internet Storage Name Service (iSNS) management. Copyright (C) The IETF Trust (2007). This version of th…
1.3.6.1.2.1.163.0NodeisnsNotifications
1.3.6.1.2.1.163.0.1NotificationisnsServerStartcurrentThis notification is sent when an iSNS Server begins operation. The notification provides the following: isnsInstanceInfo : iSNS Server textual information isn…
1.3.6.1.2.1.163.0.2NotificationisnsServerShutdowncurrentThis notification is sent when an iSNS Server is shutdown. The notification provides the following: isnsInstanceInfo : iSNS Server textual information isnsAddr…
1.3.6.1.2.1.163.1NodeisnsObjects
1.3.6.1.2.1.163.1.1NodeisnsServerInfo
1.3.6.1.2.1.163.1.1.1TableisnsServerTablenot-accessiblecurrentThis table provides a list of the iSNS Server instances that are managed through the same SNMP context.
1.3.6.1.2.1.163.1.1.1.1RowisnsServerEntrynot-accessiblecurrentThis is a row in the iSNS Server instance table. The number of rows is dependent on the number of iSNS Server instances that are being managed through the same…
1.3.6.1.2.1.163.1.1.1.1.1ColumnisnsServerIndexnot-accessiblecurrentThis object uniquely identifies the iSNS Server being managed by the SNMP context and is the key for this table. This is an instance index for each iSNS Server…
1.3.6.1.2.1.163.1.1.1.1.2ColumnisnsServerNameread-onlycurrentA non-unique name that can be assigned to the iSNS Server instance. If not configured, then the string SHALL be zero-length.
1.3.6.1.2.1.163.1.1.1.1.3ColumnisnsServerIsnsVersionread-onlycurrentThe iSNS version value as contained in messages received from the current primary server. The header of each iSNSP message contains the iSNS version of the sen…
1.3.6.1.2.1.163.1.1.1.1.4ColumnisnsServerVendorInforead-onlycurrentIf this server instance is utilizing the product of a particular 'vendor', then this managed object contains that vendor's name and version. Otherwise, the str…
1.3.6.1.2.1.163.1.1.1.1.5ColumnisnsServerPhysicalIndexread-onlycurrentAn index identifying the network interface for this iSNS Server within a network entity. This index maps to the entPhysicalIndex of entPhysicalTable table in R…
1.3.6.1.2.1.163.1.1.1.1.6ColumnisnsServerTcpPortread-onlycurrentIndicates the TCP port this iSNS instance is accepting iSNSP messages on, generally the iSNS well-known port. The well-known TCP port for iSNSP is 3205. If TCP…
1.3.6.1.2.1.163.1.1.1.1.7ColumnisnsServerUdpPortread-onlycurrentIndicates the UDP port this iSNS instance is accepting iSNSP messages on; generally, the iSNS well-known port. The well-known UDP port for iSNSP is 3205. If UD…
1.3.6.1.2.1.163.1.1.1.1.8ColumnisnsServerDiscontinuityTimeread-onlycurrentThe value of sysUpTime on the most recent occasion that this iSNS server became active or suffered a discontinuity.
1.3.6.1.2.1.163.1.1.1.1.9ColumnisnsServerRoleread-onlycurrentThe current operational mode of this iSNS Server instance. Value Description notSet The iSNS Server role is not configured. server The iSNS Server instance is …
1.3.6.1.2.1.163.1.1.1.1.10ColumnisnsServerDiscoveryMethodsEnabledread-onlycurrentIndicates the discovery methods currently enabled for this iSNS Server instance. This allows a client to determine what discovery methods can be used for this …
1.3.6.1.2.1.163.1.1.1.1.11ColumnisnsServerDiscoveryMcGroupTyperead-onlycurrentThe type of Internet address in isnsServerDiscoveryMcGroupAddress. If the address is specified, then it must be a valid multicast address and the value of this…
1.3.6.1.2.1.163.1.1.1.1.12ColumnisnsServerDiscoveryMcGroupAddressread-onlycurrentThe multicast group that iSNS Heartbeat messages are sent to if multicast-based discovery has been enabled for this server instance. If not configured, then th…
1.3.6.1.2.1.163.1.1.1.1.13ColumnisnsServerEsiNonResponseThresholdread-onlycurrentEntity Status Inquiry (ESI) Non-Response Threshold - the number of ESI messages that will be sent without receiving a response before an entity is deregistered…
1.3.6.1.2.1.163.1.1.1.1.14ColumnisnsServerEnableControlNodeMgtScnread-onlycurrentIndicates if the iSNS Server administrative option to send Management SCNs to Control Nodes is enabled. Management SCNs are used by Control Nodes to monitor an…
1.3.6.1.2.1.163.1.1.1.1.15ColumnisnsServerDefaultDdDdsStatusread-onlycurrentThis indicates the Discovery Domain (DD) and Discovery Domain Set (DDS) membership status for a new device when registered in the iSNS Server instance. Either …
1.3.6.1.2.1.163.1.1.1.1.16ColumnisnsServerUpdateDdDdsSupportedread-onlycurrentThe methods that this iSNS Server instance supports to modify Discovery Domains and Discovery Domain Sets.
1.3.6.1.2.1.163.1.1.1.1.17ColumnisnsServerUpdateDdDdsEnabledread-onlycurrentThis indicates the methods this server instance currently allows for modifying Discovery Domains and Discovery Domain Sets.
1.3.6.1.2.1.163.1.1.2TableisnsNumObjectsTablenot-accessiblecurrentTable providing the number of registered objects of each type in the iSNS Server instance. The number of entries is dependent upon the number of iSNS Server in…
1.3.6.1.2.1.163.1.1.2.1RowisnsNumObjectsEntrynot-accessiblecurrentEntry of an iSNS Server instance.
1.3.6.1.2.1.163.1.1.2.1.1ColumnisnsNumDdsread-onlycurrentThe current total number of Discovery Domain Sets in this iSNS instance. This is the number of rows in the isnsDdsTable.
1.3.6.1.2.1.163.1.1.2.1.2ColumnisnsNumDdread-onlycurrentThe current total number of Discovery Domains in this iSNS instance. This is the number of rows in the isnsDdTable.
1.3.6.1.2.1.163.1.1.2.1.3ColumnisnsNumEntitiesread-onlycurrentThe current number of Entities registered in this iSNS Server instance. This is the number of rows in the isnsRegEntityTable for this instance.
1.3.6.1.2.1.163.1.1.2.1.4ColumnisnsNumPortalsread-onlycurrentThe current total number of Portals registered in iSNS. This is the number of rows in isnsRegPortalTable.
1.3.6.1.2.1.163.1.1.2.1.5ColumnisnsNumPortalGroupsread-onlycurrentThe current total number of Portal Groups registered in iSNS. This is the number of rows in isnsRegPgTable.
1.3.6.1.2.1.163.1.1.2.1.6ColumnisnsNumIscsiNodesread-onlycurrentThe current total number of iSCSI node entries registered in the iSNS. This is the number rows in isnsRegIscsiNodeTable.
1.3.6.1.2.1.163.1.1.2.1.7ColumnisnsNumFcPortsread-onlycurrentThe current total number of FC Port entries registered in the iSNS. This is the number of rows in isnsRegFcPortTable.
1.3.6.1.2.1.163.1.1.2.1.8ColumnisnsNumFcNodesread-onlycurrentThe current total number of FC node entries registered in the iSNS. This is the number of rows in isnsRegFcNodeTable.
1.3.6.1.2.1.163.1.1.3NodeisnsControlNodeInfo
1.3.6.1.2.1.163.1.1.3.1TableisnsControlNodeIscsiTablenot-accessiblecurrentSpecified iSCSI Nodes that can register or are registered as control nodes. The number of rows is dependent on the number of iSCSI Control Nodes.
1.3.6.1.2.1.163.1.1.3.1.1RowisnsControlNodeIscsiEntrynot-accessiblecurrentThis is an iSCSI Control Node entry for a specific iSNS server instance.
1.3.6.1.2.1.163.1.1.3.1.1.1ColumnisnsControlNodeIscsiNodeIndexnot-accessiblecurrentThe index for the iSCSI storage node authorized to act as a control node.
1.3.6.1.2.1.163.1.1.3.1.1.2ColumnisnsControlNodeIscsiNodeNameread-onlycurrentThe iSCSI Name of the initiator or target associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS Server internal maximum si…
1.3.6.1.2.1.163.1.1.3.1.1.3ColumnisnsControlNodeIscsiIsRegisteredread-onlycurrentIndicates whether the control node is currently registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.3.1.1.4ColumnisnsControlNodeIscsiRcvMgtSCNread-onlycurrentIndicates whether the Control Node has registered to receive Management SCNs. Management SCNs are sent to a Control Node if they are enabled, as indicated by i…
1.3.6.1.2.1.163.1.1.3.2TableisnsControlNodeFcPortTablenot-accessiblecurrentSpecified FC Ports that can register or are registered as control nodes. The number of rows is dependent on the number of FC Port Control Nodes.
1.3.6.1.2.1.163.1.1.3.2.1RowisnsControlNodeFcPortEntrynot-accessiblecurrentFC Port control node entry.
1.3.6.1.2.1.163.1.1.3.2.1.1ColumnisnsControlNodeFcPortWwpnnot-accessiblecurrentThe FC Port World Wide Port Name that can and/or is acting as a Control Node for the specified iSNS Server. A zero- length string is not valid for this managed…
1.3.6.1.2.1.163.1.1.3.2.1.2ColumnisnsControlNodeFcPortIsRegisteredread-onlycurrentIndicates whether the control node is currently registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.3.2.1.3ColumnisnsControlNodeFcPortRcvMgtSCNread-onlycurrentIndicates whether the Control Node has registered to receive Management SCNs. Management SCNs are sent to a Control Node if they are enabled, as indicated by i…
1.3.6.1.2.1.163.1.1.4NodeisnsDdsInfo
1.3.6.1.2.1.163.1.1.4.1TableisnsDdsTablenot-accessiblecurrentA table containing configuration information for each Discovery Domain Set (DDS) registered in the iSNS Server instance. The number of rows in the table is dep…
1.3.6.1.2.1.163.1.1.4.1.1RowisnsDdsEntrynot-accessiblecurrentInformation on one Discovery Domain Set (DDS) registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.4.1.1.1ColumnisnsDdsIdnot-accessiblecurrentThe ID that refers to this Discovery Domain Set and index to the table.
1.3.6.1.2.1.163.1.1.4.1.1.2ColumnisnsDdsSymbolicNameread-onlycurrentThe Discovery Domain Set Symbolic Name field contains a unique variable-length description (up to 255 bytes) that is associated with the DDS. If a Symbolic Nam…
1.3.6.1.2.1.163.1.1.4.1.1.3ColumnisnsDdsStatusread-onlycurrentThe status of this Discovery Domain Set (DDS).
1.3.6.1.2.1.163.1.1.4.2TableisnsDdsMemberTablenot-accessiblecurrentA table containing Discovery Domains (DDs) that have been assigned to specific Discovery Domain Sets (DDSs). The number of rows in the table is dependent on th…
1.3.6.1.2.1.163.1.1.4.2.1RowisnsDdsMemberEntrynot-accessiblecurrentThe mapping of one Discovery Domain (DD) to a Discovery Domain Set (DDS). This indicates the DD is a member of the DDS.
1.3.6.1.2.1.163.1.1.4.2.1.1ColumnisnsDdsMemberDdIdnot-accessiblecurrentThe ID that identifies the Discovery Domain that is a member of the Discovery Domain Set.
1.3.6.1.2.1.163.1.1.4.2.1.2ColumnisnsDdsMemberSymbolicNameread-onlycurrentThe Symbolic Name of the Discovery Domain that is a member of this DDS. This value SHALL be identical to the object isnsDdSymbolicName for the associated DD ID.
1.3.6.1.2.1.163.1.1.5NodeisnsDdInfo
1.3.6.1.2.1.163.1.1.5.1TableisnsDdTablenot-accessiblecurrentA table containing configuration information for each Discovery Domain (DD) registered in the iSNS. The number of rows in the table is dependent on the number …
1.3.6.1.2.1.163.1.1.5.1.1RowisnsDdEntrynot-accessiblecurrentInformation on a Discovery Domain (DD) registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.5.1.1.1ColumnisnsDdIdnot-accessiblecurrentThe ID that refers to this Discovery Domain, and the index to the table.
1.3.6.1.2.1.163.1.1.5.1.1.2ColumnisnsDdSymbolicNameread-onlycurrentThe Discovery Domain Symbolic Name field contains a unique variable-length description (up to 255 bytes) that is associated with the DD.
1.3.6.1.2.1.163.1.1.5.1.1.3ColumnisnsDdFeaturesread-onlycurrentThis defines the features the Discovery Domain has.
1.3.6.1.2.1.163.1.1.5.2TableisnsDdIscsiMemberTablenot-accessiblecurrentA table containing iSCSI node indexes that have been assigned to specific DDs in this iSNS Server instance. The number of rows in the table is dependent on the…
1.3.6.1.2.1.163.1.1.5.2.1RowisnsDdIscsiMemberEntrynot-accessiblecurrentThe mapping of one iSCSI Node to a Discovery Domain to indicate membership in the DD. The indexes are the iSNS server instance, the DD ID of the Discovery Doma…
1.3.6.1.2.1.163.1.1.5.2.1.1ColumnisnsDdIscsiMemberIndexnot-accessiblecurrentThe index for this member iSCSI node entry.
1.3.6.1.2.1.163.1.1.5.2.1.2ColumnisnsDdIscsiMemberNameread-onlycurrentThe iSCSI Name associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS server internal maximum size is 224 bytes to provide …
1.3.6.1.2.1.163.1.1.5.2.1.3ColumnisnsDdIscsiMemberIsRegisteredread-onlycurrentThis indicates whether this member of the DD is currently registered in the iSNS Server instance. iSCSI Storage Node members do not need to be currently regist…
1.3.6.1.2.1.163.1.1.5.3TableisnsDdPortalMemberTablenot-accessiblecurrentA table containing currently registered and unregistered portal objects that have been explicitly assigned to specific DDs. Explicit assignment of a portal to …
1.3.6.1.2.1.163.1.1.5.3.1RowisnsDdPortalMemberEntrynot-accessiblecurrentEach entry indicates an explicit addition of a portal to a discovery domain. The explicit addition of an entity portal to a discovery domain indicates the port…
1.3.6.1.2.1.163.1.1.5.3.1.1ColumnisnsDdPortalMemberIndexnot-accessiblecurrentThe index for a portal explicitly contained in the discovery domain. This managed object, combined with isnsServerIndex and isnsDdId, is the key for this table.
1.3.6.1.2.1.163.1.1.5.3.1.2ColumnisnsDdPortalMemberAddressTyperead-onlycurrentThe type of Inet address in isnsDdPortalMemberAddress. If the address is specified, then it must be a valid unicast address and the value of this object must b…
1.3.6.1.2.1.163.1.1.5.3.1.3ColumnisnsDdPortalMemberAddressread-onlycurrentThe Inet Address for the portal. The format of this object is specified by isnsDdPortalMemberAddressType.
1.3.6.1.2.1.163.1.1.5.3.1.4ColumnisnsDdPortalMemberPortTyperead-onlycurrentThe port type for the portal, either UDP or TCP.
1.3.6.1.2.1.163.1.1.5.3.1.5ColumnisnsDdPortalMemberPortread-onlycurrentThe port number for the portal. Whether the portal type is TCP or UDP is indicated by isnsDdPortalMemberPortType.
1.3.6.1.2.1.163.1.1.5.3.1.6ColumnisnsDdPortalMemberIsRegisteredread-onlycurrentThis indicates whether this member of the DD is currently registered in the iSNS Server instance. Portals that are DD members do not need to be currently regis…
1.3.6.1.2.1.163.1.1.5.4TableisnsDdFcPortMemberTablenot-accessiblecurrentA table containing FC Port World Wide Names (WWN) that have been assigned to specific DDs. The number of rows in the table is dependent on the number of relati…
1.3.6.1.2.1.163.1.1.5.4.1RowisnsDdFcPortMemberEntrynot-accessiblecurrentThe association of one FC Port with a Discovery Domain. Membership of an FC Port in a Discovery Domain is indicated by creating a row for the appropriate DD ID…
1.3.6.1.2.1.163.1.1.5.4.1.1ColumnisnsDdFcPortMemberPortNamenot-accessiblecurrentThe Port WWN of the FC Port that is a member of the DD. The value MUST be a valid FC WWN, as per the FC-GS (Fibre Channel - Generic Services) standard. This ma…
1.3.6.1.2.1.163.1.1.5.4.1.2ColumnisnsDdFcPortMemberIsRegisteredread-onlycurrentThis indicates whether this member of the DD is currently registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.6NodeisnsReg
1.3.6.1.2.1.163.1.1.6.1NodeisnsRegEntityInfo
1.3.6.1.2.1.163.1.1.6.1.1TableisnsRegEntityTablenot-accessiblecurrentA table containing registered Entity objects in each iSNS server instance. The number of entries in the table is dependent on the number of Entity objects regi…
1.3.6.1.2.1.163.1.1.6.1.1.1RowisnsRegEntityEntrynot-accessiblecurrentInformation on one registered Entity object in an iSNS server instance.
1.3.6.1.2.1.163.1.1.6.1.1.1.1ColumnisnsRegEntityIndexnot-accessiblecurrentThe Entity Index for this entity. This index is assigned by the iSNS Server when an Entity is initially registered. The Entity Index can be used to represent a…
1.3.6.1.2.1.163.1.1.6.1.1.1.2ColumnisnsRegEntityEIDread-onlycurrentThe EID is a unique registered Entity object identifier, as specified in the iSNS Specification. This is the iSNS Entity Identifier for the registered Entity o…
1.3.6.1.2.1.163.1.1.6.1.1.1.3ColumnisnsRegEntityProtocolread-onlycurrentThe block storage protocol supported by this entity, as defined in the iSNS Specification, Section 6.2.2. The following values are initially assigned. Type Val…
1.3.6.1.2.1.163.1.1.6.1.1.1.4ColumnisnsRegEntityManagementAddressTyperead-onlycurrentThe type of Inet address in isnsRegEntityManagementAddress. If the address is specified, then it must be a valid unicast address and the value of this object m…
1.3.6.1.2.1.163.1.1.6.1.1.1.5ColumnisnsRegEntityManagementAddressread-onlycurrentThe iSNS Management IP Address for the registered Entity object. The format of this object is specified by isnsRegEntityManagementAddressType.
1.3.6.1.2.1.163.1.1.6.1.1.1.6ColumnisnsRegEntityTimestampread-onlycurrentThe iSNS Entity Registration Timestamp for the registered Entity object. This is the most recent date and time that the registered Entity object, and associate…
1.3.6.1.2.1.163.1.1.6.1.1.1.7ColumnisnsRegEntityVersionMinread-onlycurrentThe minimum version supported for the block storage protocol specified by isnsRegEntityProtocol. The protocol version specified can be from 1 to 254. A value o…
1.3.6.1.2.1.163.1.1.6.1.1.1.8ColumnisnsRegEntityVersionMaxread-onlycurrentThe maximum version supported for the block storage protocol specified by isnsRegEntityProtocol. The protocol version specified can be from 1 to 254. A value o…
1.3.6.1.2.1.163.1.1.6.1.1.1.9ColumnisnsRegEntityRegistrationPeriodread-onlycurrentThe iSNS Entity Status Inquiry (ESI) registration period, which indicates the maximum time, in seconds, that the registration will be maintained without receip…
1.3.6.1.2.1.163.1.1.6.1.2TableisnsRegEntityNumObjectsTablenot-accessiblecurrentA table containing information on the number of registered objects associated with a registered Entity in the iSNS server instance. The number of entries in th…
1.3.6.1.2.1.163.1.1.6.1.2.1RowisnsRegEntityNumObjectsEntrynot-accessiblecurrentInformation on the number of registered objects associated with a registered Entity object in an iSNS Server instance.
1.3.6.1.2.1.163.1.1.6.1.2.1.1ColumnisnsRegEntityInfoNumPortalsread-onlycurrentThe number of Portals associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.2ColumnisnsRegEntityInfoNumPortalGroupsread-onlycurrentThe number of Portal Groups associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.3ColumnisnsRegEntityInfoNumIscsiNodesread-onlycurrentThe number of iSCSI Storage Nodes associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.4ColumnisnsRegEntityInfoNumFcPortsread-onlycurrentThe number of FC Ports associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.5ColumnisnsRegEntityInfoNumFcNodesread-onlycurrentThe number of FC Nodes associated with this Entity.
1.3.6.1.2.1.163.1.1.6.2NodeisnsRegPortalInfo
1.3.6.1.2.1.163.1.1.6.2.1TableisnsRegPortalTablenot-accessiblecurrentA table containing the registered Portals in the iSNS. The number of entries is dependent on the number of Portals registered in the iSNS.
1.3.6.1.2.1.163.1.1.6.2.1.1RowisnsRegPortalEntrynot-accessiblecurrentInformation on one registered Entity Portal in the iSNS. The Entity Index is part of the table index to quickly find Portals that support a specific Entity.
1.3.6.1.2.1.163.1.1.6.2.1.1.1ColumnisnsRegPortalPortalIndexnot-accessiblecurrentThe index for this Entity Portal.
1.3.6.1.2.1.163.1.1.6.2.1.1.2ColumnisnsRegPortalAddressTyperead-onlycurrentThe type of Inet address in isnsRegPortalAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv…
1.3.6.1.2.1.163.1.1.6.2.1.1.3ColumnisnsRegPortalAddressread-onlycurrentThe Inet Address for this Portal as defined in the iSNS Specification, RFC 4171. The format of this object is specified by isnsRegPortalAddressType.
1.3.6.1.2.1.163.1.1.6.2.1.1.4ColumnisnsRegPortalPortTyperead-onlycurrentThe port type for this Portal, either UDP or TCP, as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.2.1.1.5ColumnisnsRegPortalPortread-onlycurrentThe port number for this Portal as defined in the iSNS Specification, RFC 4171. Whether the Portal type is TCP or UDP is indicated by isnsRegPortalPortType.
1.3.6.1.2.1.163.1.1.6.2.1.1.6ColumnisnsRegPortalSymbolicNameread-onlycurrentThe Symbolic Name for this Portal as defined in the iSNS Specification, RFC 4171. If not provided, then the string SHALL be zero-length.
1.3.6.1.2.1.163.1.1.6.2.1.1.7ColumnisnsRegPortalEsiIntervalread-onlycurrentThe Entity Status Inquiry (ESI) Interval for this Portal as defined in the iSNS Specification, RFC 4171. A value of 0 indicates that ESI monitoring has not bee…
1.3.6.1.2.1.163.1.1.6.2.1.1.8ColumnisnsRegPortalEsiPortTyperead-onlycurrentThe port type for the ESI Port, either UDP or TCP, as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.2.1.1.9ColumnisnsRegPortalEsiPortread-onlycurrentThe TCP or UDP port number used for ESI monitoring. Whether the port type is TCP or UDP is indicated by isnsRegPortalEsiPortType. A value of 0 indicates that E…
1.3.6.1.2.1.163.1.1.6.2.1.1.10ColumnisnsRegPortalScnPortTyperead-onlycurrentThe port type for the SCN Port, either UDP or TCP, as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.2.1.1.11ColumnisnsRegPortalScnPortread-onlycurrentThe TCP or UDP port used to receive SCN messages from the iSNS Server. Whether the port type is TCP or UDP is indicated by isnsRegPortalScnPortType. A value of…
1.3.6.1.2.1.163.1.1.6.2.1.1.12ColumnisnsRegPortalSecurityInforead-onlycurrentIndicates security attribute settings for the Portal as registered in the iSNS server. The bit for bitmapVALID must be set in order for this attribute to conta…
1.3.6.1.2.1.163.1.1.6.3NodeisnsRegPortalGroupInfo
1.3.6.1.2.1.163.1.1.6.3.1TableisnsRegPgTablenot-accessiblecurrentA table containing the registered Portal Groups (PGs) in the iSNS Server instance. The number of entries is dependent on the number of Portal Groups registered…
1.3.6.1.2.1.163.1.1.6.3.1.1RowisnsRegPgEntrynot-accessiblecurrentInformation on one registered Portal Group in the iSNS server instance. The Entity Index is part of the table index to quickly find Portal Groups that support …
1.3.6.1.2.1.163.1.1.6.3.1.1.1ColumnisnsRegPgIndexnot-accessiblecurrentThe PG Index for this node. The index is created by the iSNS Server instance for uniquely identifying registered objects. The PG object is registered at the sa…
1.3.6.1.2.1.163.1.1.6.3.1.1.2ColumnisnsRegPgIscsiNodeIndexread-onlycurrentThe index for the iSCSI Node associated with this PG. This index can be used to reference the isnsRegIscsiNodeTable.
1.3.6.1.2.1.163.1.1.6.3.1.1.3ColumnisnsRegPgIscsiNameread-onlycurrentThe iSCSI Name of the initiator or target associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS Server internal maximum si…
1.3.6.1.2.1.163.1.1.6.3.1.1.4ColumnisnsRegPgPortalPortalIndexread-onlycurrentThe Portal Index for the Portal associated with this PG. This index can be used to reference the isnsRegPortalTable.
1.3.6.1.2.1.163.1.1.6.3.1.1.5ColumnisnsRegPgPortalAddressTyperead-onlycurrentThe type of Inet address in isnsRegPgPortalAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be i…
1.3.6.1.2.1.163.1.1.6.3.1.1.6ColumnisnsRegPgPortalAddressread-onlycurrentThe Inet Address for the Portal that is associated with the PG. The format of this object is specified by isnsRegPgPortalAddressType.
1.3.6.1.2.1.163.1.1.6.3.1.1.7ColumnisnsRegPgPortalPortTyperead-onlycurrentThe port type, either UDP or TCP, for the Portal that is associated with this registered PG object.
1.3.6.1.2.1.163.1.1.6.3.1.1.8ColumnisnsRegPgPortalPortread-onlycurrentThe port number for the Portal that is associated with this registered PG object. Whether the Portal type is TCP or UDP is indicated by isnsRegPgPortalPortType.
1.3.6.1.2.1.163.1.1.6.3.1.1.9ColumnisnsRegPgPGTread-onlycurrentThe Portal Group Tag (PGT) for the registered iSCSI Portal Group object in an iSNS Server instance. This indicates the tag value that the Portal uses for acces…
1.3.6.1.2.1.163.1.1.6.4NodeisnsRegIscsiNodeInfo
1.3.6.1.2.1.163.1.1.6.4.1TableisnsRegIscsiNodeTablenot-accessiblecurrentA table containing the registered iSCSI Nodes in the iSNS server instance. Storage devices register using the iSNS protocol. While a device cannot be registere…
1.3.6.1.2.1.163.1.1.6.4.1.1RowisnsRegIscsiNodeEntrynot-accessiblecurrentInformation on one iSCSI node that has been registered in the iSNS Server instance. New rows cannot be added using SNMP.
1.3.6.1.2.1.163.1.1.6.4.1.1.1ColumnisnsRegIscsiNodeIndexnot-accessiblecurrentThe index for this iSCSI node.
1.3.6.1.2.1.163.1.1.6.4.1.1.2ColumnisnsRegIscsiNodeNameread-onlycurrentThe iSCSI Name of the initiator or target associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS Server internal maximum si…
1.3.6.1.2.1.163.1.1.6.4.1.1.3ColumnisnsRegIscsiNodeTyperead-onlycurrentThe Node Type defining the functions of this iSCSI node.
1.3.6.1.2.1.163.1.1.6.4.1.1.4ColumnisnsRegIscsiNodeAliasread-onlycurrentThe Alias name of the iSCSI node. This is a variable-length text-based description of up to 255 bytes.
1.3.6.1.2.1.163.1.1.6.4.1.1.5ColumnisnsRegIscsiNodeScnTypesread-onlycurrentThe State Change Notification (SCN) types enabled for this iSCSI node.
1.3.6.1.2.1.163.1.1.6.4.1.1.6ColumnisnsRegIscsiNodeWwnTokenread-onlycurrentThis contains a globally unique 64-bit integer value that can be used to represent the World Wide Node Name of the iSCSI device in a Fibre Channel fabric. This…
1.3.6.1.2.1.163.1.1.6.4.1.1.7ColumnisnsRegIscsiNodeAuthMethodread-onlycurrentThis attribute contains a null-terminated string containing UTF-8 text listing the iSCSI authentication methods enabled for this iSCSI Node, in order of prefer…
1.3.6.1.2.1.163.1.1.6.5NodeisnsRegFcNodeInfo
1.3.6.1.2.1.163.1.1.6.5.1TableisnsRegFcNodeTablenot-accessiblecurrentA table containing the registered FC Nodes in the iSNS. This supports iFCP as defined in RFC 4172.
1.3.6.1.2.1.163.1.1.6.5.1.1RowisnsRegFcNodeEntrynot-accessiblecurrentInformation on one registered FC node that has been registered in the iSNS.
1.3.6.1.2.1.163.1.1.6.5.1.1.1ColumnisnsRegFcNodeWwnnnot-accessiblecurrentThe FC Node World Wide Node Name as defined in the iSNS Specification, RFC 4171. A zero-length string is not valid for this managed object.
1.3.6.1.2.1.163.1.1.6.5.1.1.2ColumnisnsRegFcNodeSymbolicNameread-onlycurrentThe FC Node Symbolic Name of the node as defined in the iSNS Specification, RFC 4171. This is a variable-length text-based description. If not provided, then t…
1.3.6.1.2.1.163.1.1.6.5.1.1.3ColumnisnsRegFcNodeAddressTyperead-onlycurrentThe type of Inet address in isnsRegFcNodeAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv…
1.3.6.1.2.1.163.1.1.6.5.1.1.4ColumnisnsRegFcNodeAddressread-onlycurrentThe FC Node Inet address of the node as defined in the iSNS Specification, RFC 4171. The format of this object is specified by isnsRegFcNodeAddressType.
1.3.6.1.2.1.163.1.1.6.5.1.1.5ColumnisnsRegFcNodeIPAread-onlycurrentThis managed object identifies the FC Initial Process Associator of the node as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.1.1.6ColumnisnsRegFcNodeProxyIscsiNameread-onlycurrentThe iSCSI Name used to represent the FC Node in the IP network. It is used as a pointer to the matching iSCSI Name entry in the iSNS Server. Its value is usual…
1.3.6.1.2.1.163.1.1.6.5.1.1.7ColumnisnsRegFcNodeNumFcPortsread-onlycurrentThe number of FC Ports associated with this FC Node.
1.3.6.1.2.1.163.1.1.6.5.2TableisnsRegFcPortTablenot-accessiblecurrentInformation on registered FC N_Ports in the iSNS. FC Ports are associated with registered FC Nodes. This supports iFCP as defined in RFC 4172.
1.3.6.1.2.1.163.1.1.6.5.2.1RowisnsRegFcPortEntrynot-accessiblecurrentInformation on one FC Port that has been registered in iSNS.
1.3.6.1.2.1.163.1.1.6.5.2.1.1ColumnisnsRegFcPortWwpnnot-accessiblecurrentThe FC Port's World Wide Port Name as defined in the iSNS Specification, RFC 4171. A zero-length string is not valid for this managed object.
1.3.6.1.2.1.163.1.1.6.5.2.1.2ColumnisnsRegFcPortIDread-onlycurrentThe FC Port's Port ID as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.3ColumnisnsRegFcPortTyperead-onlycurrentThe FC Port Type as defined in the iSNS Specification, RFC 4171, and the Fibre Channel Generic Services Specification. Current values are as shown below: unkno…
1.3.6.1.2.1.163.1.1.6.5.2.1.4ColumnisnsRegFcPortSymbolicNameread-onlycurrentThe FC Port Symbolic Name as defined in the iSNS Specification, RFC 4171. If not provided, then the string SHALL be zero-length.
1.3.6.1.2.1.163.1.1.6.5.2.1.5ColumnisnsRegFcPortFabricPortWwnread-onlycurrentThe Fabric Port WWN for this entry as defined in the iSNS Specification, RFC 4171. A zero-length string for this managed object indicates that the Fabric Port …
1.3.6.1.2.1.163.1.1.6.5.2.1.6ColumnisnsRegFcPortHAread-onlycurrentThe FC Port Hard Address as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.7ColumnisnsRegFcPortAddressTyperead-onlycurrentThe type of Inet address in isnsRegFcPortAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv…
1.3.6.1.2.1.163.1.1.6.5.2.1.8ColumnisnsRegFcPortAddressread-onlycurrentThe FC Port Inet Address as defined in the iSNS Specification, RFC 4171. The format of this object is specified by isnsRegFcPortAddressType.
1.3.6.1.2.1.163.1.1.6.5.2.1.9ColumnisnsRegFcPortFcCosread-onlycurrentThe FC Port Class of Service as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.10ColumnisnsRegFcPortFc4Typesread-onlycurrentThe FC Port FC-4 Types as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.11ColumnisnsRegFcPortFc4Descrread-onlycurrentThe FC Port FC-4 Descriptor as defined in the iSNS Specification, RFC 4171. The FC-4 Descriptor cannot be longer than 255 bytes. The iSNS Server internal maxim…
1.3.6.1.2.1.163.1.1.6.5.2.1.12ColumnisnsRegFcPortFc4Featuresread-onlycurrentThe FC Port FC-4 Features as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.13ColumnisnsRegFcPortScnTypesread-onlycurrentThe iFCP State Change Notification (SCN) types enabled for the registered object.
1.3.6.1.2.1.163.1.1.6.5.2.1.14ColumnisnsRegFcPortRoleread-onlycurrentThe FC Port Role defines the role of the registered object.
1.3.6.1.2.1.163.1.1.6.5.2.1.15ColumnisnsRegFcPortFcNodeWwnnread-onlycurrentThe FC Node World Wide Node Name that is associated with this FC Port as defined in the iSNS Specification, RFC 4171. This managed object may contain a zero-le…
1.3.6.1.2.1.163.1.1.6.5.2.1.16ColumnisnsRegFcPortPpnWwnread-onlycurrentThe Permanent Port Name (PPN) attribute is the FC Port Name WWPN of the first Storage Node registered in the iSNS Database that is associated with a particular…
1.3.6.1.2.1.163.1.1.6.5.3TableisnsRegFcNodePortTablenot-accessiblecurrentA table containing the mapping of a registered FC Node and associated registered iFCP Port to the supporting registered Entity object in an iSNS Server instanc…
1.3.6.1.2.1.163.1.1.6.5.3.1RowisnsRegFcNodePortEntrynot-accessiblecurrentInformation on one mapping from an FC Node and iFCP Port to an Entity object registered in an iSNS.
1.3.6.1.2.1.163.1.1.6.5.3.1.1ColumnisnsRegFcNodePortEntityIndexread-onlycurrentThe Entity Index for the registered Entity object associated with the FC Port and FC Node. This managed object may contain the value of zero prior to a device …
1.3.6.1.2.1.163.1.2NodeisnsNotificationsInfo
1.3.6.1.2.1.163.1.2.1ScalarisnsInstanceInfoaccessible-for-notifycurrentTextual information about the notification event and the iSNS Server generating the notification. An example is: iSNS Server Started.
1.3.6.1.2.1.163.1.2.2ScalarisnsAddressNotificationTypeaccessible-for-notifycurrentThe type of Inet address in isnsAddressNotification. If the address is specified, then it must be a valid unicast address and the value of this object must be …
1.3.6.1.2.1.163.1.2.3ScalarisnsAddressNotificationaccessible-for-notifycurrentIdentifies the IP address of the iSNS Server. The format of this object is specified by isnsAddressNotificationType. The IP address will always be specified in…
1.3.6.1.2.1.163.1.2.4ScalarisnsTcpPortNotificationaccessible-for-notifycurrentIndicates the TCP port the iSNS Server is using, or 0 if TCP-based registrations are not supported.
1.3.6.1.2.1.163.1.2.5ScalarisnsUdpPortNotificationaccessible-for-notifycurrentIndicates the UDP port the iSNS Server is using, or 0 if UDP-based registrations are not supported.
1.3.6.1.2.1.163.2NodeisnsConformance
1.3.6.1.2.1.163.2.1NodeisnsCompliances
1.3.6.1.2.1.163.2.1.1ComplianceisnsIscsiServerCompliancecurrentInitial compliance statement for an iSNS Server providing support to iSCSI clients.
1.3.6.1.2.1.163.2.1.2ComplianceisnsIfcpServerCompliancecurrentInitial compliance statement for an iSNS Server providing support to iFCP Clients.
1.3.6.1.2.1.163.2.2NodeisnsGroups
1.3.6.1.2.1.163.2.2.1GroupisnsServerAttributesGroupcurrentiSNS Server attributes.
1.3.6.1.2.1.163.2.2.2GroupisnsServerNumObjectsGroupcurrentManaged objects indicating the number of registered objects in an iSNS Server or the number of registered objects associated with a registered Entity. These ma…
1.3.6.1.2.1.163.2.2.3GroupisnsServerIscsiControlNodeGroupcurrentiSNS Server iSCSI control node managed objects.
1.3.6.1.2.1.163.2.2.4GroupisnsServerIfcpPortControlNodeGroupcurrentiSNS Server iFCP Port control node managed objects.
1.3.6.1.2.1.163.2.2.5GroupisnsServerIscsiDdsDdObjGroupcurrentiSNS Server DDS and DD managed objects for iSCSI.
1.3.6.1.2.1.163.2.2.6GroupisnsServerIfcpDdsDdObjGroupcurrentiSNS Server DDS and DD managed objects for iFCP.
1.3.6.1.2.1.163.2.2.7GroupisnsServerRegIscsiObjGroupcurrentiSNS Server registered iSCSI managed objects.
1.3.6.1.2.1.163.2.2.8GroupisnsServerRegIfcpObjGroupcurrentiSNS Server registered iFCP managed objects.
1.3.6.1.2.1.163.2.2.9GroupisnsNotificationsObjGroupcurrentiSNS Notification managed objects.
1.3.6.1.2.1.163.2.2.10GroupisnsServerNotificationGroupcurrentiSNS Server Notification managed objects.
Type Definitions
NameSyntaxStatusDescription
IsnsDdDdsModificationTypeBITS { controlNode(0), targetIscsiNode(1), initiatorIscsiNode(2), targetIfcpNode(3), initiatorIfcpNode(4) }currentThe methods that can be used to modify the Discovery Domain and Discovery Domain Sets in an iSNS Server instance. Bit Flag Description 0 Control Nodes are allowed 1 Target iSCSI Nodes are allowed 2 Initiator iSCSI Nodes…
IsnsDdFeatureTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), reserved24(24), reserved25(25), reserved26(26), reserved27(27), reserved28(28), reserved29(29), reserved30(30), bootlist(31) }currentThis type defines the features that each Discovery Domain (DD) has. Bit Status 31 Boot List All others RESERVED Boot List: this feature indicates that the targets in this DD provide boot capabilities for the member init…
IsnsDdsStatusTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), reserved24(24), reserved25(25), reserved26(26), reserved27(27), reserved28(28), reserved29(29), reserved30(30), ddsEnabled (31) }currentThe status of a Discovery Domain Set (DDS) registered in the iSNS. The initially assigned values are below: Bit Status 31 DDS Enabled All others RESERVED Setting a bit to 1 indicates the feature is enabled. Otherwise, i…
IsnsDiscoveryDomainIdUnsigned32 ( 1 .. 4294967295 )currentThe unique Discovery Domain Identifier (DD_ID) associated with each Discovery Domain (DD). This is used to uniquely index and reference a DD.
IsnsDiscoveryDomainSetIdUnsigned32 ( 1 .. 4294967295 )currentThe unique Discovery Domain Set Identifier associated with a Discovery Domain Set (DDS).
IsnsEntityIndexIdOrZeroUnsigned32 ( 0 .. 4294967295 )currentThe identifier for the unique integer Entity Index associated with an iSNS registered Entity object, and the value zero. The value zero is object-specific and MUST therefore be defined as part of the description of any …
IsnsFcClassOfServiceTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), reserved24(24), reserved25(25), reserved26(26), reserved27(27), class3(28), class2(29) }currentThis defines the Fibre Channel Class of Service types that are supported by the registered port. The definitions are as defined in RFC 4171. Bit FC COS Type 28 Fibre Channel Class 3 Supported 29 Fibre Channel Class 2 Su…
IsnsFcPortRoleTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), reserved24(24), reserved25(25), reserved26(26), reserved27(27), reserved28(28), control(29), initiator(30), target(31) }currentThe FC Port Role defines the functions of the registered object. The definitions of each setting are defined in RFC 4171. Bit Port Role 29 Control 30 FCP Initiator 31 FCP Target All others RESERVED Setting a bit to 1 in…
IsnsIfcpScnTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), initiatorAndSelfOnly(24), targetAndSelfOnly(25), managementRegistrationScn(26), objectRemoved(27), objectAdded(28), objectUpdated(29), ddOrDdsMemberRemoved(30), ddOrDdsMemberAdded(31) }currentThe iFCP State Change Notification (SCN) values for an iFCP object as defined in RFC 4171. Bit Description 24 Initiator and self information only 25 Target and self information only 26 Management registration/SCN 27 Obj…
IsnsIscsiNodeTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), reserved24(24), reserved25(25), reserved26(26), reserved27(27), reserved28(28), control(29), initiator(30), target(31) }currentThe iSCSI Node Type defines the functions of the registered object. The definitions of each setting are defined in RFC 4171. Bit Node Type 29 Control 30 Initiator 31 Target All others RESERVED Setting a bit to 1 indicat…
IsnsIscsiScnTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), initiatorAndSelfOnly(24), targetAndSelfOnly(25), managementRegistrationScn(26), objectRemoved(27), objectAdded(28), objectUpdated(29), ddOrDdsMemberRemoved(30), ddOrDdsMemberAdded(31) }currentThe iSCSI Node State Change Notification (SCN) values for a node as defined in RFC 4171. Bit Description 24 Initiator and self information only 25 Target and self information only 26 Management registration/SCN 27 Objec…
IsnsNodeIndexIdUnsigned32 ( 1 .. 4294967295 )currentThe identifier for the unique integer Node Index associated with a storage node. This index provides a 1-to-1 mapping to an iSCSI node name. The iSCSI node name maximum length is too long to be used for an index directl…
IsnsPortalGroupIndexIdUnsigned32 ( 1 .. 4294967295 )currentThe identifier for the unique integer Portal Group Index associated with an iSNS registered Portal Group object.
IsnsPortalGroupTagIdOrNullInteger32 ( -1 .. 65535 )currentThe Portal Group Tag (PGT) represents an association between a Portal and iSCSI Node using the value range 0 to 65535. A PGT with no association is a NULL value. The value of -1 indicates a NULL value.
IsnsPortalIndexIdUnsigned32 ( 1 .. 4294967295 )currentThe identifier for the unique integer Portal Index associated with an iSNS registered Portal object. The index is created by the iSNS Server for mapping between registered objects. The Portal Index used for a specific p…
IsnsPortalPortTypeIdINTEGER { udp(1), tcp(2) }currentThe UDP or TCP port type being used by a Portal for an Entity.
IsnsPortalSecurityTypeBITS { reserved0(0), reserved1(1), reserved2(2), reserved3(3), reserved4(4), reserved5(5), reserved6(6), reserved7(7), reserved8(8), reserved9(9), reserved10(10), reserved11(11), reserved12(12), reserved13(13), reserved14(14), reserved15(15), reserved16(16), reserved17(17), reserved18(18), reserved19(19), reserved20(20), reserved21(21), reserved22(22), reserved23(23), reserved24(24), tunnelModePreferred(25), transportModePreferred(26), pfsEnabled(27), agressiveModeEnabled(28), mainModeEnabled(29), ikeIPsecEnabled(30), bitmapVALID(31) }currentIndicates security attribute settings for a Portal that is registered in the iSNS server. The bitmapVALID field must be set in order for the contents to be considered valid information. The definitions of the bit fields…
IsnsSrvrDiscoveryMethodsTypeBITS { dhcp(0), slp(1), multicastGroupHb(2), broadcastHb(3), cfgdServerList(4), other(5) }currentThe types of iSNS Server discovery methods that are enabled on an iSNS Server. The options are DHCP, Service Location Protocol (SLP), multicast group iSNS heartbeat, broadcast group iSNS heartbeat, configured server lis…