NHDP-MIB
122 objects
This NHDP-MIB module is applicable to routers implementing the Neighborhood Discovery Protocol defined in RFC 6130. Copyright (c) 2012 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 6779; see the RFC itself for full legal notices.
Imported Objects
| FLOAT-TC-MIB | -- RFC 2863 Float32TC |
| IF-MIB | -- RFC 4001 InterfaceIndex |
| INET-ADDRESS-MIB | -- RFC 3411 InetAddressType InetAddress InetAddressPrefixLength |
| SNMP-FRAMEWORK-MIB | -- STD 58 SnmpAdminString |
| SNMPv2-CONF | -- RFC 2579 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP |
| SNMPv2-SMI | Counter32 Counter64 Integer32 mib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE TimeTicks Unsigned32 |
| SNMPv2-TC | -- RFC 2578 TEXTUAL-CONVENTION RowStatus TimeStamp TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.213 | IdentitynhdpMIB | This NHDP-MIB module is applicable to routers implementing the Neighborhood Discovery Protocol defined in RFC 6130. Copyright (c) 2012 IETF Trust and the perso… | ||
| 1.3.6.1.2.1.213.0 | NodenhdpNotifications | |||
| 1.3.6.1.2.1.213.0.0 | NodenhdpNotificationsObjects | |||
| 1.3.6.1.2.1.213.0.0.1 | NotificationnhdpNbrStateChange | current | nhdpNbrStateChange is a notification sent when more than nhdpNbrStateChangeThreshold neighbors change their status (i.e., 'down(0)', 'asymmetric(1)', or 'symme… | |
| 1.3.6.1.2.1.213.0.0.2 | Notificationnhdp2HopNbrStateChange | current | nhdp2HopNbrStateChange is a notification sent when more than nhdp2HopNbrStateChangeThreshold 2-hop neighbors change their status (i.e., 'down(0)' or 'up(1)') w… | |
| 1.3.6.1.2.1.213.0.0.3 | NotificationnhdpIfStateChange | current | nhdpIfStateChange is a notification sent when nhdpIfStatus has changed on this interface. | |
| 1.3.6.1.2.1.213.0.1 | NodenhdpNotificationsControl | |||
| 1.3.6.1.2.1.213.0.1.1 | ScalarnhdpNbrStateChangeThreshold | read-write | current | A threshold value for the nhdpNbrStateChange object. If the number of occurrences exceeds this threshold within the previous nhdpNbrStateChangeWindow, then the… |
| 1.3.6.1.2.1.213.0.1.2 | ScalarnhdpNbrStateChangeWindow | read-write | current | A time window for the nhdpNbrStateChange object. If the number of occurrences exceeds the nhdpNbrStateChangeThreshold within the previous nhdpNbrStateChangeWin… |
| 1.3.6.1.2.1.213.0.1.3 | Scalarnhdp2HopNbrStateChangeThreshold | read-write | current | A threshold value for the nhdp2HopNbrStateChange object. If the number of occurrences exceeds this threshold within the previous nhdp2HopNbrStateChangeWindow, … |
| 1.3.6.1.2.1.213.0.1.4 | Scalarnhdp2HopNbrStateChangeWindow | read-write | current | A time window for the nhdp2HopNbrStateChange object. If the number of occurrences exceeds the nhdp2HopNbrStateChangeThreshold within the previous nhdp2HopNbrSt… |
| 1.3.6.1.2.1.213.0.2 | NodenhdpNotificationsStates | |||
| 1.3.6.1.2.1.213.0.2.1 | ScalarnhdpNbrState | read-only | current | NHDP neighbor states. In NHDP, it is not necessary to remove Protocol Tuples from Protocol Sets at the exact time indicated, only to behave as if the Protocol … |
| 1.3.6.1.2.1.213.0.2.2 | Scalarnhdp2HopNbrState | read-only | current | NHDP 2-hop neighbor states. In NHDP, it is not necessary to remove Protocol Tuples from Protocol Sets at the exact time indicated, only to behave as if the Pro… |
| 1.3.6.1.2.1.213.1 | NodenhdpObjects | |||
| 1.3.6.1.2.1.213.1.1 | NodenhdpConfigurationObjGrp | |||
| 1.3.6.1.2.1.213.1.1.1 | TablenhdpInterfaceTable | not-accessible | current | The nhdpInterfaceTable describes the configuration of the interfaces of this router that are intended to use MANET control protocols. As such, this table 'spar… |
| 1.3.6.1.2.1.213.1.1.1.1 | RownhdpInterfaceEntry | not-accessible | current | The nhdpInterfaceEntry describes one NHDP local interface configuration as indexed by its ifIndex as defined in the Standard MIB II Interface Table (RFC 2863).… |
| 1.3.6.1.2.1.213.1.1.1.1.1 | ColumnnhdpIfIndex | not-accessible | current | This value MUST correspond to an ifIndex referring to a valid entry in the Interfaces Table. |
| 1.3.6.1.2.1.213.1.1.1.1.2 | ColumnnhdpIfName | read-only | current | The textual name of the interface. The value of this object SHOULD be the name of the interface as assigned by the local device. This can be a text-name, such … |
| 1.3.6.1.2.1.213.1.1.1.1.3 | ColumnnhdpIfStatus | read-create | current | nhdpIfStatus indicates whether this interface is currently running NHDP. A value of 'true(1)' indicates that NHDP is running on this interface. A value of 'fal… |
| 1.3.6.1.2.1.213.1.1.1.1.4 | ColumnnhdpHelloInterval | read-create | current | nhdpHelloInterval corresponds to HELLO_INTERVAL of NHDP and represents the maximum time between the transmission of two successive HELLO messages on this MANET… |
| 1.3.6.1.2.1.213.1.1.1.1.5 | ColumnnhdpHelloMinInterval | read-create | current | nhdpHelloMinInterval corresponds to HELLO_MIN_INTERVAL of NHDP and represents the minimum interval between transmission of two successive HELLO messages on thi… |
| 1.3.6.1.2.1.213.1.1.1.1.6 | ColumnnhdpRefreshInterval | read-create | current | nhdpRefreshInterval corresponds to REFRESH_INTERVAL of NHDP and represents the maximum interval between advertisements of each 1-hop neighbor network address a… |
| 1.3.6.1.2.1.213.1.1.1.1.7 | ColumnnhdpLHoldTime | read-create | current | nhdpLHoldTime corresponds to L_HOLD_TIME of NHDP and represents the period of advertisement, on this MANET interface, of former 1-hop neighbor network addresse… |
| 1.3.6.1.2.1.213.1.1.1.1.8 | ColumnnhdpHHoldTime | read-create | current | nhdpHHoldTime corresponds to H_HOLD_TIME of NHDP and is used as the value in the VALIDITY_TIME Message TLV included in all HELLO messages on this MANET interfa… |
| 1.3.6.1.2.1.213.1.1.1.1.9 | ColumnnhdpHystAcceptQuality | read-create | current | nhdpHystAcceptQuality corresponds to HYST_ACCEPT of NHDP and represents the link quality threshold at or above which a link becomes usable, if it was not alrea… |
| 1.3.6.1.2.1.213.1.1.1.1.10 | ColumnnhdpHystRejectQuality | read-create | current | nhdpHystRejectQuality corresponds to HYST_REJECT of NHDP and represents the link quality threshold below which a link becomes unusable, if it was not already s… |
| 1.3.6.1.2.1.213.1.1.1.1.11 | ColumnnhdpInitialQuality | read-create | current | nhdpInitialQuality corresponds to INITIAL_QUALITY of NHDP and represents the initial quality of a newly identified link. Guidance for setting this object may b… |
| 1.3.6.1.2.1.213.1.1.1.1.12 | ColumnnhdpInitialPending | read-create | current | nhdpInitialPending corresponds to INITIAL_PENDING of NHDP. If the value of this object is 'true(1)', then a newly identified link is considered pending and is … |
| 1.3.6.1.2.1.213.1.1.1.1.13 | ColumnnhdpHpMaxJitter | read-create | current | nhdpHpMaxJitter corresponds to HP_MAXJITTER of NHDP and represents the value of MAXJITTER used in RFC 5148 for periodically generated HELLO messages on this MA… |
| 1.3.6.1.2.1.213.1.1.1.1.14 | ColumnnhdpHtMaxJitter | read-create | current | nhdpHtMaxJitter corresponds to HT_MAXJITTER of NHDP and represents the value of MAXJITTER used in RFC 5148 for externally triggered HELLO messages on this MANE… |
| 1.3.6.1.2.1.213.1.1.1.1.15 | ColumnnhdpIfRowStatus | read-create | current | This object permits management of the table by facilitating actions such as row creation, construction, and destruction. The value of this object has no effect… |
| 1.3.6.1.2.1.213.1.1.2 | ScalarnhdpNHoldTime | read-write | current | nhdpNHoldTime corresponds to N_HOLD_TIME of NHDP and is used as the period during which former 1-hop neighbor network addresses are advertised as lost in HELLO… |
| 1.3.6.1.2.1.213.1.1.3 | ScalarnhdpIHoldTime | read-write | current | nhdpIHoldTime corresponds to I_HOLD_TIME of NHDP and represents the period for which a recently used local interface network address is recorded. This object i… |
| 1.3.6.1.2.1.213.1.1.4 | TablenhdpLibLocalIfSetTable | not-accessible | current | A router's Local Interface Set records all network addresses that are defined as local MANET interface network addresses. As such, this table 'sparse augments'… |
| 1.3.6.1.2.1.213.1.1.4.1 | RownhdpLibLocalIfSetEntry | not-accessible | current | A router's Local Interface Set consists of Configured Interface Address Tuples for each network interface. The objects in this table are persistent, and when w… |
| 1.3.6.1.2.1.213.1.1.4.1.1 | ColumnnhdpLibLocalIfSetIndex | not-accessible | current | The index for this table. Necessary because multiple addresses may be associated with a given nhdpIfIndex. |
| 1.3.6.1.2.1.213.1.1.4.1.2 | ColumnnhdpLibLocalIfSetIfIndex | read-only | current | Specifies the local nhdpIfIndex for which this IP address was added. |
| 1.3.6.1.2.1.213.1.1.4.1.3 | ColumnnhdpLibLocalIfSetIpAddrType | read-create | current | The type of the nhdpLibLocalIfSetIpAddr in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.213.1.1.4.1.4 | ColumnnhdpLibLocalIfSetIpAddr | read-create | current | nhdpLibLocalIfSetIpAddr is an address of an interface of this router. This object is interpreted according to the setting of nhdpLibLocalIfSetIpAddrType. |
| 1.3.6.1.2.1.213.1.1.4.1.5 | ColumnnhdpLibLocalIfSetIpAddrPrefixLen | read-create | current | Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpLibLocalIfSetIpAddr to determine the address prefix. A row … |
| 1.3.6.1.2.1.213.1.1.4.1.6 | ColumnnhdpLibLocalIfSetRowStatus | read-create | current | This object permits management of the table by facilitating actions such as row creation, construction, and destruction. The value of this object has no effect… |
| 1.3.6.1.2.1.213.1.1.5 | TablenhdpLibRemovedIfAddrSetTable | not-accessible | current | A router's Removed Interface Address Set records network addresses that were recently used as local interface network addresses. If a router's interface networ… |
| 1.3.6.1.2.1.213.1.1.5.1 | RownhdpLibRemovedIfAddrSetEntry | not-accessible | current | A router's Removed Interface Address Set consists of Removed Interface Address Tuples, one per network address: (IR_local_iface_addr, IR_time) The association … |
| 1.3.6.1.2.1.213.1.1.5.1.1 | ColumnnhdpLibRemovedIfAddrSetIndex | not-accessible | current | The index for this table. Necessary because multiple addresses may be associated with a given nhdpIfIndex. |
| 1.3.6.1.2.1.213.1.1.5.1.2 | ColumnnhdpLibRemovedIfAddrSetIpAddrType | read-only | current | The type of the nhdpLibRemovedIfAddrSetIpAddr in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.213.1.1.5.1.3 | ColumnnhdpLibRemovedIfAddrSetIpAddr | read-only | current | nhdpLibRemovedIfAddrSetIpAddr is a recently used address of an interface of this router. |
| 1.3.6.1.2.1.213.1.1.5.1.4 | ColumnnhdpLibRemovedIfAddrSetIpAddrPrefixLen | read-only | current | Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpLibRemovedIfAddrSetIpAddr to determine the address prefix. … |
| 1.3.6.1.2.1.213.1.1.5.1.5 | ColumnnhdpLibRemovedIfAddrSetIfIndex | read-only | current | Specifies the local IfIndex from which this IP address was recently removed. |
| 1.3.6.1.2.1.213.1.1.5.1.6 | ColumnnhdpLibRemovedIfAddrSetIRTime | read-only | current | nhdpLibRemovedIfAddrSetIRTime specifies the value of sysUptime when this entry should expire and be removed from the nhdpLibRemovedIfAddrSetTable. |
| 1.3.6.1.2.1.213.1.2 | NodenhdpStateObjGrp | |||
| 1.3.6.1.2.1.213.1.2.1 | ScalarnhdpUpTime | read-only | current | The value of sysUpTime at the time the current NHDP process was initialized. |
| 1.3.6.1.2.1.213.1.2.2 | TablenhdpInterfaceStateTable | not-accessible | current | nhdpInterfaceStateTable lists state information related to specific interfaces of this router. The value of nhdpIfIndex is an ifIndex from the interfaces group… |
| 1.3.6.1.2.1.213.1.2.2.1 | RownhdpInterfaceStateEntry | not-accessible | current | nhdpInterfaceStateEntry describes one NHDP local interface state as indexed by its nhdpIfIndex. |
| 1.3.6.1.2.1.213.1.2.2.1.1 | ColumnnhdpIfStateUpTime | read-only | current | The value of the sysUpTime when NHDP was last initialized on this MANET interface. |
| 1.3.6.1.2.1.213.1.2.3 | TablenhdpDiscIfSetTable | not-accessible | current | A router's set of discovered interfaces on neighboring routers. |
| 1.3.6.1.2.1.213.1.2.3.1 | RownhdpDiscIfSetEntry | not-accessible | current | The entries include the nhdpDiscRouterIndex of the discovered router, the nhdpDiscIfIndex of the discovered interface, and the current set of addresses associa… |
| 1.3.6.1.2.1.213.1.2.3.1.1 | ColumnnhdpDiscIfSetIndex | not-accessible | current | The index for this table. Necessary because multiple addresses may be associated with a given nhdpDiscIfIndex. |
| 1.3.6.1.2.1.213.1.2.3.1.2 | ColumnnhdpDiscIfIndex | read-only | current | The NHDP interface index (locally created) of a neighbor's interface. Used for cross- indexing into other NHDP tables and other MIB modules. |
| 1.3.6.1.2.1.213.1.2.3.1.3 | ColumnnhdpDiscRouterIndex | read-only | current | The NHDP neighbor index (locally created) of a neighboring router. Used for cross- indexing into other NHDP tables and other MIB modules. |
| 1.3.6.1.2.1.213.1.2.3.1.4 | ColumnnhdpDiscIfSetIpAddrType | read-only | current | The type of the nhdpDiscIfSetIpAddr in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.213.1.2.3.1.5 | ColumnnhdpDiscIfSetIpAddr | read-only | current | The nhdpDiscIfSetIpAddr is a recently used address of a neighbor of this router. |
| 1.3.6.1.2.1.213.1.2.3.1.6 | ColumnnhdpDiscIfSetIpAddrPrefixLen | read-only | current | Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpDiscIfSetIpAddr to determine the address prefix. A row matc… |
| 1.3.6.1.2.1.213.1.2.4 | TablenhdpIibLinkSetTable | not-accessible | current | A Link Set of an interface records all links from other routers that are, or recently were, 1-hop neighbors. |
| 1.3.6.1.2.1.213.1.2.4.1 | RownhdpIibLinkSetEntry | not-accessible | current | A Link Set consists of Link Tuples, each representing a single link indexed by the local and remote interface pair: (L_neighbor_iface_addr_list, L_HEARD_time, … |
| 1.3.6.1.2.1.213.1.2.4.1.1 | ColumnnhdpIibLinkSetLHeardTime | read-only | current | nhdpIibLinkSetLHeardTime corresponds to L_HEARD_time of NHDP and represents the time up to which the MANET interface of the 1-hop neighbor would be considered … |
| 1.3.6.1.2.1.213.1.2.4.1.2 | ColumnnhdpIibLinkSetLSymTime | read-only | current | nhdpIibLinkSetLSymTime corresponds to L_SYM_time of NHDP and represents the time up to which the link to the 1-hop neighbor would be considered symmetric if no… |
| 1.3.6.1.2.1.213.1.2.4.1.3 | ColumnnhdpIibLinkSetLPending | read-only | current | nhdpIibLinkSetLPending corresponds to L_pending of NHDP and is a boolean flag, describing if a link is considered pending (i.e., a candidate, but not yet estab… |
| 1.3.6.1.2.1.213.1.2.4.1.4 | ColumnnhdpIibLinkSetLLost | read-only | current | nhdpIibLinkSetLLost corresponds to L_lost of NHDP and is a boolean flag, describing if a link is considered lost due to low link quality. |
| 1.3.6.1.2.1.213.1.2.4.1.5 | ColumnnhdpIibLinkSetLTime | read-only | current | nhdpIibLinkSetLTime specifies the value of sysUptime when this entry should expire and be removed from the nhdpIibLinkSetTable. |
| 1.3.6.1.2.1.213.1.2.5 | TablenhdpIib2HopSetTable | not-accessible | current | A 2-Hop Set of an interface records network addresses of symmetric 2-hop neighbors and the symmetric links to symmetric 1-hop neighbors through which these sym… |
| 1.3.6.1.2.1.213.1.2.5.1 | RownhdpIib2HopSetEntry | not-accessible | current | nhdpIib2HopSetTable consists of 2-Hop Tuples, each representing a single network address of a symmetric 2-hop neighbor and a single MANET interface of a symmet… |
| 1.3.6.1.2.1.213.1.2.5.1.1 | ColumnnhdpIib2HopSetIpAddressType | not-accessible | current | The type of the nhdpIib2HopSetIpAddress in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.213.1.2.5.1.2 | ColumnnhdpIib2HopSetIpAddress | not-accessible | current | nhdpIib2HopSetIpAddr corresponds to N2_2hop_addr of NHDP and is a network address of a symmetric 2-hop neighbor that has a symmetric link (using any MANET inte… |
| 1.3.6.1.2.1.213.1.2.5.1.3 | ColumnnhdpIib2HopSetIpAddrPrefixLen | read-only | current | Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpIib2HopSetIpAddress to determine the address prefix. A row … |
| 1.3.6.1.2.1.213.1.2.5.1.4 | ColumnnhdpIib2HopSet1HopIfIndex | read-only | current | nhdpIib2HopSet1HopIfIndex is nhdpDiscIfIndex of the 1-hop neighbor that communicated the ipAddress of the 2-hop neighbor in this row entry. |
| 1.3.6.1.2.1.213.1.2.5.1.5 | ColumnnhdpIib2HopSetN2Time | read-only | current | nhdpIib2HopSetN2Time specifies the value of sysUptime when this entry should expire and be removed from the nhdpIib2HopSetTable. |
| 1.3.6.1.2.1.213.1.2.6 | TablenhdpNibNeighborSetTable | not-accessible | current | A router's Neighbor Set records all network addresses of each 1-hop neighbor. |
| 1.3.6.1.2.1.213.1.2.6.1 | RownhdpNibNeighborSetEntry | not-accessible | current | A router's Neighbor Set consists of Neighbor Tuples, each representing a single 1-hop neighbor: (N_neighbor_addr_list, N_symmetric) |
| 1.3.6.1.2.1.213.1.2.6.1.1 | ColumnnhdpNibNeighborSetNSymmetric | read-only | current | nhdpNibNeighborNSymmetric corresponds to N_symmetric of NHDP and is a boolean flag, describing if this is a symmetric 1-hop neighbor. |
| 1.3.6.1.2.1.213.1.2.7 | TablenhdpNibLostNeighborSetTable | not-accessible | current | A router's Lost Neighbor Set records network addresses of routers that were recently symmetric 1-hop neighbors but are now advertised as lost. |
| 1.3.6.1.2.1.213.1.2.7.1 | RownhdpNibLostNeighborSetEntry | not-accessible | current | A router's Lost Neighbor Set consists of Lost Neighbor Tuples, each representing a single such network address: (NL_neighbor_addr, NL_time) |
| 1.3.6.1.2.1.213.1.2.7.1.1 | ColumnnhdpNibLostNeighborSetNLTime | read-only | current | nhdpNibLostNeighborSetNLTime specifies the value of sysUptime when this entry should expire and be removed from the nhdpNibLostNeighborSetTable. |
| 1.3.6.1.2.1.213.1.3 | NodenhdpPerformanceObjGrp | |||
| 1.3.6.1.2.1.213.1.3.1 | TablenhdpInterfacePerfTable | not-accessible | current | This table summarizes performance objects that are measured per local NHDP interface. |
| 1.3.6.1.2.1.213.1.3.1.1 | RownhdpInterfacePerfEntry | not-accessible | current | A single entry contains performance counters for a local NHDP interface. |
| 1.3.6.1.2.1.213.1.3.1.1.1 | ColumnnhdpIfHelloMessageXmits | read-only | current | A counter is incremented each time a HELLO message has been transmitted on that interface. |
| 1.3.6.1.2.1.213.1.3.1.1.2 | ColumnnhdpIfHelloMessageRecvd | read-only | current | A counter is incremented each time a HELLO message has been received on that interface. |
| 1.3.6.1.2.1.213.1.3.1.1.3 | ColumnnhdpIfHelloMessageXmitAccumulatedSize | read-only | current | A counter is incremented by the number of octets in a HELLO message each time a HELLO message has been sent. |
| 1.3.6.1.2.1.213.1.3.1.1.4 | ColumnnhdpIfHelloMessageRecvdAccumulatedSize | read-only | current | A counter is incremented by the number of octets in a HELLO message each time a HELLO message has been received. |
| 1.3.6.1.2.1.213.1.3.1.1.5 | ColumnnhdpIfHelloMessageTriggeredXmits | read-only | current | A counter is incremented each time a triggered HELLO message has been sent. |
| 1.3.6.1.2.1.213.1.3.1.1.6 | ColumnnhdpIfHelloMessagePeriodicXmits | read-only | current | A counter is incremented each time a periodic HELLO message has been sent. |
| 1.3.6.1.2.1.213.1.3.1.1.7 | ColumnnhdpIfHelloMessageXmitAccumulatedSymmetricNeighborCount | read-only | current | A counter is incremented by the number of advertised symmetric neighbors in a HELLO each time a HELLO message has been sent. |
| 1.3.6.1.2.1.213.1.3.1.1.8 | ColumnnhdpIfHelloMessageXmitAccumulatedHeardNeighborCount | read-only | current | A counter is incremented by the number of advertised heard neighbors in a HELLO each time a HELLO message has been sent. |
| 1.3.6.1.2.1.213.1.3.1.1.9 | ColumnnhdpIfHelloMessageXmitAccumulatedLostNeighborCount | read-only | current | A counter is incremented by the number of advertised lost neighbors in a HELLO each time a HELLO message has been sent. |
| 1.3.6.1.2.1.213.1.3.2 | TablenhdpDiscIfSetPerfTable | not-accessible | current | A router's set of performance properties for each discovered interface of a neighbor. |
| 1.3.6.1.2.1.213.1.3.2.1 | RownhdpDiscIfSetPerfEntry | not-accessible | current | There is an entry for each discovered interface of a neighbor. |
| 1.3.6.1.2.1.213.1.3.2.1.1 | ColumnnhdpDiscIfRecvdPackets | read-only | current | This counter increments each time this router receives a packet from that interface of the neighbor. |
| 1.3.6.1.2.1.213.1.3.2.1.2 | ColumnnhdpDiscIfExpectedPackets | read-only | current | This counter increments by the number of missed packets from this neighbor based on the packet sequence number each time this router receives a packet from tha… |
| 1.3.6.1.2.1.213.1.3.3 | ScalarnhdpNibNeighborSetChanges | read-only | current | This counter increments each time the Neighbor Set changes. A change occurs whenever a new Neighbor Tuple has been added, a Neighbor Tuple has been removed, or… |
| 1.3.6.1.2.1.213.1.3.4 | TablenhdpDiscNeighborSetPerfTable | not-accessible | current | A router's set of discovered neighbors and their properties. |
| 1.3.6.1.2.1.213.1.3.4.1 | RownhdpDiscNeighborSetPerfEntry | not-accessible | current | The entries include the nhdpDiscRouterIndex of the discovered router as well as performance objects related to changes of the Neighbor Set. |
| 1.3.6.1.2.1.213.1.3.4.1.1 | ColumnnhdpDiscNeighborNibNeighborSetChanges | read-only | current | This object returns the number of changes to the given Neighbor Tuple. |
| 1.3.6.1.2.1.213.1.3.4.1.2 | ColumnnhdpDiscNeighborNibNeighborSetUpTime | read-only | current | This object returns the sysUpTime when the neighbor becomes 'nbrup'. A neighbor is said to become 'nbrup' if a new nhdpNibNeighborSetEntry is created for a par… |
| 1.3.6.1.2.1.213.1.3.4.1.3 | ColumnnhdpDiscNeighborNibNeighborSetReachableLinkChanges | read-only | current | This object counts each time the neighbor changes the interface(s) over which it is reachable. A change in the set of Link Tuples corresponding to the appropri… |
| 1.3.6.1.2.1.213.1.3.5 | TablenhdpIib2HopSetPerfTable | not-accessible | current | This table contains performance objects per discovered 2-hop neighbor. |
| 1.3.6.1.2.1.213.1.3.5.1 | RownhdpIib2HopSetPerfEntry | not-accessible | current | The entries contain performance objects per discovered 2-hop neighbor. |
| 1.3.6.1.2.1.213.1.3.5.1.1 | ColumnnhdpIib2HopSetPerfChanges | read-only | current | This object counts the changes of the union of all N2_neighbor_iface_addr_list of 2-Hop Tuples with an N2_2hop_addr equal to one of the given 2-hop neighbor's … |
| 1.3.6.1.2.1.213.1.3.5.1.2 | ColumnnhdpIib2HopSetPerfUpTime | read-only | current | This object returns the sysUpTime when the 2-Hop Tuple corresponding to the given 2-hop neighbor IP address was registered in the nhdpIib2HopSetTable. |
| 1.3.6.1.2.1.213.2 | NodenhdpConformance | |||
| 1.3.6.1.2.1.213.2.1 | NodenhdpCompliances | |||
| 1.3.6.1.2.1.213.2.1.1 | CompliancenhdpBasicCompliance | current | The basic implementation requirements for managed network entities that implement NHDP. | |
| 1.3.6.1.2.1.213.2.1.2 | CompliancenhdpFullCompliance | current | The full implementation requirements for managed network entities that implement NHDP. | |
| 1.3.6.1.2.1.213.2.2 | NodenhdpMIBGroups | |||
| 1.3.6.1.2.1.213.2.2.2 | GroupnhdpConfigurationGroup | current | Set of NHDP configuration objects implemented in this module. | |
| 1.3.6.1.2.1.213.2.2.3 | GroupnhdpStateGroup | current | Set of NHDP state objects implemented in this module. | |
| 1.3.6.1.2.1.213.2.2.4 | GroupnhdpPerformanceGroup | current | Set of NHDP performance objects implemented in this module. | |
| 1.3.6.1.2.1.213.2.2.5 | GroupnhdpNotificationObjectGroup | current | Set of NHDP notification objects implemented in this module. | |
| 1.3.6.1.2.1.213.2.2.6 | GroupnhdpNotificationGroup | current | Set of NHDP notifications implemented in this module. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| NeighborIfIndex | Unsigned32 (1..2147483647) | current | An arbitrary, locally unique identifier associated with a virtual interface of a discovered NHDP neighbor. Due to the nature of NHDP, the local router may not know if two distinct addresses belong to the same interface … |
| NeighborRouterIndex | Unsigned32 (1..2147483647) | current | An arbitrary, locally unique identifier associated with a virtual discovered neighbor (one or two hop). Due to the nature of NHDP, the local router may identify multiple virtual neighbors that, in fact, are one and the … |