PRINTER-PORT-MONITOR-MIB
35 objects
The MIB module for printer port monitor support. Copyright (C) IEEE/ISTO PWG (2005).
Imported Objects
| SNMP-FRAMEWORK-MIB | -- RFC 2580 SnmpAdminString |
| SNMPv2-CONF | -- RFC 2579 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | enterprises Gauge32 Integer32 MODULE-IDENTITY OBJECT-TYPE |
| SNMPv2-TC | -- RFC 2578 TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.4.1.2699.1.2 | IdentityppmMIB | The MIB module for printer port monitor support. Copyright (C) IEEE/ISTO PWG (2005). | ||
| 1.3.6.1.4.1.2699.1.2.1 | NodeppmMIBObjects | |||
| 1.3.6.1.4.1.2699.1.2.1.1 | NodeppmGeneral | |||
| 1.3.6.1.4.1.2699.1.2.1.1.1 | ScalarppmGeneralNaturalLanguage | read-only | current | The natural language tag (RFC 3066), specified in US-ASCII, for all localized text string objects defined in this MIB (syntax of 'SnmpAdminString'), or the emp… |
| 1.3.6.1.4.1.2699.1.2.1.1.2 | ScalarppmGeneralNumberOfPrinters | read-only | current | The number of printers supported on this network system, i.e., the number of entries in the 'ppmPrinterTable' below, or zero if no printers are currently confi… |
| 1.3.6.1.4.1.2699.1.2.1.1.3 | ScalarppmGeneralNumberOfPorts | read-only | current | The number of printer ports supported on this network system, i.e., the number of entries in the 'ppmPortTable' below, or zero if no printer ports are currentl… |
| 1.3.6.1.4.1.2699.1.2.1.2 | NodeppmPrinter | |||
| 1.3.6.1.4.1.2699.1.2.1.2.1 | TableppmPrinterTable | not-accessible | current | A table containing a list of printers configured on this network system, especially for use by operating systems to facilitate selection and automatic installa… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1 | RowppmPrinterEntry | not-accessible | current | An entry containing one printer configured on this network system, especially for use by operating systems to facilitate selection and automatic installation o… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.1 | ColumnppmPrinterIndex | not-accessible | current | A locally unique identifier for this network printer. The value of this object SHOULD be preserved (for each printer) across reboots and administrative configu… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.2 | ColumnppmPrinterName | read-only | current | A user friendly name for this printer that may be used to facilitate user selection of a printer supported by a network system, in the locale specified by 'ppm… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.3 | ColumnppmPrinterIEEE1284DeviceId | read-only | current | The IEEE 1284 device ID for this printer, a set of capabilities (keys and values) specified in the US-ASCII charset and the format 'key1: value {, value }; ...… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.4 | ColumnppmPrinterNumberOfPorts | read-only | current | The number of printer ports supported on this network printer, i.e., the number of entries in the 'ppmPortTable' below with a first index of 'ppmPrinterIndex',… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.5 | ColumnppmPrinterPreferredPortIndex | read-only | current | The value of 'ppmPortIndex' for the preferred port for this printer (configured by vendor or site administrator), or zero if not specified. Compatibility Note:… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.6 | ColumnppmPrinterHrDeviceIndex | read-only | current | The value of 'hrDeviceIndex' in the IETF Host Resources MIB (RFC 1514/2790), or zero if not specified. This value of 'hrDeviceIndex' MAY be used for status que… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.7 | ColumnppmPrinterSnmpCommunityName | read-only | current | The SNMP read community name, an opaque binary string, for access to status information in IETF Host Resources MIB (RFC 1514/2790) and IETF Printer MIB (RFC 17… |
| 1.3.6.1.4.1.2699.1.2.1.2.1.1.8 | ColumnppmPrinterSnmpQueryEnabled | read-only | current | The status query mode for this printer, for queries by monitoring applications in the IETF Host Resources MIB (RFC 1514/2790) and/or IETF Printer MIB (RFC 1759… |
| 1.3.6.1.4.1.2699.1.2.1.3 | NodeppmPort | |||
| 1.3.6.1.4.1.2699.1.2.1.3.1 | TableppmPortTable | not-accessible | current | A table containing a list of input printer ports configured on this network system, especially for use by operating systems to facilitate selection and automat… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1 | RowppmPortEntry | not-accessible | current | An entry containing one input printer port configured on this network system, especially for use by operating systems to facilitate selection and automatic ins… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.1 | ColumnppmPortIndex | not-accessible | current | A locally unique identifier for this printer port when appended to the value of 'ppmPrinterIndex' for this printer port. The value of this object SHOULD be pre… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.2 | ColumnppmPortEnabled | read-only | current | The current administrative configuration mode for this port. If this object is 'false', then applications MUST NOT attempt installation of this port and SHOULD… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.3 | ColumnppmPortName | read-only | current | A user friendly name for this port that may be used to facilitate user selection of a port on a multi-port network system, in the locale specified by 'ppmGener… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.4 | ColumnppmPortServiceNameOrURI | read-only | current | The service name or URI for this port, specified in UTF-8 (RFC 3629), in the locale specified by 'ppmGeneralNaturalLanguage'. The service name is typically a q… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.5 | ColumnppmPortProtocolType | read-only | current | The protocol type of this printer port, specified as a value from 'PrtChannelTypeTC' in the IANA Printer MIB (e.g., 'chLPDServer(8)' for LPR (RFC 1179) or 'chP… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.6 | ColumnppmPortProtocolTargetPort | read-only | current | The transport (TCP, UDP, etc.) target port number for this protocol, i.e., an alternate port from the protocol default, or zero if not specified (use protocol … |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.7 | ColumnppmPortProtocolAltSourceEnabled | read-only | current | The alternate transport source port mode for this protocol. If this object is 'true', then transport source ports outside the standard range MAY be used (e.g.,… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.8 | ColumnppmPortPrtChannelIndex | read-only | current | The value of 'prtChannelIndex' in IETF Printer MIB (RFC 1759/3805) that corresponds to this printer port, or zero if not specified. Compatibility Note: The val… |
| 1.3.6.1.4.1.2699.1.2.1.3.1.1.9 | ColumnppmPortLprByteCountEnabled | read-only | current | The current LPR byte counting mode for this port if applicable. If the value of 'ppmPortProtocolType' is NOT 'chLPDServer(8)', then monitoring applications MUS… |
| 1.3.6.1.4.1.2699.1.2.2 | NodeppmMIBConformance | |||
| 1.3.6.1.4.1.2699.1.2.2.1 | ComplianceppmMIBCompliance | current | The compliance statements for SNMP Agents that implement this Printer Port Monitor MIB. | |
| 1.3.6.1.4.1.2699.1.2.2.2 | NodeppmMIBObjectGroups | |||
| 1.3.6.1.4.1.2699.1.2.2.2.1 | GroupppmGeneralGroup | current | The General object group in the Printer Port Monitor MIB | |
| 1.3.6.1.4.1.2699.1.2.2.2.2 | GroupppmPrinterGroup | current | The Printer object group in the Printer Port Monitor MIB | |
| 1.3.6.1.4.1.2699.1.2.2.2.3 | GroupppmPortGroup | current | The Port object group in the Printer Port Monitor MIB |