PSAMP-MIB
55 objects
The PSAMP MIB defines managed objects for packet sampling and filtering. These objects provide information about managed nodes supporting packet sampling, including packet sampling capabilities, configuration, and statistics. The PSAMP MIB module registers additional top-level OIDs for the parameter subtrees of its Selector functions in the IPFIX-SELECTOR-MIB Function sub-registry according to the procedures defined in RFC 6615. Copyright (c) 2012 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 6727; see the RFC itself for full legal notices.
Imported Objects
| APPLICATION-MIB | -- RFC 2580 Unsigned64TC |
| FLOAT-TC-MIB | -- RFC 2564 Float64TC |
| IPFIX-SELECTOR-MIB | -- RFC 6340 ipfixSelectorFunctions |
| SNMPv2-CONF | -- RFC 2579 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | Integer32 mib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 2578 TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.194.1.1.2 | NodepsampSampCountBased | |||
| 1.3.6.1.2.1.194.1.1.2.1 | ScalarpsampSampCountBasedAvail | read-only | current | This object indicates the availability of systematic count-based sampling at the managed node. A Selector may be unavailable if it is implemented but currently… |
| 1.3.6.1.2.1.194.1.1.2.2 | TablepsampSampCountBasedParamSetTable | not-accessible | current | This table lists configurations of systematic count-based packet sampling. A parameter set describing a configuration contains two parameters: the sampling int… |
| 1.3.6.1.2.1.194.1.1.2.2.1 | RowpsampSampCountBasedParamSetEntry | not-accessible | current | Defines an entry in the psampSampCountBasedParamSetTable. |
| 1.3.6.1.2.1.194.1.1.2.2.1.1 | ColumnpsampSampCountBasedIndex | not-accessible | current | The index of this parameter set in the psampSampCountBasedParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSel… |
| 1.3.6.1.2.1.194.1.1.2.2.1.2 | ColumnpsampSampCountBasedInterval | read-only | current | This object specifies the number of packets that are consecutively sampled. A value of 100 means that 100 consecutive packets are sampled. |
| 1.3.6.1.2.1.194.1.1.2.2.1.3 | ColumnpsampSampCountBasedSpace | read-only | current | This object specifies the number of packets between two intervals specified by the object psampSampCountBasedInterval. A value of 100 means that the next inter… |
| 1.3.6.1.2.1.194.1.1.3 | NodepsampSampTimeBased | |||
| 1.3.6.1.2.1.194.1.1.3.1 | ScalarpsampSampTimeBasedAvail | read-only | current | This object indicates the availability of systematic time-based sampling at the managed node. A Selector may be unavailable if it is implemented but currently … |
| 1.3.6.1.2.1.194.1.1.3.2 | TablepsampSampTimeBasedParamSetTable | not-accessible | current | This table lists configurations of systematic time-based packet sampling. A parameter set describing a configuration contains two parameters: the sampling inte… |
| 1.3.6.1.2.1.194.1.1.3.2.1 | RowpsampSampTimeBasedParamSetEntry | not-accessible | current | Defines an entry in the psampSampTimeBasedParamSetTable. |
| 1.3.6.1.2.1.194.1.1.3.2.1.1 | ColumnpsampSampTimeBasedIndex | not-accessible | current | The index of this parameter set in the psampSampTimeBasedParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSele… |
| 1.3.6.1.2.1.194.1.1.3.2.1.2 | ColumnpsampSampTimeBasedInterval | read-only | current | This object specifies the time interval in microseconds during which all arriving packets are sampled. |
| 1.3.6.1.2.1.194.1.1.3.2.1.3 | ColumnpsampSampTimeBasedSpace | read-only | current | This object specifies the time interval in microseconds between two intervals specified by the object psampSampTimeBasedInterval. A value of 100 means that the… |
| 1.3.6.1.2.1.194.1.1.4 | NodepsampSampRandOutOfN | |||
| 1.3.6.1.2.1.194.1.1.4.1 | ScalarpsampSampRandOutOfNAvail | read-only | current | This object indicates the availability of random n-out-of-N sampling at the managed node. A Selector may be unavailable if it is implemented but currently disa… |
| 1.3.6.1.2.1.194.1.1.4.2 | TablepsampSampRandOutOfNParamSetTable | not-accessible | current | This table lists configurations of random n-out-of-N sampling. A parameter set describing a configuration contains two parameters: the sampling size and the pa… |
| 1.3.6.1.2.1.194.1.1.4.2.1 | RowpsampSampRandOutOfNParamSetEntry | not-accessible | current | Defines an entry in the psampSampRandOutOfNParamSetTable. |
| 1.3.6.1.2.1.194.1.1.4.2.1.1 | ColumnpsampSampRandOutOfNIndex | not-accessible | current | The index of this parameter set in the psampSampRandOutOfNParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSel… |
| 1.3.6.1.2.1.194.1.1.4.2.1.2 | ColumnpsampSampRandOutOfNSize | read-only | current | This object specifies the number of elements taken from the parent Population specified in psampSampRandOutOfNPopulation. |
| 1.3.6.1.2.1.194.1.1.4.2.1.3 | ColumnpsampSampRandOutOfNPopulation | read-only | current | This object specifies the number of elements in the parent Population. |
| 1.3.6.1.2.1.194.1.1.5 | NodepsampSampUniProb | |||
| 1.3.6.1.2.1.194.1.1.5.1 | ScalarpsampSampUniProbAvail | read-only | current | This object indicates the availability of random uniform probabilistic sampling at the managed node. A Selector may be unavailable if it is implemented but cur… |
| 1.3.6.1.2.1.194.1.1.5.2 | TablepsampSampUniProbParamSetTable | not-accessible | current | This table lists configurations of random probabilistic sampling. A parameter set describing a configuration contains a single parameter only: the sampling pro… |
| 1.3.6.1.2.1.194.1.1.5.2.1 | RowpsampSampUniProbParamSetEntry | not-accessible | current | Defines an entry in the psampSampUniProbParamSetTable. |
| 1.3.6.1.2.1.194.1.1.5.2.1.1 | ColumnpsampSampUniProbIndex | not-accessible | current | The index of this parameter set in the psampSampUniProbParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelect… |
| 1.3.6.1.2.1.194.1.1.5.2.1.2 | ColumnpsampSampUniProbProbability | read-only | current | This object specifies the probability that a packet is sampled, expressed as a value between 0 and 1. The probability is equal for every packet. A value of 0 m… |
| 1.3.6.1.2.1.194.1.1.6 | NodepsampFiltPropMatch | |||
| 1.3.6.1.2.1.194.1.1.6.1 | ScalarpsampFiltPropMatchAvail | read-only | current | This object indicates the availability of property match filtering at the managed node. A Selector may be unavailable if it is implemented but currently disabl… |
| 1.3.6.1.2.1.194.1.1.7 | NodepsampFiltHash | |||
| 1.3.6.1.2.1.194.1.1.7.1 | ScalarpsampFiltHashAvail | read-only | current | This object indicates the availability of hash filtering at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to,… |
| 1.3.6.1.2.1.194.1.1.7.2 | NodepsampFiltHashCapabilities | |||
| 1.3.6.1.2.1.194.1.1.7.3 | TablepsampFiltHashParamSetTable | not-accessible | current | This table lists configurations of hash filtering. A parameter set describing a configuration contains eight parameters describing the hash function. |
| 1.3.6.1.2.1.194.1.1.7.3.1 | RowpsampFiltHashParamSetEntry | not-accessible | current | Defines an entry in the psampFiltHashParamSetTable. |
| 1.3.6.1.2.1.194.1.1.7.3.1.1 | ColumnpsampFiltHashIndex | not-accessible | current | The index of this parameter set in the psampFiltHashParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelection… |
| 1.3.6.1.2.1.194.1.1.7.3.1.2 | ColumnpsampFiltHashFunction | read-only | current | The hash function used by this filter. The PSAMP-MIB defines the following hash functions: crc32(1): The CRC-32 Hash Function as defined in RFC 1141. ipsx(2): … |
| 1.3.6.1.2.1.194.1.1.7.3.1.3 | ColumnpsampFiltHashInitializerValue | read-only | current | This object specifies the initializer value to the hash function. |
| 1.3.6.1.2.1.194.1.1.7.3.1.4 | ColumnpsampFiltHashIpPayloadOffset | read-only | current | This object specifies the IP payload offset used by a Hash-based Selection Selector. |
| 1.3.6.1.2.1.194.1.1.7.3.1.5 | ColumnpsampFiltHashIpPayloadSize | read-only | current | This object specifies the IP payload size used by a Hash-based Selection Selector. |
| 1.3.6.1.2.1.194.1.1.7.3.1.6 | ColumnpsampFiltHashSelectedRangeMin | read-only | current | This object specifies the value for the beginning of a hash function's selected range. |
| 1.3.6.1.2.1.194.1.1.7.3.1.7 | ColumnpsampFiltHashSelectedRangeMax | read-only | current | This object specifies the value for the end of a hash function's selected range. |
| 1.3.6.1.2.1.194.1.1.7.3.1.8 | ColumnpsampFiltHashOutputRangeMin | read-only | current | This object specifies the value for the beginning of a hash function's potential output range. |
| 1.3.6.1.2.1.194.1.1.7.3.1.9 | ColumnpsampFiltHashOutputRangeMax | read-only | current | This object specifies the value for the end of a hash function's potential output range. |
| 1.3.6.1.2.1.212 | IdentitypsampMIB | The PSAMP MIB defines managed objects for packet sampling and filtering. These objects provide information about managed nodes supporting packet sampling, incl… | ||
| 1.3.6.1.2.1.212.1 | NodepsampObjects | |||
| 1.3.6.1.2.1.212.2 | NodepsampConformance | |||
| 1.3.6.1.2.1.212.2.1 | NodepsampCompliances | |||
| 1.3.6.1.2.1.212.2.1.1 | CompliancepsampCompliance | current | The implementation of all objects is optional and depends on the implementation of the corresponding functionality in the equipment. | |
| 1.3.6.1.2.1.212.2.2 | NodepsampGroups | |||
| 1.3.6.1.2.1.212.2.2.1 | GrouppsampGroupSampCountBased | current | These objects are needed if count based sampling is implemented. | |
| 1.3.6.1.2.1.212.2.2.2 | GrouppsampGroupSampTimeBased | current | These objects are needed if time based sampling is implemented. | |
| 1.3.6.1.2.1.212.2.2.3 | GrouppsampGroupSampRandOutOfN | current | These objects are needed if random n-out-of-N sampling is implemented. | |
| 1.3.6.1.2.1.212.2.2.4 | GrouppsampGroupSampUniProb | current | These objects are needed if uniform probabilistic sampling is implemented. | |
| 1.3.6.1.2.1.212.2.2.5 | GrouppsampGroupFiltPropMatch | current | These objects are needed if property match filtering is implemented. | |
| 1.3.6.1.2.1.212.2.2.6 | GrouppsampGroupFiltHash | current | These objects are needed if hash filtering is implemented. |