RFC1286-MIB
85 objects
No module-level DESCRIPTION found.
Imported Objects
| RFC-1212 | OBJECT-TYPE |
| RFC-1215 | TRAP-TYPE |
| RFC1155-SMI | Counter Gauge TimeTicks |
| RFC1213-MIB | mib-2 |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.17 | Nodedot1dBridge | |||
| 1.3.6.1.2.1.17.1 | Nodedot1dBase | |||
| 1.3.6.1.2.1.17.1 | NodenewRoot | The newRoot trap indicates that the sending agent has become the new root of the Spanning Tree; the trap is sent by a bridge soon after its election as the new… | ||
| 1.3.6.1.2.1.17.1.1 | Scalardot1dBaseBridgeAddress | read-only | mandatory | The MAC address used by this bridge when it must be referred to in a unique fashion. It is recommended that this be the numerically smallest MAC address of all… |
| 1.3.6.1.2.1.17.1.2 | Scalardot1dBaseNumPorts | read-only | mandatory | The number of ports controlled by this bridging entity. |
| 1.3.6.1.2.1.17.1.3 | Scalardot1dBaseType | read-only | mandatory | Indicates what type of bridging this bridge can perform. If a bridge is actually performing a certain type of bridging this will be indicated by entries in the… |
| 1.3.6.1.2.1.17.1.4 | Tabledot1dBasePortTable | not-accessible | mandatory | A table that contains generic information about every port that is associated with this bridge. Transparent, source-route, and srt ports are included. |
| 1.3.6.1.2.1.17.1.4.1 | Rowdot1dBasePortEntry | not-accessible | mandatory | A list of information for each port of the bridge. |
| 1.3.6.1.2.1.17.1.4.1.1 | Columndot1dBasePort | read-only | mandatory | The port number of the port for which this entry contains bridge management information. |
| 1.3.6.1.2.1.17.1.4.1.2 | Columndot1dBasePortIfIndex | read-only | mandatory | The value of the instance of the ifIndex object, defined in [4,6], for the interface corresponding to this port. |
| 1.3.6.1.2.1.17.1.4.1.3 | Columndot1dBasePortCircuit | read-only | mandatory | For a port which (potentially) has the same value of dot1dBasePortIfIndex as another port on the same bridge, this object contains the name of an object instan… |
| 1.3.6.1.2.1.17.1.4.1.4 | Columndot1dBasePortDelayExceededDiscards | read-only | mandatory | The number of frames discarded by this port due to excessive transit delay through the bridge. It is incremented by both transparent and source route bridges. |
| 1.3.6.1.2.1.17.1.4.1.5 | Columndot1dBasePortMtuExceededDiscards | read-only | mandatory | The number of frames discarded by this port due to an excessive size. It is incremented by both transparent and source route bridges. |
| 1.3.6.1.2.1.17.2 | Nodedot1dStp | |||
| 1.3.6.1.2.1.17.2 | NodetopologyChange | A topologyChange trap is sent by a bridge when any of its configured ports transitions from the Learning state to the Forwarding state, or from the Forwarding … | ||
| 1.3.6.1.2.1.17.2.1 | Scalardot1dStpProtocolSpecification | read-only | mandatory | An indication of what version of the Spanning Tree Protocol is being run. The value 'decLb100(2)' indicates the DEC LANbridge 100 Spanning Tree protocol. IEEE … |
| 1.3.6.1.2.1.17.2.2 | Scalardot1dStpPriority | read-write | mandatory | The value of the write-able portion of the Bridge ID, i.e., the first two octets of the (8 octet long) Bridge ID. The other (last) 6 octets of the Bridge ID ar… |
| 1.3.6.1.2.1.17.2.3 | Scalardot1dStpTimeSinceTopologyChange | read-only | mandatory | The time (in hundredths of a second) since the last time a topology change was detected by the bridge entity. |
| 1.3.6.1.2.1.17.2.4 | Scalardot1dStpTopChanges | read-only | mandatory | The total number of topology changes detected by this bridge since the management entity was last reset or initialized. |
| 1.3.6.1.2.1.17.2.5 | Scalardot1dStpDesignatedRoot | read-only | mandatory | The bridge identifier of the root of the spanning tree as determined by the Spanning Tree Protocol as executed by this node. This value is used as the Root Ide… |
| 1.3.6.1.2.1.17.2.6 | Scalardot1dStpRootCost | read-only | mandatory | The cost of the path to the root as seen from this bridge. |
| 1.3.6.1.2.1.17.2.7 | Scalardot1dStpRootPort | read-only | mandatory | The port number of the port which offers the lowest cost path from this bridge to the root bridge. |
| 1.3.6.1.2.1.17.2.8 | Scalardot1dStpMaxAge | read-only | mandatory | The maximum age of Spanning Tree Protocol information learned from the network on any port before it is discarded, in units of hundredths of a second. This is … |
| 1.3.6.1.2.1.17.2.9 | Scalardot1dStpHelloTime | read-only | mandatory | The amount of time between the transmission of Configuration bridge PDUs by this node on any port when it is the root of the spanning tree or trying to become … |
| 1.3.6.1.2.1.17.2.10 | Scalardot1dStpHoldTime | read-only | mandatory | This time value determines the interval length during which no more than two Configuration bridge PDUs shall be transmitted by this node, in units of hundredth… |
| 1.3.6.1.2.1.17.2.11 | Scalardot1dStpForwardDelay | read-only | mandatory | This time value, measured in units of hundredths of a second, controls how fast a port changes its spanning state when moving towards the Forwarding state. The… |
| 1.3.6.1.2.1.17.2.12 | Scalardot1dStpBridgeMaxAge | read-write | mandatory | The value that all bridges use for MaxAge when this bridge is acting as the root. Note that 802.1d/D9 specifies that the range for this parameter is related to… |
| 1.3.6.1.2.1.17.2.13 | Scalardot1dStpBridgeHelloTime | read-write | mandatory | The value that all bridges use for HelloTime when this bridge is acting as the root. The granularity of this timer is specified by 802.1d/D9 to be 1 second. An… |
| 1.3.6.1.2.1.17.2.14 | Scalardot1dStpBridgeForwardDelay | read-write | mandatory | The value that all bridges use for ForwardDelay when this bridge is acting as the root. Note that 802.1d/D9 specifies that the range for this parameter is rela… |
| 1.3.6.1.2.1.17.2.15 | Tabledot1dStpPortTable | not-accessible | mandatory | A table that contains port-specific information for the Spanning Tree Protocol. |
| 1.3.6.1.2.1.17.2.15.1 | Rowdot1dStpPortEntry | not-accessible | mandatory | A list of information maintained by every port about the Spanning Tree Protocol state for that port. |
| 1.3.6.1.2.1.17.2.15.1.1 | Columndot1dStpPort | read-only | mandatory | The port number of the port for which this entry contains Spanning Tree Protocol management information. |
| 1.3.6.1.2.1.17.2.15.1.2 | Columndot1dStpPortPriority | read-write | mandatory | The value of the priority field which is contained in the first (in network byte order) octet of the (2 octet long) Port ID. The other octet of the Port ID is … |
| 1.3.6.1.2.1.17.2.15.1.3 | Columndot1dStpPortState | read-only | mandatory | The port's current state as defined by application of the Spanning Tree Protocol. This state controls what action a port takes on reception of a frame. If the … |
| 1.3.6.1.2.1.17.2.15.1.4 | Columndot1dStpPortEnable | read-write | mandatory | The enabled/disabled status of the port. |
| 1.3.6.1.2.1.17.2.15.1.5 | Columndot1dStpPortPathCost | read-write | mandatory | The contribution of this port to the path cost of paths towards the spanning tree root which include this port. |
| 1.3.6.1.2.1.17.2.15.1.6 | Columndot1dStpPortDesignatedRoot | read-only | mandatory | The unique Bridge Identifier of the Bridge recorded as the Root in the Configuration BPDUs transmitted by the Designated Bridge for the segment to which the po… |
| 1.3.6.1.2.1.17.2.15.1.7 | Columndot1dStpPortDesignatedCost | read-only | mandatory | The path cost of the Designated Port of the segment connected to this port. This value is compared to the Root Path Cost field in received bridge PDUs. |
| 1.3.6.1.2.1.17.2.15.1.8 | Columndot1dStpPortDesignatedBridge | read-only | mandatory | The Bridge Identifier of the bridge which this port considers to be the Designated Bridge for this port's segment. |
| 1.3.6.1.2.1.17.2.15.1.9 | Columndot1dStpPortDesignatedPort | read-only | mandatory | The Port Identifier of the port on the Designated Bridge for this port's segment. |
| 1.3.6.1.2.1.17.2.15.1.10 | Columndot1dStpPortForwardTransitions | read-only | mandatory | The number of times this port has transitioned from the Learning state to the Forwarding state. |
| 1.3.6.1.2.1.17.3 | Nodedot1dSr | |||
| 1.3.6.1.2.1.17.3.1 | Tabledot1dSrPortTable | not-accessible | mandatory | A table that contains information about every port that is associated with this source route bridge. |
| 1.3.6.1.2.1.17.3.1.1 | Rowdot1dSrPortEntry | not-accessible | mandatory | A list of information for each port of a source route bridge. |
| 1.3.6.1.2.1.17.3.1.1.1 | Columndot1dSrPort | read-only | mandatory | The port number of the port for which this entry contains Source Route management information. |
| 1.3.6.1.2.1.17.3.1.1.2 | Columndot1dSrPortHopCount | read-write | mandatory | The maximum number of routing descriptors allowed in an All Paths or Spanning Tree Explorer frames. |
| 1.3.6.1.2.1.17.3.1.1.3 | Columndot1dSrPortLocalSegment | read-write | mandatory | The segment number that uniquely identifies the segment to which this port is connected. Current source routing protocols limit this value to the range: 0 thro… |
| 1.3.6.1.2.1.17.3.1.1.4 | Columndot1dSrPortBridgeNum | read-write | mandatory | A bridge number uniquely identifies a bridge when more than one bridge is used to span the same two segments. Current source routing protocols limit this value… |
| 1.3.6.1.2.1.17.3.1.1.5 | Columndot1dSrPortTargetSegment | read-write | mandatory | The segment number that corresponds to the target segment this port is considered to be connected to by the bridge. Current source routing protocols limit this… |
| 1.3.6.1.2.1.17.3.1.1.6 | Columndot1dSrPortLargestFrame | read-write | mandatory | The maximum size of the INFO field (LLC and above) that this port can send/receive. It does not include any MAC level (framing) octets. The value of this objec… |
| 1.3.6.1.2.1.17.3.1.1.7 | Columndot1dSrPortSTESpanMode | read-write | mandatory | Determines how this port behaves when presented with a Spanning Tree Explorer frame. The value 'disabled(2)' indicates that the port will not accept or send Sp… |
| 1.3.6.1.2.1.17.3.1.1.8 | Columndot1dSrPortSpecInFrames | read-only | mandatory | The number of specifically routed frames that have been received from this port's segment. |
| 1.3.6.1.2.1.17.3.1.1.9 | Columndot1dSrPortSpecOutFrames | read-only | mandatory | The number of specifically routed frames that this port has transmitted on its segment. |
| 1.3.6.1.2.1.17.3.1.1.10 | Columndot1dSrPortApeInFrames | read-only | mandatory | The number of all paths explorer frames that have been received by this port from its segment. |
| 1.3.6.1.2.1.17.3.1.1.11 | Columndot1dSrPortApeOutFrames | read-only | mandatory | The number of all paths explorer frames that have been transmitted by this port on its segment. |
| 1.3.6.1.2.1.17.3.1.1.12 | Columndot1dSrPortSteInFrames | read-only | mandatory | The number of spanning tree explorer frames that have been received by this port from its segment. |
| 1.3.6.1.2.1.17.3.1.1.13 | Columndot1dSrPortSteOutFrames | read-only | mandatory | The number of spanning tree explorer frames that have been transmitted by this port on its segment. |
| 1.3.6.1.2.1.17.3.1.1.14 | Columndot1dSrPortSegmentMismatchDiscards | read-only | mandatory | The number of explorer frames that have been discarded by this port because the routing descriptor field contained an invalid adjacent segment value. |
| 1.3.6.1.2.1.17.3.1.1.15 | Columndot1dSrPortDuplicateSegmentDiscards | read-only | mandatory | The number of frames that have been discarded by this port because the routing descriptor field contained a duplicate segment identifier. |
| 1.3.6.1.2.1.17.3.1.1.16 | Columndot1dSrPortHopCountExceededDiscards | read-only | mandatory | The number of explorer frames that have been discarded by this port because the Routing Information Field has exceeded the maximum route descriptor length. |
| 1.3.6.1.2.1.17.4 | Nodedot1dTp | |||
| 1.3.6.1.2.1.17.4.1 | Scalardot1dTpLearnedEntryDiscards | read-only | mandatory | The total number of Forwarding Database entries, which have been or would have been learnt, but have been discarded due to a lack of space to store them in the… |
| 1.3.6.1.2.1.17.4.2 | Scalardot1dTpAgingTime | read-write | mandatory | The timeout period in seconds for aging out dynamically learned forwarding information. |
| 1.3.6.1.2.1.17.4.3 | Tabledot1dTpFdbTable | not-accessible | mandatory | A table that contains information about unicast entries for which the bridge has forwarding and/or filtering information. This information is used by the trans… |
| 1.3.6.1.2.1.17.4.3.1 | Rowdot1dTpFdbEntry | not-accessible | mandatory | Information about a specific unicast MAC address for which the bridge has some forwarding and/or filtering information. |
| 1.3.6.1.2.1.17.4.3.1.1 | Columndot1dTpFdbAddress | read-only | mandatory | A unicast MAC address for which the bridge has forwarding and/or filtering information. |
| 1.3.6.1.2.1.17.4.3.1.2 | Columndot1dTpFdbPort | read-only | mandatory | Either the value '0', or the port number of the port on which a frame having a source address equal to the value of the corresponding instance of dot1dTpFdbAdd… |
| 1.3.6.1.2.1.17.4.3.1.3 | Columndot1dTpFdbStatus | read-only | mandatory | The status of this entry. The meanings of the values are: other(1) : none of the following. This would include the case where some other MIB object (not the co… |
| 1.3.6.1.2.1.17.4.4 | Tabledot1dTpPortTable | not-accessible | mandatory | A table that contains information about every port that is associated with this transparent bridge. |
| 1.3.6.1.2.1.17.4.4.1 | Rowdot1dTpPortEntry | not-accessible | mandatory | A list of information for each port of a transparent bridge. |
| 1.3.6.1.2.1.17.4.4.1.1 | Columndot1dTpPort | read-only | mandatory | The port number of the port for which this entry contains Transparent bridging management information. |
| 1.3.6.1.2.1.17.4.4.1.2 | Columndot1dTpPortMaxInfo | read-only | mandatory | The maximum size of the INFO (non-MAC) field that this port will receive or transmit. |
| 1.3.6.1.2.1.17.4.4.1.3 | Columndot1dTpPortInFrames | read-only | mandatory | The number of frames that have been received by this port from its segment. Note that a frame received on the interface corresponding to this port is only coun… |
| 1.3.6.1.2.1.17.4.4.1.4 | Columndot1dTpPortOutFrames | read-only | mandatory | The number of frames that have been transmitted by this port to its segment. Note that a frame transmitted on the interface corresponding to this port is only … |
| 1.3.6.1.2.1.17.4.4.1.5 | Columndot1dTpPortInDiscards | read-only | mandatory | Count of valid frames received which were discarded (i.e., filtered) by the Forwarding Process. |
| 1.3.6.1.2.1.17.5 | Nodedot1dStatic | |||
| 1.3.6.1.2.1.17.5.1 | Tabledot1dStaticTable | not-accessible | mandatory | A table containing filtering information configured into the bridge by (local or network) management specifying the set of ports to which frames received from … |
| 1.3.6.1.2.1.17.5.1.1 | Rowdot1dStaticEntry | not-accessible | mandatory | Filtering information configured into the bridge by (local or network) management specifying the set of ports to which frames received from a specific port and… |
| 1.3.6.1.2.1.17.5.1.1.1 | Columndot1dStaticAddress | read-write | mandatory | The destination MAC address in a frame to which this entry's filtering information applies. This object can take the value of a unicast address, a group addres… |
| 1.3.6.1.2.1.17.5.1.1.2 | Columndot1dStaticReceivePort | read-write | mandatory | Either the value '0', or the port number of the port from which a frame must be received in order for this entry's filtering information to apply. A value of z… |
| 1.3.6.1.2.1.17.5.1.1.3 | Columndot1dStaticAllowedToGoTo | read-write | mandatory | The set of ports to which frames received from a specific port and destined for a specific MAC address, are allowed to be forwarded. Each octet within the valu… |
| 1.3.6.1.2.1.17.5.1.1.4 | Columndot1dStaticStatus | read-write | mandatory | This object indicates the status of this entry. other(1) - this entry is currently in use but the conditions under which it will remain so are different from e… |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| BridgeId | OCTET STRING (SIZE (8)) | ||
| MacAddress | OCTET STRING (SIZE (6)) | ||
| Timeout | INTEGER |