MIB Viewer

ROHC-RTP-MIB

32 objects
This MIB module defines a set of objects for monitoring and configuring RObust Header Compression (ROHC). The objects are specific to ROHC RTP (profile 0x0001), ROHC UDP (profile 0x0002), and ROHC ESP (profile 0x0003) defined in RFC 3095 and for the ROHC LLA profile (profile 0x0005) defined in RFC 3242. Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3816. For full legal notices see the RFC itself or see: http://www.ietf.org/copyrights/ianamib.html
Imported Objects
OIDNameAccessStatusDescription
1.3.6.1.2.1.114IdentityrohcRtpMIBThis MIB module defines a set of objects for monitoring and configuring RObust Header Compression (ROHC). The objects are specific to ROHC RTP (profile 0x0001)…
1.3.6.1.2.1.114.1NoderohcRtpObjects
1.3.6.1.2.1.114.1.1TablerohcRtpContextTablenot-accessiblecurrentThis table lists and describes RTP profile specific properties of compressor contexts and decompressor contexts. It extends the rohcContextTable of the ROHC-MI…
1.3.6.1.2.1.114.1.1.1RowrohcRtpContextEntrynot-accessiblecurrentAn entry describing a particular context.
1.3.6.1.2.1.114.1.1.1.3ColumnrohcRtpContextStateread-onlycurrentState of the context as defined in RFC 3095. States initAndRefresh(1), firstOrder(2), and secondOrder(3) are states of compressor contexts, states noContext(4)…
1.3.6.1.2.1.114.1.1.1.4ColumnrohcRtpContextModeread-onlycurrentMode of the context.
1.3.6.1.2.1.114.1.1.1.5ColumnrohcRtpContextAlwaysPadread-onlycurrentBoolean, only applicable to compressor contexts using the LLA profile. If its value is true, the compressor must pad every RHP packet with a minimum of one oct…
1.3.6.1.2.1.114.1.1.1.6ColumnrohcRtpContextLargePktsAllowedread-onlycurrentBoolean, only applicable to compressor contexts using the LLA profile. It specifies how to handle packets that do not fit any of the preferred packet sizes spe…
1.3.6.1.2.1.114.1.1.1.7ColumnrohcRtpContextVerifyPeriodread-onlycurrentThis object is only applicable to compressor contexts using the LLA profile. It specifies the minimum frequency with which a packet validating the context must…
1.3.6.1.2.1.114.1.1.1.8ColumnrohcRtpContextSizesAllowedread-onlycurrentThe value of this object is only valid for decompressor contexts, i.e., if rohcInstanceType of the corresponding rohcContextEntry has the value decompressor(2)…
1.3.6.1.2.1.114.1.1.1.9ColumnrohcRtpContextSizesUsedread-onlycurrentThe value of this object is only valid for decompressor contexts, i.e., if rohcInstanceType of the corresponding rohcContextEntry has the value decompressor(2)…
1.3.6.1.2.1.114.1.1.1.10ColumnrohcRtpContextACKsread-onlycurrentThe number of all positive feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initial…
1.3.6.1.2.1.114.1.1.1.11ColumnrohcRtpContextNACKsread-onlycurrentThe number of all dynamic negative feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re…
1.3.6.1.2.1.114.1.1.1.12ColumnrohcRtpContextSNACKsread-onlycurrentThe number of all static negative feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-…
1.3.6.1.2.1.114.1.1.1.13ColumnrohcRtpContextNHPsread-onlycurrentThis object is only applicable to contexts using the LLA profile. It contains the number of all no-header packets (NHP) sent or received in this context, respe…
1.3.6.1.2.1.114.1.1.1.14ColumnrohcRtpContextCSPsread-onlycurrentThis object is only applicable to contexts using the LLA profile. It contains the number of all context synchronization packets (CSP) sent or received in this …
1.3.6.1.2.1.114.1.1.1.15ColumnrohcRtpContextCCPsread-onlycurrentThis object is only applicable to contexts using the LLA profile. It contains the number of all context check packets (CCP) sent or received in this context, r…
1.3.6.1.2.1.114.1.1.1.16ColumnrohcRtpContextPktsLostPhysicalread-onlycurrentThis object is only applicable to decompressor contexts using the LLA profile. It contains the number of physical packet losses on the link between compressor …
1.3.6.1.2.1.114.1.1.1.17ColumnrohcRtpContextPktsLostPreLinkread-onlycurrentThis object is only applicable to decompressor contexts using the LLA profile. It contains the number of pre-link packet losses on the link between compressor …
1.3.6.1.2.1.114.1.2TablerohcRtpPacketSizeTablenot-accessiblecurrentThis table lists all allowed, preferred, and used packet sizes per compressor context and channel. Note, that the sizes table represents implementation paramet…
1.3.6.1.2.1.114.1.2.1RowrohcRtpPacketSizeEntrynot-accessiblecurrentAn entry of a particular packet size.
1.3.6.1.2.1.114.1.2.1.3ColumnrohcRtpPacketSizenot-accessiblecurrentA packet size used as index.
1.3.6.1.2.1.114.1.2.1.4ColumnrohcRtpPacketSizePreferredread-onlycurrentThis object is only applicable to compressor contexts using the LLA profile. When retrieved, it will have the value true(1) if the packet size is preferred. Ot…
1.3.6.1.2.1.114.1.2.1.5ColumnrohcRtpPacketSizeUsedread-onlycurrentThis object is only applicable to compressor contexts using the UDP, RTP, or ESP profile. When retrieved, it will have the value true(1) if the packet size is …
1.3.6.1.2.1.114.1.2.1.6ColumnrohcRtpPacketSizeRestrictedTyperead-onlycurrentThis object is only applicable to preferred packet sizes of compressor contexts using the LLA profile. When retrieved, it will indicate whether the packet size…
1.3.6.1.2.1.114.2NoderohcRtpConformance
1.3.6.1.2.1.114.2.1NoderohcRtpCompliances
1.3.6.1.2.1.114.2.1.1CompliancerohcRtpCompliancecurrentThe compliance statement for SNMP entities that implement the ROHC-RTP-MIB. Note that compliance with this compliance statement requires compliance with the ro…
1.3.6.1.2.1.114.2.2NoderohcRtpGroups
1.3.6.1.2.1.114.2.2.1GrouprohcRtpContextGroupcurrentA collection of objects providing information about ROHC RTP compressors and decompressors.
1.3.6.1.2.1.114.2.2.2GrouprohcRtpPacketSizesGroupcurrentA collection of objects providing information about allowed and used packet sizes at a ROHC RTP compressor.
1.3.6.1.2.1.114.2.2.3GrouprohcRtpStatisticsGroupcurrentA collection of objects providing ROHC compressor and decompressor statistics.