MIB Viewer

RPKI-ROUTER-MIB

58 objects
This MIB module contains management objects to support monitoring of the Resource Public Key Infrastructure (RPKI) protocol on routers. Copyright (c) 2013 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 6945; see the RFC itself for full legal notices.
Imported Objects
INET-ADDRESS-MIB-- RFC 2578 InetAddressType InetAddress InetAddressPrefixLength InetAutonomousSystemNumber InetPortNumber
SNMPv2-CONF-- RFC 2579 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP
SNMPv2-SMICounter32 Gauge32 Integer32 mib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32
SNMPv2-TC-- RFC 4001 TEXTUAL-CONVENTION TimeStamp
SYSAPPL-MIB-- RFC 2580 LongUtf8String
OIDNameAccessStatusDescription
1.3.6.1.2.1.218IdentityrpkiRtrMIBThis MIB module contains management objects to support monitoring of the Resource Public Key Infrastructure (RPKI) protocol on routers. Copyright (c) 2013 IETF…
1.3.6.1.2.1.218.0NoderpkiRtrNotifications
1.3.6.1.2.1.218.0.1NotificationrpkiRtrCacheServerConnectionStateChangecurrentThis notification signals a change in the status of an rpkiRtrCacheServerConnection. The management agent MUST throttle the generation of consecutive rpkiRtrCa…
1.3.6.1.2.1.218.0.2NotificationrpkiRtrCacheServerConnectionToGoStalecurrentThis notification signals that an RPKI cache server connection is about to go stale. It is suggested that this notification is generated when the value of the …
1.3.6.1.2.1.218.1NoderpkiRtrObjects
1.3.6.1.2.1.218.1.1ScalarrpkiRtrDiscontinuityTimerread-onlycurrentThis timer represents the timestamp (value of sysUpTime) at which time any of the Counter32 objects in this MIB module encountered a discontinuity. For objects…
1.3.6.1.2.1.218.1.2TablerpkiRtrCacheServerTablenot-accessiblecurrentThis table lists the RPKI cache servers known to this router/system.
1.3.6.1.2.1.218.1.2.1RowrpkiRtrCacheServerTableEntrynot-accessiblecurrentAn entry in the rpkiRtrCacheServerTable. It holds management attributes associated with one connection to a RPKI cache server. Implementers should be aware tha…
1.3.6.1.2.1.218.1.2.1.1ColumnrpkiRtrCacheServerRemoteAddressTypenot-accessiblecurrentThe network address type of the connection to this RPKI cache server. Note: Only IPv4, IPv6, and DNS support are required for read-only compliance with RFC 694…
1.3.6.1.2.1.218.1.2.1.2ColumnrpkiRtrCacheServerRemoteAddressnot-accessiblecurrentThe remote network address for this connection to this RPKI cache server. The format of the address is defined by the value of the corresponding instance of rp…
1.3.6.1.2.1.218.1.2.1.3ColumnrpkiRtrCacheServerRemotePortnot-accessiblecurrentThe remote port number for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.4ColumnrpkiRtrCacheServerLocalAddressTyperead-onlycurrentThe network address type of the connection to this RPKI cache server. Note: Only IPv4, IPv6, and DNS support are required for read-only compliance with RFC 694…
1.3.6.1.2.1.218.1.2.1.5ColumnrpkiRtrCacheServerLocalAddressread-onlycurrentThe local network address for this connection to this RPKI cache server. The format of the address is defined by the value of the corresponding instance of rpk…
1.3.6.1.2.1.218.1.2.1.6ColumnrpkiRtrCacheServerLocalPortread-onlycurrentThe local port number for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.7ColumnrpkiRtrCacheServerPreferenceread-onlycurrentThe routers' preference for this RPKI cache server. A lower value means more preferred. If two entries have the same preference, then the order is arbitrary. I…
1.3.6.1.2.1.218.1.2.1.8ColumnrpkiRtrCacheServerConnectionTyperead-onlycurrentThe connection type or transport security suite in use for this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.9ColumnrpkiRtrCacheServerConnectionStatusread-onlycurrentThe connection status for this entry (connection to this RPKI cache server).
1.3.6.1.2.1.218.1.2.1.10ColumnrpkiRtrCacheServerDescriptionread-onlycurrentFree form description/information for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.11ColumnrpkiRtrCacheServerMsgsReceivedread-onlycurrentNumber of messages received from this RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.12ColumnrpkiRtrCacheServerMsgsSentread-onlycurrentNumber of messages sent to this RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.13ColumnrpkiRtrCacheServerV4ActiveRecordsread-onlycurrentNumber of active IPv4 records received from this RPKI cache server via this connection.
1.3.6.1.2.1.218.1.2.1.14ColumnrpkiRtrCacheServerV4Announcementsread-onlycurrentThe number of IPv4 records announced by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.15ColumnrpkiRtrCacheServerV4Withdrawalsread-onlycurrentThe number of IPv4 records withdrawn by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.16ColumnrpkiRtrCacheServerV6ActiveRecordsread-onlycurrentNumber of active IPv6 records received from this RPKI cache server via this connection.
1.3.6.1.2.1.218.1.2.1.17ColumnrpkiRtrCacheServerV6Announcementsread-onlycurrentThe number of IPv6 records announced by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.18ColumnrpkiRtrCacheServerV6Withdrawalsread-onlycurrentThe number of IPv6 records withdrawn by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.19ColumnrpkiRtrCacheServerLatestSerialread-onlycurrentThe latest serial number of data received from this RPKI server on this connection. Note: this value wraps back to zero when it reaches its maximum value.
1.3.6.1.2.1.218.1.2.1.20ColumnrpkiRtrCacheServerSessionIDread-onlycurrentThe Session ID associated with the RPKI cache server at the other end of this connection.
1.3.6.1.2.1.218.1.2.1.21ColumnrpkiRtrCacheServerRefreshTimerread-onlycurrentThe number of seconds configured for the refresh timer for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.22ColumnrpkiRtrCacheServerTimeToRefreshread-onlycurrentThe number of seconds remaining before a new refresh is performed via a Serial Query to this cache server over this connection. A negative value means that the…
1.3.6.1.2.1.218.1.2.1.23ColumnrpkiRtrCacheServerIdread-onlycurrentThe unique ID for this connection. An implementation must make sure this ID is unique within this table. It is this ID that can be used to find entries in the …
1.3.6.1.2.1.218.1.3TablerpkiRtrCacheServerErrorsTablenot-accessiblecurrentThis table provides statistics on errors per RPKI peer connection. These can be used for debugging.
1.3.6.1.2.1.218.1.3.1RowrpkiRtrCacheServerErrorsTableEntrynot-accessiblecurrentAn entry in the rpkiCacheServerErrorTable. It holds management objects associated with errors codes that were received on the specified connection to a specifi…
1.3.6.1.2.1.218.1.3.1.1ColumnrpkiRtrCacheServerErrorsCorruptDataread-onlycurrentThe number of 'Corrupt Data' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpki…
1.3.6.1.2.1.218.1.3.1.2ColumnrpkiRtrCacheServerErrorsInternalErrorread-onlycurrentThe number of 'Internal Error' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rp…
1.3.6.1.2.1.218.1.3.1.3ColumnrpkiRtrCacheServerErrorsNoDataread-onlycurrentThe number of 'No Data Available' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of…
1.3.6.1.2.1.218.1.3.1.4ColumnrpkiRtrCacheServerErrorsInvalidRequestread-onlycurrentThe number of 'Invalid Request' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of r…
1.3.6.1.2.1.218.1.3.1.5ColumnrpkiRtrCacheServerErrorsUnsupportedVersionread-onlycurrentThe number of 'Unsupported Protocol Version' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by t…
1.3.6.1.2.1.218.1.3.1.6ColumnrpkiRtrCacheServerErrorsUnsupportedPduread-onlycurrentThe number of 'Unsupported PDU Type' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value…
1.3.6.1.2.1.218.1.3.1.7ColumnrpkiRtrCacheServerErrorsWithdrawalUnknownread-onlycurrentThe number of 'Withdrawal of Unknown Record' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by t…
1.3.6.1.2.1.218.1.3.1.8ColumnrpkiRtrCacheServerErrorsDuplicateAnnounceread-onlycurrentThe number of 'Duplicate Announcement Received' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated b…
1.3.6.1.2.1.218.1.4TablerpkiRtrPrefixOriginTablenot-accessiblecurrentThis table lists the prefixes that were announced by RPKI cache servers to this system. That is the prefixes and their Origin Autonomous System Number (ASN) as…
1.3.6.1.2.1.218.1.4.1RowrpkiRtrPrefixOriginTableEntrynot-accessiblecurrentAn entry in the rpkiRtrPrefixOriginTable. This represents one announced prefix. If a cache server is removed from the local configuration, any table rows assoc…
1.3.6.1.2.1.218.1.4.1.1ColumnrpkiRtrPrefixOriginAddressTypenot-accessiblecurrentThe network address type for this prefix. Note: Only IPv4 and IPv6 support are required for read-only compliance with RFC 6945.
1.3.6.1.2.1.218.1.4.1.2ColumnrpkiRtrPrefixOriginAddressnot-accessiblecurrentThe network address for this prefix. The format of the address is defined by the value of the corresponding instance of rpkiRtrPrefixOriginAddressType.
1.3.6.1.2.1.218.1.4.1.3ColumnrpkiRtrPrefixOriginMinLengthnot-accessiblecurrentThe minimum prefix length allowed for this prefix.
1.3.6.1.2.1.218.1.4.1.4ColumnrpkiRtrPrefixOriginMaxLengthnot-accessiblecurrentThe maximum prefix length allowed for this prefix. Note, this value must be greater or equal to the value of rpkiRtrPrefixOriginMinLength.
1.3.6.1.2.1.218.1.4.1.5ColumnrpkiRtrPrefixOriginASNnot-accessiblecurrentThe ASN that is authorized to announce the prefix or sub-prefixes covered by this entry.
1.3.6.1.2.1.218.1.4.1.6ColumnrpkiRtrPrefixOriginCacheServerIdread-onlycurrentThe unique ID of the connection to the cache server from which this announcement was received. That connection is identified/found by a matching value in attri…
1.3.6.1.2.1.218.2NoderpkiRtrConformance
1.3.6.1.2.1.218.2.1NoderpkiRtrCompliances
1.3.6.1.2.1.218.2.1.1CompliancerpkiRtrRFC6945ReadOnlyCompliancecurrentThe compliance statement for the rpkiRtrMIB module. There are only read-only objects in this MIB module, so the 'ReadOnly' in the name of this compliance state…
1.3.6.1.2.1.218.2.2NoderpkiRtrGroups
1.3.6.1.2.1.218.2.2.1GrouprpkiRtrCacheServerGroupcurrentThe collection of objects to monitor the RPKI peer connections.
1.3.6.1.2.1.218.2.2.2GrouprpkiRtrCacheServerErrorsGroupcurrentThe collection of objects that may help in debugging the communication between RPKI clients and cache servers.
1.3.6.1.2.1.218.2.2.3GrouprpkiRtrPrefixOriginGroupcurrentThe collection of objects that represent the prefix(es) and their validated Origin ASes.
1.3.6.1.2.1.218.2.2.4GrouprpkiRtrNotificationsGroupcurrentThe set of notifications to alert an NMS of change in connections to RPKI cache servers.
Type Definitions
NameSyntaxStatusDescription
RpkiRtrConnectionTypeINTEGER { ssh(1), tls(2), tcpMD5(3), tcpAO(4), tcp(5), ipsec(6), other(7) }currentThe connection type used between a router (as a client) and a cache server. The following types have been defined in RFC 6810: ssh(1) - Section 7.1; see also RFC 4252. tls(2) - Section 7.2; see also RFC 5246. tcpMD5(3) …