SIP-SERVER-MIB
59 objects
Session Initiation Protocol (SIP) Server MIB module. SIP is an application-layer signaling protocol for creating, modifying, and terminating multimedia sessions with one or more participants. These sessions include Internet multimedia conferences and Internet telephone calls. SIP is defined in RFC 3261 (June 2002). This MIB is defined for the management of SIP Proxy, Redirect, and Registrar Servers. A Proxy Server acts as both a client and a server. It accepts requests from other clients, either responding to them or passing them on to other servers, possibly after modification. A Redirect Server accepts requests from clients and returns zero or more addresses to that client. Unlike a User Agent Server, it does not accept calls. A Registrar is a server that accepts REGISTER requests. A Registrar is typically co-located with a Proxy or Redirect Server. Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4780; see the RFC itself for full legal notices.
Imported Objects
| INET-ADDRESS-MIB | -- RFC 2788 InetAddressType InetAddress |
| NETWORK-SERVICES-MIB | -- RFC 3411 applIndex |
| SNMP-FRAMEWORK-MIB | -- RFC 2580 SnmpAdminString |
| SNMPv2-CONF | -- RFC 2579 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | Counter32 Gauge32 mib-2 MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 2578 TruthValue DateAndTime TimeStamp |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.151 | IdentitysipServerMIB | Session Initiation Protocol (SIP) Server MIB module. SIP is an application-layer signaling protocol for creating, modifying, and terminating multimedia session… | ||
| 1.3.6.1.2.1.151.1 | NodesipServerMIBObjects | |||
| 1.3.6.1.2.1.151.1.1 | NodesipServerCfg | |||
| 1.3.6.1.2.1.151.1.1.1 | TablesipServerCfgTable | not-accessible | current | This table contains configuration objects applicable to SIP Redirect and Proxy Servers. |
| 1.3.6.1.2.1.151.1.1.1.1 | RowsipServerCfgEntry | not-accessible | current | A row of common configuration. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify the… |
| 1.3.6.1.2.1.151.1.1.1.1.1 | ColumnsipServerCfgHostAddressType | read-only | current | The type of Internet address by which the SIP server is reachable. |
| 1.3.6.1.2.1.151.1.1.1.1.2 | ColumnsipServerCfgHostAddress | read-only | current | This is the host portion of a SIP URI that is assigned to the SIP server. It MAY contain a fully qualified domain name or an IP address. The length of the valu… |
| 1.3.6.1.2.1.151.1.3 | NodesipServerProxyCfg | |||
| 1.3.6.1.2.1.151.1.3.1 | TablesipServerProxyCfgTable | not-accessible | current | This table contains configuration objects applicable to SIP Proxy Servers. |
| 1.3.6.1.2.1.151.1.3.1.1 | RowsipServerProxyCfgEntry | not-accessible | current | A row of common proxy configuration. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identi… |
| 1.3.6.1.2.1.151.1.3.1.1.1 | ColumnsipServerCfgProxyStatefulness | read-only | current | This object reflects the default mode of operation for the Proxy Server entity. A stateless proxy is a logical entity that does not maintain the client or serv… |
| 1.3.6.1.2.1.151.1.3.1.1.2 | ColumnsipServerCfgProxyRecursion | read-only | current | This object reflects whether or not the Proxy performs a recursive search on the Contacts provided in 3xx redirects. If the value of this object is 'true', a r… |
| 1.3.6.1.2.1.151.1.3.1.1.3 | ColumnsipServerCfgProxyRecordRoute | read-only | current | This object reflects whether or not the proxy adds itself to the Record-Route header as a default action. This header is used to list the proxies that insist o… |
| 1.3.6.1.2.1.151.1.3.1.1.4 | ColumnsipServerCfgProxyAuthMethod | read-only | current | This object reflects the authentication methods that MAY be used to authenticate request originators. bit 0 no authentication is performed bit 1 TLS is used bi… |
| 1.3.6.1.2.1.151.1.3.1.1.5 | ColumnsipServerCfgProxyAuthDefaultRealm | read-only | current | This object reflects the default realm value used in Proxy-Authenticate headers. Note that this MAY need to be stored per user, in which case, this default val… |
| 1.3.6.1.2.1.151.1.4 | NodesipServerProxyStats | |||
| 1.3.6.1.2.1.151.1.4.1 | TablesipServerProxyStatsTable | not-accessible | current | This table contains the statistics objects applicable to all SIP Proxy Servers in this system. |
| 1.3.6.1.2.1.151.1.4.1.1 | RowsipServerProxyStatsEntry | not-accessible | current | A row of summary statistics. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these… |
| 1.3.6.1.2.1.151.1.4.1.1.1 | ColumnsipServerProxyStatProxyReqFailures | read-only | current | This object contains the number of occurrences of unsupported options being specified in received Proxy-Require headers. Such occurrences result in a 420 Bad E… |
| 1.3.6.1.2.1.151.1.4.1.1.2 | ColumnsipServerProxyStatsDisconTime | read-only | current | The value of the sysUpTime object when the counters for the server statistics objects in this row last experienced a discontinuity. |
| 1.3.6.1.2.1.151.1.5 | NodesipServerRegCfg | |||
| 1.3.6.1.2.1.151.1.5.1 | TablesipServerRegCfgTable | not-accessible | current | This table contains configuration objects applicable to SIP Registrars. |
| 1.3.6.1.2.1.151.1.5.1.1 | RowsipServerRegCfgEntry | not-accessible | current | A row of common Registrar configuration. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely id… |
| 1.3.6.1.2.1.151.1.5.1.1.1 | ColumnsipServerRegMaxContactExpiryDuration | read-only | current | This object reflects the maximum expiry that may be requested by a User Agent for a particular Contact. User Agents can specify expiry using either an Expiry h… |
| 1.3.6.1.2.1.151.1.5.1.1.2 | ColumnsipServerRegMaxUsers | read-only | current | This object reflects the maximum number of users that the Registrar supports. The current number of users is reflected by sipServerRegCurrentUsers. |
| 1.3.6.1.2.1.151.1.5.1.1.3 | ColumnsipServerRegCurrentUsers | read-only | current | This object reflects the number of users currently registered with the Registrar. |
| 1.3.6.1.2.1.151.1.5.1.1.4 | ColumnsipServerRegDfltRegActiveInterval | read-only | current | This object reflects the default time interval the Registrar considers registrations to be active. The value is used to compute the Expires header in the REGIS… |
| 1.3.6.1.2.1.151.1.5.2 | TablesipServerRegUserTable | not-accessible | current | This table contains information on all users registered to each Registrar in this system. |
| 1.3.6.1.2.1.151.1.5.2.1 | RowsipServerRegUserEntry | not-accessible | current | This entry contains information for a single user registered to this Registrar. Each row represents those objects for a particular SIP server present in this s… |
| 1.3.6.1.2.1.151.1.5.2.1.1 | ColumnsipServerRegUserIndex | not-accessible | current | This object uniquely identifies a conceptual row in the table. |
| 1.3.6.1.2.1.151.1.5.2.1.2 | ColumnsipServerRegUserUri | read-only | current | This object contains the user's address-of-record. It is the main form by which the Registrar knows the user. The format is typically 'user@domain'. It is cont… |
| 1.3.6.1.2.1.151.1.5.2.1.3 | ColumnsipServerRegUserAuthenticationFailures | read-only | current | This object contains a count of the number of times the user has failed authentication. Discontinuities in the value of this counter can occur due to successfu… |
| 1.3.6.1.2.1.151.1.5.2.1.4 | ColumnsipServerRegUserDisconTime | read-only | current | The value of the sysUpTime object when the counters for the user registration statistics objects in this row last experienced a discontinuity. |
| 1.3.6.1.2.1.151.1.5.3 | TablesipServerRegContactTable | not-accessible | current | This table contains information on every location where a registered user (specified by sipServerRegUserIndex) wishes to be found (i.e., the user has provided … |
| 1.3.6.1.2.1.151.1.5.3.1 | RowsipServerRegContactEntry | not-accessible | current | This entry contains information for a single Contact. Multiple contacts may exist for a single user. Each row represents those objects for a particular SIP ser… |
| 1.3.6.1.2.1.151.1.5.3.1.1 | ColumnsipServerRegContactIndex | not-accessible | current | Along with the sipServerRegUserIndex, this object uniquely identifies a conceptual row in the table. |
| 1.3.6.1.2.1.151.1.5.3.1.2 | ColumnsipServerRegContactDisplayName | read-only | current | This object contains the display name for the Contact. For example, 'Santa at Home', or 'Santa on his Sled', corresponding to contact URIs of sip:BigGuy@exampl… |
| 1.3.6.1.2.1.151.1.5.3.1.3 | ColumnsipServerRegContactURI | read-only | current | This object contains either a SIP URI where the user can be contacted. This URI is normally returned to a client from a Redirect Server, or is used as the Requ… |
| 1.3.6.1.2.1.151.1.5.3.1.4 | ColumnsipServerRegContactLastUpdated | read-only | current | This object indicates the time when this contact information was accepted. If the contact information is updated via a subsequent REGISTER of the same informat… |
| 1.3.6.1.2.1.151.1.5.3.1.5 | ColumnsipServerRegContactExpiry | read-only | current | This object contains the date and time when the contact information will no longer be valid. Such times may be specified by the user at registration (i.e., Exp… |
| 1.3.6.1.2.1.151.1.5.3.1.6 | ColumnsipServerRegContactPreference | read-only | current | This object indicates a relative preference for the particular Contact header field value compared to other bindings for this address-of-record. A registering … |
| 1.3.6.1.2.1.151.1.6 | NodesipServerRegStats | |||
| 1.3.6.1.2.1.151.1.6.1 | TablesipServerRegStatsTable | not-accessible | current | This table contains the summary statistics objects applicable to all SIP Registrars in this system. |
| 1.3.6.1.2.1.151.1.6.1.1 | RowsipServerRegStatsEntry | not-accessible | current | A row of summary statistics. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these… |
| 1.3.6.1.2.1.151.1.6.1.1.1 | ColumnsipServerRegStatsAcceptedRegs | read-only | current | This object contains a count of the number of REGISTER requests that have been accepted (status code 200) by the Registrar. This includes additions of new cont… |
| 1.3.6.1.2.1.151.1.6.1.1.2 | ColumnsipServerRegStatsRejectedRegs | read-only | current | This object contains a count of the number REGISTER requests that have been rejected by the Registrar. Discontinuities in the value of this counter can occur a… |
| 1.3.6.1.2.1.151.1.6.1.1.3 | ColumnsipServerRegStatsDisconTime | read-only | current | The value of the sysUpTime object when the counters for the registrar statistics objects in this row last experienced a discontinuity. |
| 1.3.6.1.2.1.151.2 | NodesipServerMIBConformance | |||
| 1.3.6.1.2.1.151.2.1 | NodesipServerMIBCompliances | |||
| 1.3.6.1.2.1.151.2.1.1 | CompliancesipServerProxyServerCompliance | current | The compliance statement for SIP entities acting as Proxy Servers. | |
| 1.3.6.1.2.1.151.2.1.2 | CompliancesipRedirectServerCompliance | current | The compliance statement for SIP entities acting as Redirect Servers. | |
| 1.3.6.1.2.1.151.2.1.3 | CompliancesipServerRegistrarServerCompliance | current | The compliance statement for SIP entities acting as Registrars. | |
| 1.3.6.1.2.1.151.2.2 | NodesipServerMIBGroups | |||
| 1.3.6.1.2.1.151.2.2.1 | GroupsipServerConfigGroup | current | A collection of objects providing configuration common to SIP Proxy and Redirect servers. | |
| 1.3.6.1.2.1.151.2.2.2 | GroupsipServerProxyConfigGroup | current | A collection of objects providing configuration for SIP Proxy servers. | |
| 1.3.6.1.2.1.151.2.2.3 | GroupsipServerProxyStatsGroup | current | A collection of objects providing statistics for SIP Proxy servers. | |
| 1.3.6.1.2.1.151.2.2.4 | GroupsipServerRegistrarConfigGroup | current | A collection of objects providing configuration for SIP Registrars. | |
| 1.3.6.1.2.1.151.2.2.5 | GroupsipServerRegistrarStatsGroup | current | A collection of objects providing statistics for SIP Registrars. | |
| 1.3.6.1.2.1.151.2.2.6 | GroupsipServerRegistrarUsersGroup | current | A collection of objects related to registered users. |