MIB Viewer

SIP-TC-MIB

5 objects
Session Initiation Protocol (SIP) MIB TEXTUAL-CONVENTION module used by other SIP-related MIB Modules. Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4780; see the RFC itself for full legal notices.
Imported Objects
SNMPv2-SMImib-2 MODULE-IDENTITY
SNMPv2-TC-- RFC 2578 TEXTUAL-CONVENTION
OIDNameAccessStatusDescription
1.3.6.1.2.1.148IdentitysipTCSession Initiation Protocol (SIP) MIB TEXTUAL-CONVENTION module used by other SIP-related MIB Modules. Copyright (C) The IETF Trust (2007). This version of thi…
Type Definitions
NameSyntaxStatusDescription
SipTCEntityRoleBITS { other(0), userAgent(1), proxyServer(2), redirectServer(3), registrarServer(4) }currentThis convention defines the role of a SIP entity. Examples of SIP entities are proxies, user agents, redirect servers, registrars, or combinations of the above. User Agent (UA): A logical entity that can act as both a u…
SipTCMethodNameOCTET STRING (SIZE (1..100))currentThis TEXTUAL-CONVENTION is a string that uniquely identifies a SIP method. The scope of uniqueness is the context of all defined SIP methods. Experimental support of extension methods is acceptable and expected. Extensi…
SipTCOptionTagHeadersBITS { require(0), proxyRequire(1), supported(2), unsupported(3) }currentThis convention defines the header fields that use the option tags per Section 19.2 of RFC 3261. These tags are used in Require (Section 20.32), Proxy-Require (Section 20.29), Supported (Section 20.37), and Unsupported …
SipTCTransportProtocolBITS { other(0), udp(1), tcp(2), sctp(3), tlsTcp(4), tlsSctp(5) }currentThis convention is a bit map. Each bit represents a transport protocol. If a bit has value 1, then that selected transport protocol is in some way dependent on the context of the object using this convention. If a bit h…