MIB Viewer

SMF-MIB

97 objects
This MIB module contains managed object definitions for the MANET SMF RSSA process defined in: Macker, J., Ed., Simplified Multicast Forwarding, RFC 6621, May 2012. Copyright (c) 2014 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
Imported Objects
IANA-SMF-MIB-- RFC 4001 IANAsmfOpModeIdTC IANAsmfRssaIdTC
IF-MIB-- RFC 2580 InterfaceIndexOrZero ifName
INET-ADDRESS-MIB-- RFC 3411 InetAddress InetAddressPrefixLength InetAddressType
SNMP-FRAMEWORK-MIB-- RFC 2863 SnmpAdminString
SNMPv2-CONF-- RFC 2579 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP
SNMPv2-SMICounter32 experimental Integer32 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE TimeTicks
SNMPv2-TC-- RFC 2578 TEXTUAL-CONVENTION RowStatus TruthValue
OIDNameAccessStatusDescription
1.3.6.1.3.126IdentitysmfMIBThis MIB module contains managed object definitions for the MANET SMF RSSA process defined in: Macker, J., Ed., Simplified Multicast Forwarding, RFC 6621, May …
1.3.6.1.3.126.0NodesmfMIBNotifications
1.3.6.1.3.126.0.0NodesmfMIBNotifObjects
1.3.6.1.3.126.0.0.1NotificationsmfNotifAdminStatusChangecurrentsmfCfgAdminStatusChange is a notification sent when the 'smfCfgAdminStatus' object changes.
1.3.6.1.3.126.0.0.2NotificationsmfNotifConfiguredOpModeChangecurrentsmfNotifConfiguredOpModeChange is a notification sent when the 'smfCfgOperationalMode' object changes.
1.3.6.1.3.126.0.0.3NotificationsmfNotifIfAdminStatusChangecurrentsmfCfgIfAdminStatusChange is a notification sent when the 'smfCfgIfAdminStatus' object changes.
1.3.6.1.3.126.0.0.4NotificationsmfNotifDpdMemoryOverflowEventcurrentsmfNotifDpdMemoryOverflowEvents is sent when the number of memory overflow events exceeds the 'smfNotifDpdMemoryOverflowThreshold' within the previous number o…
1.3.6.1.3.126.0.1NodesmfMIBNotifControl
1.3.6.1.3.126.0.1.1ScalarsmfNotifDpdMemoryOverflowThresholdread-writecurrentA threshold value for the 'smfNotifDpdmemoryOverflowEvents' object. If the number of occurrences exceeds this threshold within the previous number of seconds '…
1.3.6.1.3.126.0.1.2ScalarsmfNotifDpdMemoryOverflowWindowread-writecurrentA time window value for the 'smfNotifDpdmemoryOverflowEvents' object. If the number of occurrences exceeds the 'smfNotifDpdMemoryOverflowThreshold' within the …
1.3.6.1.3.126.1NodesmfMIBObjects
1.3.6.1.3.126.1.1NodesmfCapabilitiesGroup
1.3.6.1.3.126.1.1.1TablesmfCapabilitiesTablenot-accessiblecurrentThe smfCapabilitiesTable identifies the resident set of SMF Operational Modes and RSSA combinations that can run on this forwarder.
1.3.6.1.3.126.1.1.1.1RowsmfCapabilitiesEntrynot-accessiblecurrentInformation about a particular operational mode and RSSA combination.
1.3.6.1.3.126.1.1.1.1.1ColumnsmfCapabilitiesIndexnot-accessiblecurrentThe index for this entry; a unique value, greater than zero, for each combination of a particular operational mode and RSSA available on this device. It is rec…
1.3.6.1.3.126.1.1.1.1.2ColumnsmfCapabilitiesOpModeIDread-onlycurrentThis object identifies the particular operational mode for this device.
1.3.6.1.3.126.1.1.1.1.3ColumnsmfCapabilitiesRssaIDread-onlycurrentThis object identifies the particular RSSA algorithm in this MIB module. Example RSSAs are found in the appendix of RFC 6621.
1.3.6.1.3.126.1.2NodesmfConfigurationGroup
1.3.6.1.3.126.1.2.1ScalarsmfCfgAdminStatusread-writecurrentThe configured status of the SMF process on this device. 'enabled(1)' means that SMF is configured to run on this device. 'disabled(2)' means that the SMF proc…
1.3.6.1.3.126.1.2.2ScalarsmfCfgSmfSysUpTimeread-onlycurrentThe time (in hundredths of a second) since the system SMF process was last re-initialized. The SMF process is re-initialized when the value of the 'smfCfgAdmin…
1.3.6.1.3.126.1.2.3ScalarsmfCfgRouterIDAddrTyperead-writecurrentThe address type of the address used for the SMF ID of this router as specified in the 'smfCfgRouterID' next. Only the values ipv4(1) and ipv6(2) are supported…
1.3.6.1.3.126.1.2.4ScalarsmfCfgRouterIDread-writecurrentThe IP address used as the SMF router ID. This can be set by the management station. If not explicitly set, then the device SHOULD select a routable IP address…
1.3.6.1.3.126.1.2.5ScalarsmfCfgOperationalModeread-writecurrentThe SMF RSS node operational mode and RSSA combination active on this local forwarder. This object is defined to be equal to the smfCapabilitiesIndex, which id…
1.3.6.1.3.126.1.2.6ScalarsmfCfgRssaMemberread-writecurrentThe RSSA downselects a set of forwarders for multicast forwarding. Sometimes it is useful to force an agent to be included or excluded from the resulting RSS. …
1.3.6.1.3.126.1.2.7ScalarsmfCfgIpv4Dpdread-writecurrentThe current method for IPv4 duplicate packet detection. The value 'hashBased(1)' indicates that the router's duplicate packet detection is based upon comparing…
1.3.6.1.3.126.1.2.8ScalarsmfCfgIpv6Dpdread-writecurrentThe current method for IPv6 duplicate packet detection. The values indicate the type of method used for duplicate packet detection as described the previous de…
1.3.6.1.3.126.1.2.9ScalarsmfCfgMaxPktLifetimeread-writecurrentThe estimate of the network packet traversal time. This object is persistent and, when written, the entity SHOULD save the change to non-volatile storage.
1.3.6.1.3.126.1.2.10ScalarsmfCfgDpdEntryMaxLifetimeread-writecurrentThe maximum lifetime of a cached DPD record in the local device storage. If the memory is running low prior to the MaxLifetime being exceeded, the local SMF de…
1.3.6.1.3.126.1.2.11ScalarsmfCfgNhdpRssaMesgTLVIncludedread-writecurrentIndicates whether or not the associated NHDP messages include the RSSA Message TLV. This is an optional SMF operational setting. The value 'true(1)' indicates …
1.3.6.1.3.126.1.2.12ScalarsmfCfgNhdpRssaAddrBlockTLVIncludedread-writecurrentIndicates whether or not the associated NHDP messages include the RSSA Address Block TLV. This is an optional SMF operational setting. The value 'true(1)' indi…
1.3.6.1.3.126.1.2.13TablesmfCfgAddrForwardingTablenot-accessiblecurrentThe smfCfgAddrForwardingTable is essentially a filter table (if populated) that identifies addresses/packets to be forwarded via the local SMF flooding process…
1.3.6.1.3.126.1.2.13.1RowsmfCfgAddrForwardingEntrynot-accessiblecurrentAn entry (conceptual row) containing the information on a particular multicast scope.
1.3.6.1.3.126.1.2.13.1.1ColumnsmfCfgAddrForwardingIndexnot-accessiblecurrentThis object identifies a unique entry for a forwarding group. The index for this entry is a unique value, greater than zero, for each row. It is recommended th…
1.3.6.1.3.126.1.2.13.1.2ColumnsmfCfgAddrForwardingGroupNameread-createcurrentThis object identifies a group name for a set of row entries in order to administratively associate a set of address ranges. If there is no group name or this …
1.3.6.1.3.126.1.2.13.1.3ColumnsmfCfgAddrForwardingAddrTyperead-createcurrentThe type of the addresses in the multicast forwarding ranges identified by this table. Only the values ipv4(1) and ipv6(2) are supported. This object is persis…
1.3.6.1.3.126.1.2.13.1.4ColumnsmfCfgAddrForwardingAddressread-createcurrentThe multicast group address that, when combined with smfCfgAddrForwardingAddrPrefixLength, gives the group prefix for this forwarding range. The InetAddressTyp…
1.3.6.1.3.126.1.2.13.1.5ColumnsmfCfgAddrForwardingAddrPrefixLengthread-createcurrentThe length in bits of the mask that, when combined with smfCfgAddrForwardingAddress, gives the group prefix for this forwarding range. This object is persisten…
1.3.6.1.3.126.1.2.13.1.6ColumnsmfCfgAddrForwardingStatusread-createcurrentThe status of this row, by which new entries may be created, or old entries deleted from this table.
1.3.6.1.3.126.1.2.14TablesmfCfgInterfaceTablenot-accessiblecurrentThe SMF Interface Table describes the SMF interfaces that are participating in the SMF packet forwarding process. The ifIndex is from the interfaces group defi…
1.3.6.1.3.126.1.2.14.1RowsmfCfgInterfaceEntrynot-accessiblecurrentThe SMF interface entry describes one SMF interface as indexed by its ifIndex. The objects in this table are persistent and, when written, the device SHOULD sa…
1.3.6.1.3.126.1.2.14.1.1ColumnsmfCfgIfIndexnot-accessiblecurrentThe ifIndex for this SMF interface. This value MUST correspond to an ifIndex referring to a valid entry in the Interfaces Table. If the manager attempts to cre…
1.3.6.1.3.126.1.2.14.1.2ColumnsmfCfgIfAdminStatusread-createcurrentThe SMF interface's administrative status. The value 'enabled' denotes that the interface is running the SMF forwarding process. The value 'disabled' denotes t…
1.3.6.1.3.126.1.2.14.1.3ColumnsmfCfgIfSmfUpTimeread-onlycurrentThe time (in hundredths of a second) since this interface SMF process was last re-initialized. The interface SMF process is re-initialized when the value of th…
1.3.6.1.3.126.1.2.14.1.4ColumnsmfCfgIfRowStatusread-createcurrentThis object permits management of this table by facilitating actions such as row creation, construction, and destruction. The value of this object has no effec…
1.3.6.1.3.126.1.3NodesmfStateGroup
1.3.6.1.3.126.1.3.1ScalarsmfStateNodeRsStatusIncludedread-onlycurrentThe current status of the SMF node in the context of the MANETs relay set. A value of 'true(1)' indicates that the node is currently part of the MANET Relay Se…
1.3.6.1.3.126.1.3.2ScalarsmfStateDpdMemoryOverflowread-onlycurrentThe number of DPD records that had to be flushed to prevent memory overruns for caching of these records. The number of records to be flushed upon a buffer ove…
1.3.6.1.3.126.1.3.3TablesmfStateNeighborTablenot-accessiblecurrentThe SMF StateNeighborTable describes the current one-hop neighbor nodes, their address and SMF RSSA, and the interface on which they can be reached.
1.3.6.1.3.126.1.3.3.1RowsmfStateNeighborEntrynot-accessiblecurrentThe SMF Neighbor Table contains the set of one-hop neighbors, the interface they are reachable on, and the SMF RSSA they are currently running.
1.3.6.1.3.126.1.3.3.1.1ColumnsmfStateNeighborIpAddrTypenot-accessiblecurrentThe one-hop neighbor IP address type. Only the values 'ipv4(1)' and 'ipv6(2)' are supported.
1.3.6.1.3.126.1.3.3.1.2ColumnsmfStateNeighborIpAddrnot-accessiblecurrentThe one-hop neighbor Inet IPv4 or IPv6 address. Only IPv4 and IPv6 addresses are supported.
1.3.6.1.3.126.1.3.3.1.3ColumnsmfStateNeighborPrefixLennot-accessiblecurrentThe prefix length. This is a decimal value that indicates the number of contiguous, higher-order bits of the address that make up the network portion of the ad…
1.3.6.1.3.126.1.3.3.1.4ColumnsmfStateNeighborRSSAread-onlycurrentThe current RSSA running on the neighbor.
1.3.6.1.3.126.1.3.3.1.6ColumnsmfStateNeighborNextHopInterfaceread-onlycurrentThe interface ifIndex over which the neighbor is reachable in one-hop.
1.3.6.1.3.126.1.4NodesmfPerformanceGroup
1.3.6.1.3.126.1.4.1NodesmfPerfGobalGroup
1.3.6.1.3.126.1.4.1.1ScalarsmfPerfIpv4MultiPktsRecvTotalread-onlycurrentA counter of the total number of multicast IPv4 packets received by the device and delivered to the SMF process. There is the potential for a counter discontin…
1.3.6.1.3.126.1.4.1.2ScalarsmfPerfIpv4MultiPktsForwardedTotalread-onlycurrentA counter of the total number of multicast IPv4 packets forwarded by the device. There is the potential for a counter discontinuity in this object if the syste…
1.3.6.1.3.126.1.4.1.3ScalarsmfPerfIpv4DuplMultiPktsDetectedTotalread-onlycurrentA counter of the total number of duplicate multicast IPv4 packets detected by the device. There is the potential for a counter discontinuity in this object if …
1.3.6.1.3.126.1.4.1.4ScalarsmfPerfIpv4DroppedMultiPktsTTLExceededTotalread-onlycurrentA counter of the total number of dropped multicast IPv4 packets by the device due to Time to Live (TTL) exceeded. There is the potential for a counter disconti…
1.3.6.1.3.126.1.4.1.5ScalarsmfPerfIpv4TTLLargerThanPreviousTotalread-onlycurrentA counter of the total number of IPv4 packets received that have a TTL larger than that of a previously received identical packet. There is the potential for a…
1.3.6.1.3.126.1.4.1.6ScalarsmfPerfIpv6MultiPktsRecvTotalread-onlycurrentA counter of the total number of multicast IPv6 packets received by the device and delivered to the SMF process. There is the potential for a counter discontin…
1.3.6.1.3.126.1.4.1.7ScalarsmfPerfIpv6MultiPktsForwardedTotalread-onlycurrentA counter of the total number of multicast IPv6 packets forwarded by the device. There is the potential for a counter discontinuity in this object if the syste…
1.3.6.1.3.126.1.4.1.8ScalarsmfPerfIpv6DuplMultiPktsDetectedTotalread-onlycurrentA counter of the total number of duplicate multicast IPv6 packets detected by the device. There is the potential for a counter discontinuity in this object if …
1.3.6.1.3.126.1.4.1.9ScalarsmfPerfIpv6DroppedMultiPktsTTLExceededTotalread-onlycurrentA counter of the total number of dropped multicast IPv6 packets by the device due to TTL exceeded. There is the potential for a counter discontinuity in this o…
1.3.6.1.3.126.1.4.1.10ScalarsmfPerfIpv6TTLLargerThanPreviousTotalread-onlycurrentA counter of the total number of IPv6 packets received that have a TTL larger than that of a previously received identical packet. There is the potential for a…
1.3.6.1.3.126.1.4.1.11ScalarsmfPerfIpv6HAVAssistsReqdTotalread-onlycurrentA counter of the total number of IPv6 packets received that required the Hash Assist Value (HAV) for DPD. There is the potential for a counter discontinuity in…
1.3.6.1.3.126.1.4.1.12ScalarsmfPerfIpv6DpdHeaderInsertionsTotalread-onlycurrentA counter of the total number of IPv6 packets received that the device inserted the DPD header option. There is the potential for a counter discontinuity in th…
1.3.6.1.3.126.1.4.2NodesmfPerfInterfaceGroup
1.3.6.1.3.126.1.4.2.1TablesmfPerfIpv4InterfacePerfTablenot-accessiblecurrentThe SMF Interface Performance Table describes the SMF counters per interface.
1.3.6.1.3.126.1.4.2.1.1RowsmfPerfIpv4InterfacePerfEntrynot-accessiblecurrentThe SMF Interface Performance entry describes the statistics for a particular node interface.
1.3.6.1.3.126.1.4.2.1.1.1ColumnsmfPerfIpv4MultiPktsRecvPerIfread-onlycurrentA counter of the number of multicast IP packets received by the SMF process on this device on this interface. There is the potential for a counter discontinuit…
1.3.6.1.3.126.1.4.2.1.1.2ColumnsmfPerfIpv4MultiPktsForwardedPerIfread-onlycurrentA counter of the number of multicast IP packets forwarded by the SMF process on this device on this interface. There is the potential for a counter discontinui…
1.3.6.1.3.126.1.4.2.1.1.3ColumnsmfPerfIpv4DuplMultiPktsDetectedPerIfread-onlycurrentA counter of the number of duplicate multicast IP packets detected by the SMF process on this device on this interface. There is the potential for a counter di…
1.3.6.1.3.126.1.4.2.1.1.4ColumnsmfPerfIpv4DroppedMultiPktsTTLExceededPerIfread-onlycurrentA counter of the total number of dropped multicast IPv4 packets by the SMF process on this device on this interface due to TTL exceeded. There is the potential…
1.3.6.1.3.126.1.4.2.1.1.5ColumnsmfPerfIpv4TTLLargerThanPreviousPerIfread-onlycurrentA counter of the total number of IPv4 packets received by the SMF process on this device on this interface that have a TTL larger than that of a previously rec…
1.3.6.1.3.126.1.4.2.2TablesmfPerfIpv6InterfacePerfTablenot-accessiblecurrentThe SMF Interface Performance Table describes the SMF counters per interface.
1.3.6.1.3.126.1.4.2.2.1RowsmfPerfIpv6InterfacePerfEntrynot-accessiblecurrentThe SMF Interface Performance entry describes the counters for a particular node interface.
1.3.6.1.3.126.1.4.2.2.1.1ColumnsmfPerfIpv6MultiPktsRecvPerIfread-onlycurrentA counter of the number of multicast IP packets received by the SMF process on this device on this interface. There is the potential for a counter discontinuit…
1.3.6.1.3.126.1.4.2.2.1.2ColumnsmfPerfIpv6MultiPktsForwardedPerIfread-onlycurrentA counter of the number of multicast IP packets forwarded by the SMF process on this device on this interface. There is the potential for a counter discontinui…
1.3.6.1.3.126.1.4.2.2.1.3ColumnsmfPerfIpv6DuplMultiPktsDetectedPerIfread-onlycurrentA counter of the number of duplicate multicast IP packets detected by the SMF process on this device on this interface. There is the potential for a counter di…
1.3.6.1.3.126.1.4.2.2.1.4ColumnsmfPerfIpv6DroppedMultiPktsTTLExceededPerIfread-onlycurrentA counter of the number of dropped multicast IP packets by the SMF process on this device on this interface due to TTL exceeded. There is the potential for a c…
1.3.6.1.3.126.1.4.2.2.1.5ColumnsmfPerfIpv6TTLLargerThanPreviousPerIfread-onlycurrentA counter of the total number of IPv6 packets received that have a TTL larger than that of a previously received identical packet by the SMF process on this de…
1.3.6.1.3.126.1.4.2.2.1.6ColumnsmfPerfIpv6HAVAssistsReqdPerIfread-onlycurrentA counter of the total number of IPv6 packets received by the SMF process on this device on this interface that required the HAV assist for DPD. There is the p…
1.3.6.1.3.126.1.4.2.2.1.7ColumnsmfPerfIpv6DpdHeaderInsertionsPerIfread-onlycurrentA counter of the total number of IPv6 packets received by the SMF process on this device on this interface that the device inserted the DPD header option. Ther…
1.3.6.1.3.126.2NodesmfMIBConformance
1.3.6.1.3.126.2.1NodesmfCompliances
1.3.6.1.3.126.2.1.1CompliancesmfBasicCompliancecurrentThe basic implementation requirements for managed network entities that implement the SMF RSSA process.
1.3.6.1.3.126.2.1.2CompliancesmfFullCompliancecurrentThe full implementation requirements for managed network entities that implement the SMF RSSA process.
1.3.6.1.3.126.2.2NodesmfMIBGroups
1.3.6.1.3.126.2.2.1GroupsmfCapabObjectsGroupcurrentSet of SMF configuration objects implemented in this module.
1.3.6.1.3.126.2.2.2GroupsmfConfigObjectsGroupcurrentSet of SMF configuration objects implemented in this module.
1.3.6.1.3.126.2.2.3GroupsmfStateObjectsGroupcurrentSet of SMF state objects implemented in this module.
1.3.6.1.3.126.2.2.4GroupsmfPerfObjectsGroupcurrentSet of SMF performance objects implemented in this module by total and per interface.
1.3.6.1.3.126.2.2.5GroupsmfNotifObjectsGroupcurrentSet of SMF notification control objects implemented in this module.
1.3.6.1.3.126.2.2.6GroupsmfNotificationsGroupcurrentSet of SMF notifications implemented in this module.
Type Definitions
NameSyntaxStatusDescription
SmfStatusINTEGER { enabled (1), disabled (2) }currentAn indication of the operability of an SMF function or feature. For example, the status of an interface: 'enabled' indicates that this interface is performing SMF functions and 'disabled' indicates that it is not. Simil…