MIB Viewer

SSPM-MIB

75 objects
This SSPM MIB module is applicable to probes implementing Synthetic Source for Performance Monitoring functions. Copyright (C) The Internet Society (2005). This version of this MIB module is part of RFC 4149; see the RFC itself for full legal notices.
OIDNameAccessStatusDescription
1.3.6.1.2.1.16.28IdentitysspmMIBThis SSPM MIB module is applicable to probes implementing Synthetic Source for Performance Monitoring functions. Copyright (C) The Internet Society (2005). Thi…
1.3.6.1.2.1.16.28.1NodesspmMIBObjects
1.3.6.1.2.1.16.28.1.1NodesspmGeneral
1.3.6.1.2.1.16.28.1.1.1ScalarsspmGeneralClockResolutionread-onlycurrentA read-only variable indicating the resolution of the measurements possible by this device.
1.3.6.1.2.1.16.28.1.1.2ScalarsspmGeneralClockMaxSkewread-onlycurrentA read-only variable indicating the maximum offset error due to skew of the local clock over the time interval 86400 seconds, in seconds.
1.3.6.1.2.1.16.28.1.1.3ScalarsspmGeneralClockSourceread-onlycurrentA read-only variable indicating the source of the clock. This is provided to allow a user to determine how accurate the timing mechanism is compared with other…
1.3.6.1.2.1.16.28.1.1.4ScalarsspmGeneralMinFrequencyread-onlycurrentA read-only variable that indicates the devices' capability for the minimum supported sspmSourceFrequency. If sspmSourceFrequency is set to a value lower than …
1.3.6.1.2.1.16.28.1.1.5TablesspmCapabilitiesTablenot-accessiblecurrentThe table of SSPM capabilities.
1.3.6.1.2.1.16.28.1.1.5.1RowsspmCapabilitiesEntrynot-accessiblecurrentDetails about a particular SSPM capability.
1.3.6.1.2.1.16.28.1.1.5.1.1ColumnsspmCapabilitiesInstanceread-onlycurrentIndicates whether SSPM configuration of the corresponding AppLocalIndex is supported by this device. Generally, entries in this table are only made by the devi…
1.3.6.1.2.1.16.28.1.2NodesspmSource
1.3.6.1.2.1.16.28.1.2.1TablesspmSourceProfileTablenot-accessiblecurrentThe table of SSPM Source Profiles configured.
1.3.6.1.2.1.16.28.1.2.1.1RowsspmSourceProfileEntrynot-accessiblecurrentDetails about a particular SSPM Source Profile configuration. Entries must exist in this table in order to be referenced by rows in the sspmSourceControlTable.
1.3.6.1.2.1.16.28.1.2.1.1.1ColumnsspmSourceProfileInstancenot-accessiblecurrentAn arbitrary index.
1.3.6.1.2.1.16.28.1.2.1.1.2ColumnsspmSourceProfileTyperead-createcurrentThe AppLocalIndex value that uniquely identifies the measurement per the APM-MIB. In order to create a row in this table, there must be a corresponding row in …
1.3.6.1.2.1.16.28.1.2.1.1.3ColumnsspmSourceProfilePacketSizeread-createcurrentThe size of packet to be transmitted in bytes. The size accounts for all data within the IPv4 or IPv6 payloads, excluding the IP headers, IP header options and…
1.3.6.1.2.1.16.28.1.2.1.1.4ColumnsspmSourceProfilePacketFillTyperead-createcurrentIndicates how the packet is filled. 'random' indicates that the packet contains random data patterns. This is probe and implementation dependent. 'pattern' ind…
1.3.6.1.2.1.16.28.1.2.1.1.5ColumnsspmSourceProfilePacketFillValueread-createcurrentThe string value with which to fill the packet. If sspmSourceProfilePacketFillType is set to 'pattern', then this pattern is repeated until the packet is sspmS…
1.3.6.1.2.1.16.28.1.2.1.1.6ColumnsspmSourceProfileTOSread-createcurrentRepresents the TOS field in the IP packet header. The value of this object defaults to zero if not set.
1.3.6.1.2.1.16.28.1.2.1.1.7ColumnsspmSourceProfileFlowLabelread-createcurrentThis object is used to specify the Flow Label in a IPv6 packet (RFC 2460) to force special handling by the IPv6 routers; e.g., non-default quality-of-service h…
1.3.6.1.2.1.16.28.1.2.1.1.8ColumnsspmSourceProfileLooseSrcRteFillread-createcurrentIn the event that the test should run over a specific route, the intent is to force the route using the Loose Source Route option in IPv4 [RFC791] and IPv6 [RF…
1.3.6.1.2.1.16.28.1.2.1.1.9ColumnsspmSourceProfileLooseSrcRteLenread-createcurrentIn the event that the test should run over a specific route, the intent is to force the route. This attribute specifies the length of data to be copied from th…
1.3.6.1.2.1.16.28.1.2.1.1.10ColumnsspmSourceProfileTTLread-createcurrentIf non-zero, this specifies the value to place into the TTL field on transmission.
1.3.6.1.2.1.16.28.1.2.1.1.11ColumnsspmSourceProfileNoFragread-createcurrentWhen true, the 'Don't Fragment Bit' should be set on the packet header.
1.3.6.1.2.1.16.28.1.2.1.1.12ColumnsspmSourceProfile8021Taggingread-createcurrentIEEE 802.1Q tagging used in IEEE 802.1D bridged environments. A value of -1 indicates that the packets are untagged. A value of 0 to 65535 is the value of the …
1.3.6.1.2.1.16.28.1.2.1.1.13ColumnsspmSourceProfileUsernameread-createcurrentAn optional username used by the application protocol.
1.3.6.1.2.1.16.28.1.2.1.1.14ColumnsspmSourceProfilePasswordread-createcurrentAn optional password used by the application protocol.
1.3.6.1.2.1.16.28.1.2.1.1.15ColumnsspmSourceProfileParameterread-createcurrentAn optional parameter used by the application protocol. For DNS, this would be the hostname or IP. For HTTP, this would be the URL. For nntp, this would be the…
1.3.6.1.2.1.16.28.1.2.1.1.16ColumnsspmSourceProfileOwnerread-createcurrentName of the management station/application that set up the profile.
1.3.6.1.2.1.16.28.1.2.1.1.17ColumnsspmSourceProfileStorageTyperead-createcurrentThe storage type of this sspmSourceProfileEntry. If the value of this object is 'permanent', no objects in this row need to be writable.
1.3.6.1.2.1.16.28.1.2.1.1.18ColumnsspmSourceProfileStatusread-createcurrentStatus of this profile. An entry may not exist in the active state unless all objects in the entry have an appropriate value. Once this object is set to active…
1.3.6.1.2.1.16.28.1.2.2TablesspmSourceControlTablenot-accessiblecurrentThe table of SSPM measurements configured.
1.3.6.1.2.1.16.28.1.2.2.1RowsspmSourceControlEntrynot-accessiblecurrentDetails about a particular SSPM configuration.
1.3.6.1.2.1.16.28.1.2.2.1.1ColumnsspmSourceControlInstancenot-accessiblecurrentAn arbitrary index.
1.3.6.1.2.1.16.28.1.2.2.1.2ColumnsspmSourceControlProfileread-createcurrentA pointer to the profile (sspmSourceProfileEntry) that this control entry uses to define the test being performed.
1.3.6.1.2.1.16.28.1.2.2.1.3ColumnsspmSourceControlSrcread-createcurrentThe ifIndex where the packet should originate from the probe (if it matters). A value of zero indicates that it does not matter and that the device decides.
1.3.6.1.2.1.16.28.1.2.2.1.4ColumnsspmSourceControlDestAddrTyperead-createcurrentThe type of Internet address by which the destination is accessed.
1.3.6.1.2.1.16.28.1.2.2.1.5ColumnsspmSourceControlDestAddrread-createcurrentThe Internet address for the destination. The formatting of this object is controlled by the sspmSourceControlDestAddrType object above. When this object conta…
1.3.6.1.2.1.16.28.1.2.2.1.6ColumnsspmSourceControlEnabledread-createcurrentWhen set to 'true', this test is enabled. When set to 'false', it is disabled.
1.3.6.1.2.1.16.28.1.2.2.1.7ColumnsspmSourceControlTimeOutread-createcurrentTimeout value for the measurement response. If no response is received in the time specified, then the test fails.
1.3.6.1.2.1.16.28.1.2.2.1.8ColumnsspmSourceControlSamplingDistread-createcurrentWhen this attribute is set to 'deterministic', then packets are generated at with a fixed inter-packet injection time specified by sspmSourceFrequency. When th…
1.3.6.1.2.1.16.28.1.2.2.1.9ColumnsspmSourceControlFrequencyread-createcurrentThe inverse of this value is the rate at which packets are generated. Refer to sspmSourceSamplingDistribution. If the value set is less than the value of sspmG…
1.3.6.1.2.1.16.28.1.2.2.1.10ColumnsspmSourceControlFirstSeqNumread-createcurrentThe first sequence number of packets to be transmitted.
1.3.6.1.2.1.16.28.1.2.2.1.11ColumnsspmSourceControlLastSeqNumread-onlycurrentThe last sequence number transmitted. This value is updated by the agent after packet generation.
1.3.6.1.2.1.16.28.1.2.2.1.12ColumnsspmSourceControlOwnerread-createcurrentName of the management station/application that set up the test.
1.3.6.1.2.1.16.28.1.2.2.1.13ColumnsspmSourceControlStorageTyperead-createcurrentThe storage type of this sspmSourceControlEntry. If the value of this object is 'permanent', no objects in this row need to be writable.
1.3.6.1.2.1.16.28.1.2.2.1.14ColumnsspmSourceControlStatusread-createcurrentStatus of this source control entry. An entry may not exist in the active state unless all objects in the entry have an appropriate value. When this attribute …
1.3.6.1.2.1.16.28.1.5NodesspmSink
1.3.6.1.2.1.16.28.1.5.1TablesspmSinkTablenot-accessiblecurrentA table configuring the sink for measurements.
1.3.6.1.2.1.16.28.1.5.1.1RowsspmSinkEntrynot-accessiblecurrentThe details of a particular sink entry. If the measurement is a round-trip type, then the sink entry will be on the same probe as the corresponding sspmSourceE…
1.3.6.1.2.1.16.28.1.5.1.1.1ColumnsspmSinkInstancenot-accessiblecurrentAn index. When the measurement is for a round-trip measurement, then this table entry is on the same probe as the corresponding sspmSourceEntry, and the value …
1.3.6.1.2.1.16.28.1.5.1.1.2ColumnsspmSinkTyperead-createcurrentThe AppLocalIndex value that uniquely identifies the measurement per the APM-MIB. In order to create a row in this table, there must be a corresponding row in …
1.3.6.1.2.1.16.28.1.5.1.1.3ColumnsspmSinkSourceAddressTyperead-createcurrentThe type of Internet address of the source.
1.3.6.1.2.1.16.28.1.5.1.1.4ColumnsspmSinkSourceAddressread-createcurrentThe Internet address of the source. The formatting of this object is controlled by the sspmSinkSourceAddressType object above. This object should be set only t…
1.3.6.1.2.1.16.28.1.5.1.1.5ColumnsspmSinkExpectedRateread-createcurrentThe expected rate at which packets will arrive.
1.3.6.1.2.1.16.28.1.5.1.1.6ColumnsspmSinkEnableread-createcurrentIndicates if the sink is enabled or not.
1.3.6.1.2.1.16.28.1.5.1.1.7ColumnsspmSinkExpectedFirstSequenceNumread-createcurrentThe expected first sequence number of packets. This is used by the sink to determine if packets were lost at the initiation of the test.
1.3.6.1.2.1.16.28.1.5.1.1.8ColumnsspmSinkLastSequenceNumberread-onlycurrentThe last sequence number received.
1.3.6.1.2.1.16.28.1.5.1.1.9ColumnsspmSinkLastSequenceInvalidread-onlycurrentThe number of packets that arrived whose sequence number was not one plus the value of sspmSinkLastSequenceNumber.
1.3.6.1.2.1.16.28.1.5.1.1.10ColumnsspmSinkStorageTyperead-createcurrentThe storage type of this sspmSinkEntry. If the value of this object is 'permanent', no objects in this row need to be writable.
1.3.6.1.2.1.16.28.1.5.1.1.11ColumnsspmSinkStatusread-createcurrentStatus of this conceptual row. An entry may not exist in the active state unless all objects in the entry have an appropriate value. Once this object is set to…
1.3.6.1.2.1.16.28.2NodesspmMIBNotifications
1.3.6.1.2.1.16.28.3NodesspmMIBConformance
1.3.6.1.2.1.16.28.3.1NodesspmCompliances
1.3.6.1.2.1.16.28.3.1.1CompliancesspmGeneralCompliancecurrentA general compliance that allows all things to be optional.
1.3.6.1.2.1.16.28.3.1.2CompliancesspmSourceFullCompliancecurrentA source compliance. Use this compliance when implementing a traffic-source-only device. This is useful for implementing devices that probe other devices for i…
1.3.6.1.2.1.16.28.3.1.3CompliancesspmSinkFullCompliancecurrentA sink-only compliance. Use this compliance when implementing a sink-only device. This is useful for devices to receive one-way measurements.
1.3.6.1.2.1.16.28.3.2NodesspmGroups
1.3.6.1.2.1.16.28.3.2.1GroupsspmGeneralGroupcurrentThe objects in the SSPM General Group.
1.3.6.1.2.1.16.28.3.2.2GroupsspmSourceGroupcurrentThe objects in the SSPM Source Group.
1.3.6.1.2.1.16.28.3.2.3GroupsspmUserPassGroupcurrentThe objects in the SSPM Username and password group.
1.3.6.1.2.1.16.28.3.2.4GroupsspmSinkGroupcurrentThe objects in the SSPM Sink Group.
Type Definitions
NameSyntaxStatusDescription
SspmClockMaxSkewInteger32 (1..65535)currentAn indication of the accuracy of the clock as defined by RFC1305. This variable indicates the maximum offset error due to skew of the local clock over the time interval 86400 seconds, in seconds.
SspmClockSourceInteger32 (0..255)currentAn indication of the source of the clock as defined by the NTP specification RFC1305 [RFC1305] definition of stratum: Stratum (sys.stratum, peer.stratum, pkt.stratum): This is an integer indicating the stratum of the lo…
SspmMicroSecondsUnsigned32currentA unit of time with resolution of MicroSeconds.