GMPLS-LABEL-STD-MIB
33 objects
Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4803; see the RFC itself for full legal notices. This MIB module contains managed object definitions for labels within GMPLS systems as defined in Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, Berger, L. (Editor), RFC 3471, January 2003.
Imported Objects
| DIFFSERV-MIB | -- RFC 2863 IndexIntegerNextFree |
| GMPLS-TC-STD-MIB | -- RFC 3811 GmplsLabelTypeTC GmplsFreeformLabelTC |
| IF-MIB | -- RFC 2579 InterfaceIndexOrZero |
| MPLS-TC-STD-MIB | -- RFC 3289 MplsLabel mplsStdMIB |
| SNMPv2-CONF | -- RFC 2578 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | Integer32 MODULE-IDENTITY OBJECT-TYPE Unsigned32 |
| SNMPv2-TC | -- RFC 2580 RowStatus StorageType |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.10.166.16 | IdentitygmplsLabelStdMIB | Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4803; see the RFC itself for full legal notices. This MIB module contains m… | ||
| 1.3.6.1.2.1.10.166.16.1 | NodegmplsLabelObjects | |||
| 1.3.6.1.2.1.10.166.16.1.1 | ScalargmplsLabelIndexNext | read-only | current | This object contains an unused value for gmplsLabelIndex, or a zero to indicate that no unused value exists or is available. A management application wishing t… |
| 1.3.6.1.2.1.10.166.16.1.2 | TablegmplsLabelTable | not-accessible | current | Table of GMPLS Labels. This table allows the representation of the more complex label forms required for GMPLS that cannot be held within the TEXTUAL-CONVENTIO… |
| 1.3.6.1.2.1.10.166.16.1.2.1 | RowgmplsLabelEntry | not-accessible | current | An entry in this table represents a single label value. There are three indexes into the table. - The interface index may be helpful to distinguish which label… |
| 1.3.6.1.2.1.10.166.16.1.2.1.1 | ColumngmplsLabelInterface | not-accessible | current | The interface on which this label is used. If this object is set to zero, the label MUST have applicability across the whole system and not be limited to a sin… |
| 1.3.6.1.2.1.10.166.16.1.2.1.2 | ColumngmplsLabelIndex | not-accessible | current | An arbitrary index into the table to identify a label. Note that implementations that are representing 32-bit labels within this table MAY choose to align this… |
| 1.3.6.1.2.1.10.166.16.1.2.1.3 | ColumngmplsLabelSubindex | not-accessible | current | In conjunction with gmplsLabelInterface and gmplsLabelIndex, this object uniquely identifies this row. This sub-index allows a single GMPLS Label to be defined… |
| 1.3.6.1.2.1.10.166.16.1.2.1.4 | ColumngmplsLabelType | read-create | current | Identifies the type of this label. Note that this object does not determine whether MPLS or GMPLS signaling is in use: a value of gmplsMplsLabel(1) denotes tha… |
| 1.3.6.1.2.1.10.166.16.1.2.1.5 | ColumngmplsLabelMplsLabel | read-create | current | The value of an MPLS Label (that is a Packet Label) if this table is used to store it. This may be used in MPLS systems even though the label values can be ade… |
| 1.3.6.1.2.1.10.166.16.1.2.1.6 | ColumngmplsLabelPortWavelength | read-create | current | The value of a Port or Wavelength Label when carried as a Generalized Label. Only valid if gmplsLabelType is set to gmplsPortWavelengthLabel(2). This object ca… |
| 1.3.6.1.2.1.10.166.16.1.2.1.7 | ColumngmplsLabelFreeform | read-create | current | The value of a Freeform Generalized Label that does not conform to one of the standardized label encodings or that an implementation chooses to represent as an… |
| 1.3.6.1.2.1.10.166.16.1.2.1.8 | ColumngmplsLabelSonetSdhSignalIndex | read-create | current | The Signal Index value (S) of a SONET or SDH Generalized Label. Zero indicates that this field is non-significant. Only valid if gmplsLabelType is set to gmpls… |
| 1.3.6.1.2.1.10.166.16.1.2.1.9 | ColumngmplsLabelSdhVc | read-create | current | The VC Indicator (U) of an SDH Generalized Label. Zero indicates that this field is non-significant. Only valid if gmplsLabelType is set to gmplsSdhLabel(5). T… |
| 1.3.6.1.2.1.10.166.16.1.2.1.10 | ColumngmplsLabelSdhVcBranch | read-create | current | The VC Branch Indicator (K) of an SDH Generalized Label. Zero indicates that this field is non-significant. Only valid if gmplsLabelType is set to gmplsSdhLabe… |
| 1.3.6.1.2.1.10.166.16.1.2.1.11 | ColumngmplsLabelSonetSdhBranch | read-create | current | The Branch Indicator (L) of a SONET or SDH Generalized Label. Zero indicates that this field is non-significant. Only valid gmplsLabelType is set to gmplsSonet… |
| 1.3.6.1.2.1.10.166.16.1.2.1.12 | ColumngmplsLabelSonetSdhGroupBranch | read-create | current | The Group Branch Indicator (M) of a SONET or SDH Generalized Label. Zero indicates that this field is non-significant. Only valid if gmplsLabelType is set to g… |
| 1.3.6.1.2.1.10.166.16.1.2.1.13 | ColumngmplsLabelWavebandId | read-create | current | The waveband identifier component of a Waveband Label. Only valid if gmplsLabelType is set to gmplsWavebandLabel(6). This object cannot be modified if gmplsLab… |
| 1.3.6.1.2.1.10.166.16.1.2.1.14 | ColumngmplsLabelWavebandStart | read-create | current | The starting label component of a Waveband Label. Only valid if gmplsLabelType is set to gmplsWavebandLabel(6). This object cannot be modified if gmplsLabelRow… |
| 1.3.6.1.2.1.10.166.16.1.2.1.15 | ColumngmplsLabelWavebandEnd | read-create | current | The end label component of a Waveband Label. Only valid if gmplsLabelType is set to gmplsWavebandLabel(6). This object cannot be modified if gmplsLabelRowStatu… |
| 1.3.6.1.2.1.10.166.16.1.2.1.16 | ColumngmplsLabelStorageType | read-create | current | This variable indicates the storage type for this row. The agent MUST ensure that this object's value remains consistent with the storage type of any rows in o… |
| 1.3.6.1.2.1.10.166.16.1.2.1.17 | ColumngmplsLabelRowStatus | read-create | current | This variable is used to create, modify, and/or delete a row in this table. When a row in this table has a row in the active(1) state, no objects in this row c… |
| 1.3.6.1.2.1.10.166.16.2 | NodegmplsLabelConformance | |||
| 1.3.6.1.2.1.10.166.16.2.1 | NodegmplsLabelGroups | |||
| 1.3.6.1.2.1.10.166.16.2.1.1 | GroupgmplsLabelTableGroup | current | Necessary, but not sufficient, set of objects to implement label table support. In addition, depending on the type of labels supported, the following other gro… | |
| 1.3.6.1.2.1.10.166.16.2.1.2 | GroupgmplsLabelPacketGroup | current | Object needed to implement Packet (MPLS) Labels. | |
| 1.3.6.1.2.1.10.166.16.2.1.3 | GroupgmplsLabelPortWavelengthGroup | current | Object needed to implement Port and Wavelength Labels. | |
| 1.3.6.1.2.1.10.166.16.2.1.4 | GroupgmplsLabelFreeformGroup | current | Object needed to implement Freeform Labels. | |
| 1.3.6.1.2.1.10.166.16.2.1.5 | GroupgmplsLabelSonetSdhGroup | current | Objects needed to implement SONET and SDH Labels. | |
| 1.3.6.1.2.1.10.166.16.2.1.6 | GroupgmplsLabelWavebandGroup | current | Objects needed to implement Waveband Labels. | |
| 1.3.6.1.2.1.10.166.16.2.2 | NodegmplsLabelCompliances | |||
| 1.3.6.1.2.1.10.166.16.2.2.1 | CompliancegmplsLabelModuleReadOnlyCompliance | read-only | current | Compliance requirement for implementations that only provide read-only support for GMPLS-LABEL-STD-MIB. Such devices can then be monitored but cannot be config… |
| 1.3.6.1.2.1.10.166.16.2.2.2 | CompliancegmplsLabelModuleFullCompliance | current | Compliance statement for agents that support the complete GMPLS-LABEL-STD-MIB module. The mandatory groups have to be implemented by GMPLS LSRs claiming suppor… |