MIB Viewer

MIDCOM-MIB

90 objects
This MIB module defines a set of basic objects for configuring middleboxes, such as firewalls and network address translators, in order to enable communication across these devices. Managed objects defined in this MIB module are structured in three kinds of objects: - transaction objects required according to the MIDCOM protocol requirements defined in RFC 3304 and according to the MIDCOM protocol semantics defined in RFC 3989, - configuration objects that can be used for retrieving or setting parameters of the implementation of transaction objects, - optional monitoring objects that provide information about used resource and statistics The transaction objects are organized in two subtrees: - objects modeling MIDCOM policy rules in the midcomRuleTable - objects modeling MIDCOM policy rule groups in the midcomGroupTable Note that typically, configuration objects are not intended to be written by MIDCOM clients. In general, write access to these objects needs to be restricted more strictly than write access to objects in the transaction subtrees. Copyright (C) The Internet Society (2008). This version of this MIB module is part of RFC 5190; see the RFC itself for full legal notices.
Imported Objects
IF-MIB-- RFC 4001 InterfaceIndexOrZero
INET-ADDRESS-MIB-- RFC 3411 InetAddressType InetAddress InetAddressPrefixLength InetPortNumber
NAT-MIB-- RFC 2863 NatBindIdOrZero
SNMP-FRAMEWORK-MIB-- RFC 2580 SnmpAdminString
SNMPv2-CONF-- RFC 2579 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP
SNMPv2-SMICounter32 Gauge32 mib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE Unsigned32
SNMPv2-TC-- RFC 2578 TEXTUAL-CONVENTION RowStatus StorageType TruthValue
OIDNameAccessStatusDescription
1.3.6.1.2.1.171IdentitymidcomMIBThis MIB module defines a set of basic objects for configuring middleboxes, such as firewalls and network address translators, in order to enable communication…
1.3.6.1.2.1.171.0NodemidcomNotifications
1.3.6.1.2.1.171.0.1NotificationmidcomUnsolicitedRuleEventcurrentThis notification is generated whenever the value of midcomRuleOperStatus enters any error state or any termination state without an explicit trigger by a MIDC…
1.3.6.1.2.1.171.0.2NotificationmidcomSolicitedRuleEventcurrentThis notification is generated whenever the value of midcomRuleOperStatus enters one of the states {reserved, enabled, any error state, any termination state} …
1.3.6.1.2.1.171.0.3NotificationmidcomSolicitedGroupEventcurrentThis notification is generated for indicating that the lifetime of all member rules of the group was changed by successfully writing to object midcomGroupLifet…
1.3.6.1.2.1.171.1NodemidcomObjects
1.3.6.1.2.1.171.1.1NodemidcomTransaction
1.3.6.1.2.1.171.1.1.3TablemidcomRuleTablenot-accessiblecurrentThis table lists policy rules. It is indexed by the midcomRuleOwner, the midcomGroupIndex, and the midcomRuleIndex. This implies that a rule is a member of exa…
1.3.6.1.2.1.171.1.1.3.1RowmidcomRuleEntrynot-accessiblecurrentAn entry describing a particular MIDCOM policy rule.
1.3.6.1.2.1.171.1.1.3.1.1ColumnmidcomRuleOwnernot-accessiblecurrentThe manager who owns this row in the midcomRuleTable. This object SHOULD uniquely identify an authenticated MIDCOM client. This object is part of the table ind…
1.3.6.1.2.1.171.1.1.3.1.3ColumnmidcomRuleIndexnot-accessiblecurrentThe value of this object must be unique in combination with the values of the objects midcomRuleOwner and midcomGroupIndex in this row.
1.3.6.1.2.1.171.1.1.3.1.4ColumnmidcomRuleAdminStatusread-createcurrentThe value of this object indicates the desired status of the policy rule. See the definition of midcomRuleOperStatus for a description of the values. When a mi…
1.3.6.1.2.1.171.1.1.3.1.5ColumnmidcomRuleOperStatusread-onlycurrentThe actual status of the policy rule. The midcomRuleOperStatus object may have the following values: - newEntry(1) indicates that the entry in the midcomRuleTa…
1.3.6.1.2.1.171.1.1.3.1.6ColumnmidcomRuleStorageTyperead-createcurrentWhen retrieved, this object returns the storage type of the policy rule. Writing to this object can change the storage type of the particular row from volatile…
1.3.6.1.2.1.171.1.1.3.1.7ColumnmidcomRuleStorageTimeread-createcurrentThe value of this object specifies how long this row can exist in the midcomRuleTable after the midcomRuleOperStatus switched to a termination state or to an e…
1.3.6.1.2.1.171.1.1.3.1.8ColumnmidcomRuleErrorread-onlycurrentThis object contains a descriptive error message if the transition into the operational status reserved(7) or enabled(8) failed. Implementations must reset the…
1.3.6.1.2.1.171.1.1.3.1.9ColumnmidcomRuleInterfaceread-createcurrentThis object indicates the IP interface for which enforcement of a policy rule is requested or performed, respectively. The interface is identified by its index…
1.3.6.1.2.1.171.1.1.3.1.10ColumnmidcomRuleFlowDirectionread-createcurrentThis parameter specifies the direction of enabled communication, either inbound(1), outbound(2), or biDirectional(3). The semantics of this object depends on t…
1.3.6.1.2.1.171.1.1.3.1.11ColumnmidcomRuleMaxIdleTimeread-createcurrentMaximum idle time of the policy rule in seconds. If no packet to which the policy rule applies passes the middlebox for the specified midcomRuleMaxIdleTime, th…
1.3.6.1.2.1.171.1.1.3.1.12ColumnmidcomRuleTransportProtocolread-createcurrentThe transport protocol. Valid values for midcomRuleTransportProtocol other than zero are defined at: http://www.iana.org/assignments/protocol-numbers This obje…
1.3.6.1.2.1.171.1.1.3.1.13ColumnmidcomRulePortRangeread-createcurrentThe range of port numbers. This object is used as input to a request for establishing a policy rule as well as for indicating the properties of an established …
1.3.6.1.2.1.171.1.1.3.1.14ColumnmidcomRuleInternalIpVersionread-createcurrentIP version of the internal address (A0) and the inside address (A1). Allowed values are ipv4(1), ipv6(2), ipv4z(3), and ipv6z(4). This object is used as input …
1.3.6.1.2.1.171.1.1.3.1.15ColumnmidcomRuleExternalIpVersionread-createcurrentIP version of the external address (A3) and the outside address (A2). Allowed values are ipv4(1) and ipv6(2). This object is used as input to a request for est…
1.3.6.1.2.1.171.1.1.3.1.16ColumnmidcomRuleInternalIpAddrread-createcurrentThe internal IP address (A0). This object is used as input to a request for establishing a policy rule as well as for indicating the properties of an establish…
1.3.6.1.2.1.171.1.1.3.1.17ColumnmidcomRuleInternalIpPrefixLengthread-createcurrentThe prefix length of the internal IP address used for wildcarding. A value of 0 indicates a full wildcard; in this case, the value of midcomRuleInternalIpAddr …
1.3.6.1.2.1.171.1.1.3.1.18ColumnmidcomRuleInternalPortread-createcurrentThe internal port number. A value of 0 is a wildcard. This object is used as input to a request for establishing a policy rule as well as for indicating the pr…
1.3.6.1.2.1.171.1.1.3.1.19ColumnmidcomRuleExternalIpAddrread-createcurrentThe external IP address (A3). This object is used as input to a request for establishing a policy rule as well as for indicating the properties of an establish…
1.3.6.1.2.1.171.1.1.3.1.20ColumnmidcomRuleExternalIpPrefixLengthread-createcurrentThe prefix length of the external IP address used for wildcarding. A value of 0 indicates a full wildcard; in this case, the value of midcomRuleExternalIpAddr …
1.3.6.1.2.1.171.1.1.3.1.21ColumnmidcomRuleExternalPortread-createcurrentThe external port number. A value of 0 is a wildcard. This object is used as input to a request for establishing a policy rule as well as for indicating the pr…
1.3.6.1.2.1.171.1.1.3.1.22ColumnmidcomRuleInsideIpAddrread-onlycurrentThe inside IP address at the middlebox (A1). The value of this object is relevant only if object midcomRuleOperStatus of the same entry has a value of either r…
1.3.6.1.2.1.171.1.1.3.1.23ColumnmidcomRuleInsidePortread-onlycurrentThe inside port number at the middlebox. A value of 0 is a wildcard. The value of this object is relevant only if object midcomRuleOperStatus of the same entry…
1.3.6.1.2.1.171.1.1.3.1.24ColumnmidcomRuleOutsideIpAddrread-onlycurrentThe outside IP address at the middlebox (A2). The value of this object is relevant only if object midcomRuleOperStatus of the same entry has a value of either …
1.3.6.1.2.1.171.1.1.3.1.25ColumnmidcomRuleOutsidePortread-onlycurrentThe outside port number at the middlebox. A value of 0 is a wildcard. The value of this object is relevant only if object midcomRuleOperStatus of the same entr…
1.3.6.1.2.1.171.1.1.3.1.26ColumnmidcomRuleLifetimeread-createcurrentThe remaining lifetime in seconds of this policy rule. Lifetime of a policy rule starts when object midcomRuleOperStatus in the same entry enters either state …
1.3.6.1.2.1.171.1.1.3.1.27ColumnmidcomRuleRowStatusread-createcurrentA control that allows entries to be added and removed from this table. Entries can also be removed from this table by setting objects midcomRuleLifetime and mi…
1.3.6.1.2.1.171.1.1.4TablemidcomGroupTablenot-accessiblecurrentThis table lists all current policy rule groups. Entries in this table are created or removed implicitly when entries in the midcomRuleTable are created or rem…
1.3.6.1.2.1.171.1.1.4.1RowmidcomGroupEntrynot-accessiblecurrentAn entry describing properties of a particular MIDCOM policy rule group.
1.3.6.1.2.1.171.1.1.4.1.2ColumnmidcomGroupIndexnot-accessiblecurrentThe index of this group for the midcomRuleOwner. A group is identified by the combination of midcomRuleOwner and midcomGroupIndex. The value of this index must…
1.3.6.1.2.1.171.1.1.4.1.3ColumnmidcomGroupLifetimeread-writecurrentWhen retrieved, this object delivers the maximum lifetime in seconds of all member rules of this group, i.e., of all rows in the midcomRuleTable that have the …
1.3.6.1.2.1.171.1.2NodemidcomConfig
1.3.6.1.2.1.171.1.2.1ScalarmidcomConfigMaxLifetimeread-writecurrentWhen retrieved, this object returns the maximum lifetime, in seconds, that this middlebox allows policy rules to have.
1.3.6.1.2.1.171.1.2.2ScalarmidcomConfigPersistentRulesread-writecurrentWhen retrieved, this object returns true(1) if the MIDCOM-MIB implementation can store policy rules persistently. Otherwise, it returns false(2). A value of tr…
1.3.6.1.2.1.171.1.2.3TablemidcomConfigIfTablenot-accessiblecurrentThis table indicates capabilities of the MIDCOM-MIB implementation per IP interface. The table is indexed by the object midcomConfigIfIndex. For indexing a sin…
1.3.6.1.2.1.171.1.2.3.1RowmidcomConfigIfEntrynot-accessiblecurrentAn entry describing the capabilities of a middlebox with respect to the indexed IP interface.
1.3.6.1.2.1.171.1.2.3.1.1ColumnmidcomConfigIfIndexnot-accessiblecurrentThe index of an entry in the midcomConfigIfTable. For values different from zero, this object identifies an IP interface by containing the same value as the if…
1.3.6.1.2.1.171.1.2.3.1.2ColumnmidcomConfigIfBitsread-onlycurrentWhen retrieved, this object returns a set of bits indicating the capabilities (or configuration) of the middlebox with respect to the referenced IP interface. …
1.3.6.1.2.1.171.1.2.3.1.3ColumnmidcomConfigIfEnabledread-writecurrentThe value of this object indicates the availability of the middlebox service described by midcomConfigIfBits at the indexed IP interface. By writing to this ob…
1.3.6.1.2.1.171.1.2.4TablemidcomConfigFirewallTablenot-accessiblecurrentThis table lists the firewall configuration per IP interface. It can be used for configuring how policy rules created by MIDCOM clients are realized as firewal…
1.3.6.1.2.1.171.1.2.4.1RowmidcomConfigFirewallEntrynot-accessiblecurrentAn entry describing a particular set of firewall resources.
1.3.6.1.2.1.171.1.2.4.1.1ColumnmidcomConfigFirewallIndexnot-accessiblecurrentThe index of an entry in the midcomConfigFirewallTable. For values different from 0, this object identifies an IP interface by containing the same value as the…
1.3.6.1.2.1.171.1.2.4.1.2ColumnmidcomConfigFirewallGroupIdread-writecurrentThe firewall rule group to which all firewall rules are assigned that the MIDCOM server creates for the interface indicated by object midcomConfigFirewallIndex…
1.3.6.1.2.1.171.1.2.4.1.3ColumnmidcomConfigFirewallPriorityread-writecurrentThe priority assigned to all firewall rules that the MIDCOM server creates for the interface indicated by object midcomConfigFirewallIndex. If the value of obj…
1.3.6.1.2.1.171.1.3NodemidcomMonitoring
1.3.6.1.2.1.171.1.3.1TablemidcomResourceTablenot-accessiblecurrentThis table lists all used middlebox resources per MIDCOM policy rule. The midcomResourceTable augments the midcomRuleTable.
1.3.6.1.2.1.171.1.3.1.1RowmidcomResourceEntrynot-accessiblecurrentAn entry describing a particular set of middlebox resources.
1.3.6.1.2.1.171.1.3.1.1.4ColumnmidcomRscNatInternalAddrBindModeread-onlycurrentAn indication of whether this policy rule uses an address NAT bind or an address-port NAT bind for binding the internal address. If the MIDCOM-MIB module is op…
1.3.6.1.2.1.171.1.3.1.1.5ColumnmidcomRscNatInternalAddrBindIdread-onlycurrentThis object references to the allocated internal NAT bind that is used by this policy rule. A NAT bind describes the mapping of internal addresses to outside a…
1.3.6.1.2.1.171.1.3.1.1.6ColumnmidcomRscNatInsideAddrBindModeread-onlycurrentAn indication of whether this policy rule uses an address NAT bind or an address-port NAT bind for binding the external address. If the MIDCOM-MIB module is op…
1.3.6.1.2.1.171.1.3.1.1.7ColumnmidcomRscNatInsideAddrBindIdread-onlycurrentThis object refers to the allocated external NAT bind that is used by this policy rule. A NAT bind describes the mapping of external addresses to inside addres…
1.3.6.1.2.1.171.1.3.1.1.8ColumnmidcomRscNatSessionId1read-onlycurrentThis object refers to the first allocated NAT session for this policy rule. MIDCOM-MIB implementations can read this object to learn whether or not a NAT sessi…
1.3.6.1.2.1.171.1.3.1.1.9ColumnmidcomRscNatSessionId2read-onlycurrentThis object refers to the second allocated NAT session for this policy rule. MIDCOM-MIB implementations can read this object to learn whether or not a NAT sess…
1.3.6.1.2.1.171.1.3.1.1.10ColumnmidcomRscFirewallRuleIdread-onlycurrentThis object refers to the allocated firewall rule in the firewall engine for this policy rule. MIDCOM-MIB implementations can read this value to learn whether …
1.3.6.1.2.1.171.1.3.2NodemidcomStatistics
1.3.6.1.2.1.171.1.3.2.1ScalarmidcomCurrentOwnersread-onlycurrentThe number of different values for midcomRuleOwner for all current entries in the midcomRuleTable.
1.3.6.1.2.1.171.1.3.2.2ScalarmidcomTotalRejectedRuleEntriesread-onlycurrentThe total number of failed attempts to create an entry in the midcomRuleTable.
1.3.6.1.2.1.171.1.3.2.3ScalarmidcomCurrentRulesIncompleteread-onlycurrentThe current number of policy rules that are incomplete. Policy rules are loaded via row entries in the midcomRuleTable. This object counts policy rules that ar…
1.3.6.1.2.1.171.1.3.2.4ScalarmidcomTotalIncorrectReserveRulesread-onlycurrentThe total number of policy reserve rules that failed parameter check and entered state incorrectRequest(4).
1.3.6.1.2.1.171.1.3.2.5ScalarmidcomTotalRejectedReserveRulesread-onlycurrentThe total number of policy reserve rules that failed while being processed and entered state requestRejected(6).
1.3.6.1.2.1.171.1.3.2.6ScalarmidcomCurrentActiveReserveRulesread-onlycurrentThe number of currently active policy reserve rules.
1.3.6.1.2.1.171.1.3.2.7ScalarmidcomTotalExpiredReserveRulesread-onlycurrentThe total number of expired policy reserve rules (entered termination state timedOut(9)).
1.3.6.1.2.1.171.1.3.2.8ScalarmidcomTotalTerminatedOnRqReserveRulesread-onlycurrentThe total number of policy reserve rules that were terminated on request (entered termination state terminatedOnRequest(10)).
1.3.6.1.2.1.171.1.3.2.9ScalarmidcomTotalTerminatedReserveRulesread-onlycurrentThe total number of policy reserve rules that were terminated, but not on request (entered termination state terminated(11)).
1.3.6.1.2.1.171.1.3.2.10ScalarmidcomTotalIncorrectEnableRulesread-onlycurrentThe total number of policy enable rules that failed parameter check and entered state incorrectRequest(4).
1.3.6.1.2.1.171.1.3.2.11ScalarmidcomTotalRejectedEnableRulesread-onlycurrentThe total number of policy enable rules that failed while being processed and entered state requestRejected(6).
1.3.6.1.2.1.171.1.3.2.12ScalarmidcomCurrentActiveEnableRulesread-onlycurrentThe number of currently active policy enable rules.
1.3.6.1.2.1.171.1.3.2.13ScalarmidcomTotalExpiredEnableRulesread-onlycurrentThe total number of expired policy enable rules (entered termination state timedOut(9)).
1.3.6.1.2.1.171.1.3.2.14ScalarmidcomTotalTerminatedOnRqEnableRulesread-onlycurrentThe total number of policy enable rules that were terminated on request (entered termination state terminatedOnRequest(10)).
1.3.6.1.2.1.171.1.3.2.15ScalarmidcomTotalTerminatedEnableRulesread-onlycurrentThe total number of policy enable rules that were terminated, but not on request (entered termination state terminated(11)).
1.3.6.1.2.1.171.2NodemidcomConformance
1.3.6.1.2.1.171.2.1NodemidcomCompliances
1.3.6.1.2.1.171.2.1.1CompliancemidcomComplianceread-onlycurrentThe compliance statement for implementations of the MIDCOM-MIB module. Note that compliance with this compliance statement requires compliance with the ifCompl…
1.3.6.1.2.1.171.2.2NodemidcomGroups
1.3.6.1.2.1.171.2.2.1GroupmidcomRuleGroupcurrentA collection of objects providing information about policy rules and policy rule groups.
1.3.6.1.2.1.171.2.2.2GroupmidcomCapabilitiesGroupcurrentA collection of objects providing information about the capabilities of a middlebox.
1.3.6.1.2.1.171.2.2.3GroupmidcomConfigFirewallGroupcurrentA collection of objects providing information about the firewall rule group and firewall rule priority to be used by firewalls loaded through MIDCOM.
1.3.6.1.2.1.171.2.2.4GroupmidcomResourceGroupcurrentA collection of objects providing information about the used NAT and firewall resources.
1.3.6.1.2.1.171.2.2.5GroupmidcomStatisticsGroupcurrentA collection of objects providing statistical information about the MIDCOM server.
1.3.6.1.2.1.171.2.2.6GroupmidcomNotificationsGroupcurrentThe notifications emitted by the midcomMIB.
Type Definitions
NameSyntaxStatusDescription
MidcomNatBindModeINTEGER { addressBind(1), addressPortBind(2), none(3) }currentAn indicator of the kind of NAT resources used by a policy rule. This definition corresponds to the definition of NatBindMode in the NAT-MIB (RFC 4008). Value none(3) can be used to indicate that the policy rule does no…
MidcomNatSessionIdOrZeroUnsigned32currentA unique ID that is assigned to each NAT session by a NAT implementation. This definition corresponds to the definition of NatSessionId in the NAT-MIB (RFC 4008). Value 0 can be used to indicate that the policy rule doe…