OLSRv2-MIB
146 objects
This OLSRv2-MIB module is applicable to routers implementing the Optimized Link State Routing Protocol version 2 (OLSRv2) defined in RFC 7181. Copyright (c) 2014 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 7184; see the RFC itself for full legal notices.
Imported Objects
| IANA-OLSRv2-LINK-METRIC-TYPE-MIB | -- RFC 6779 IANAolsrv2LinkMetricTypeTC |
| INET-ADDRESS-MIB | -- STD 58 InetAddressType InetAddress InetAddressPrefixLength |
| NHDP-MIB | -- RFC 4001 nhdpInterfaceEntry nhdpIib2HopSetEntry nhdpIibLinkSetEntry nhdpInterfacePerfEntry nhdpNibNeighborSetEntry |
| SNMPv2-CONF | -- RFC 2579 MODULE-COMPLIANCE NOTIFICATION-GROUP OBJECT-GROUP |
| SNMPv2-SMI | Counter32 Counter64 Integer32 mib-2 MODULE-IDENTITY NOTIFICATION-TYPE OBJECT-TYPE TimeTicks Unsigned32 |
| SNMPv2-TC | -- RFC 2578 TEXTUAL-CONVENTION TimeStamp TruthValue |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.219 | IdentitymanetOlsrv2MIB | This OLSRv2-MIB module is applicable to routers implementing the Optimized Link State Routing Protocol version 2 (OLSRv2) defined in RFC 7181. Copyright (c) 20… | ||
| 1.3.6.1.2.1.219.0 | Nodeolsrv2MIBNotifications | |||
| 1.3.6.1.2.1.219.0.0 | Nodeolsrv2NotificationsObjects | |||
| 1.3.6.1.2.1.219.0.0.1 | Notificationolsrv2RouterStatusChange | current | olsrv2RouterStatusChange is a notification generated when the OLSRv2 router changes it status. The router status is maintained in the olsrv2AdminStatus object. | |
| 1.3.6.1.2.1.219.0.0.2 | Notificationolsrv2OrigIpAddrChange | current | olsrv2OrigIpAddrChange is a notification generated when the OLSRv2 router changes it originator IP address. The notification includes the new and the previous … | |
| 1.3.6.1.2.1.219.0.0.3 | Notificationolsrv2RoutingSetRecalculationCountChange | current | The olsrv2RoutingSetRecalculationCountChange notification is generated when a significant number of Routing Set recalculations have occurred in a short time. T… | |
| 1.3.6.1.2.1.219.0.0.4 | Notificationolsrv2MPRSetRecalculationCountChange | current | The olsrv2MPRSetRecalculationCountChange notification is generated when a significant number of MPR set recalculations occur in a short period of time. This no… | |
| 1.3.6.1.2.1.219.0.1 | Nodeolsrv2NotificationsControl | |||
| 1.3.6.1.2.1.219.0.1.1 | Scalarolsrv2RoutingSetRecalculationCountThreshold | read-write | current | A threshold value for the olsrv2RoutingSetRecalculationCount object. If the number of occurrences exceeds this threshold within the previous olsrv2RoutingSetRe… |
| 1.3.6.1.2.1.219.0.1.2 | Scalarolsrv2RoutingSetRecalculationCountWindow | read-write | current | This object is used to determine whether to generate an olsrv2RoutingSetRecalculationCountChange notification. This object represents an interval from the pres… |
| 1.3.6.1.2.1.219.0.1.3 | Scalarolsrv2MPRSetRecalculationCountThreshold | read-write | current | A threshold value for the olsrv2MPRSetRecalculationCount object. If the number of occurrences exceeds this threshold within the previous olsrv2MPRSetRecalculat… |
| 1.3.6.1.2.1.219.0.1.4 | Scalarolsrv2MPRSetRecalculationCountWindow | read-write | current | This object is used to determine whether to generate an olsrv2MPRSetRecalculationCountChange notification. This object represents an interval from the present … |
| 1.3.6.1.2.1.219.0.2 | Nodeolsrv2NotificationsStates | |||
| 1.3.6.1.2.1.219.0.2.1 | Scalarolsrv2PreviousOrigIpAddrType | read-only | current | The type of the olsrv2PreviousOrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. This obje… |
| 1.3.6.1.2.1.219.0.2.2 | Scalarolsrv2PreviousOrigIpAddr | read-only | current | The previous origination IP address of this OLSRv2 router. This object SHOULD be updated each time the olsrv2OrigIpAddr is modified. This object is persistent,… |
| 1.3.6.1.2.1.219.1 | Nodeolsrv2MIBObjects | |||
| 1.3.6.1.2.1.219.1.1 | Nodeolsrv2ConfigurationGroup | |||
| 1.3.6.1.2.1.219.1.1.1 | Scalarolsrv2AdminStatus | read-write | current | The configured status of the OLSRv2 process on this device. 'enabled(1)' means that OLSRv2 is configured to run on this device. 'disabled(2)' mean that the OLS… |
| 1.3.6.1.2.1.219.1.1.2 | Tableolsrv2InterfaceTable | not-accessible | current | The olsrv2InterfaceTable describes the OLSRv2 status on the NHDP interfaces of this router. As such, this table augments the nhdpInterfaceTable defined in the … |
| 1.3.6.1.2.1.219.1.1.2.1 | Rowolsrv2InterfaceEntry | not-accessible | current | The olsrv2InterfaceEntry describes one OLSRv2 local interface configuration as indexed by its nhdpIfIndex, as defined in the NHDP-MIB (RFC 6779). The objects i… |
| 1.3.6.1.2.1.219.1.1.2.1.1 | Columnolsrv2InterfaceAdminStatus | read-create | current | The OLSRv2 interface's administrative status. The value 'enabled(1)' denotes that the interface is permitted to participate in the OLSRv2 routing process. The … |
| 1.3.6.1.2.1.219.1.1.3 | Scalarolsrv2OrigIpAddrType | read-write | current | The type of the olsrv2OrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.1.4 | Scalarolsrv2OrigIpAddr | read-write | current | The router's originator address. An address that is unique (within the MANET) to this router. This object is persistent, and when written, the entity SHOULD sa… |
| 1.3.6.1.2.1.219.1.1.5 | Scalarolsrv2OHoldTime | read-write | current | olsrv2OHoldTime corresponds to O_HOLD_TIME of OLSRv2, and represents the time for which a recently used and replaced originator address is used to recognize th… |
| 1.3.6.1.2.1.219.1.1.6 | Scalarolsrv2TcInterval | read-write | current | olsrv2TcInterval corresponds to TC_INTERVAL of OLSRv2 and represents the maximum time between the transmission of two successive TC messages by this router. Gu… |
| 1.3.6.1.2.1.219.1.1.7 | Scalarolsrv2TcMinInterval | read-write | current | olsrv2TcMinInterval corresponds to TC_MIN_INTERVAL of OLSRv2 and represents the minimum interval between transmission of two successive TC messages by this rou… |
| 1.3.6.1.2.1.219.1.1.8 | Scalarolsrv2THoldTime | read-write | current | olsrv2THoldTime corresponds to T_HOLD_TIME of OLSRv2 and is used as the minimum value in the TLV with Type = VALIDITY_TIME included in all TC messages sent by … |
| 1.3.6.1.2.1.219.1.1.9 | Scalarolsrv2AHoldTime | read-write | current | olsrv2AHoldTime corresponds to A_HOLD_TIME of OLSRv2 and represents the period during which TC messages are sent after they no longer have any advertised infor… |
| 1.3.6.1.2.1.219.1.1.10 | Scalarolsrv2RxHoldTime | read-write | current | olsrv2RxHoldTime corresponds to RX_HOLD_TIME of OLSRv2 and represents the period after receipt of a message by the appropriate OLSRv2 interface of this router … |
| 1.3.6.1.2.1.219.1.1.11 | Scalarolsrv2PHoldTime | read-write | current | olsrv2PHoldTime corresponds to P_HOLD_TIME of OLSRv2 and represents the period after receipt of a message that is processed by this router for which that infor… |
| 1.3.6.1.2.1.219.1.1.12 | Scalarolsrv2FHoldTime | read-write | current | olsrv2FHoldTime corresponds to F_HOLD_TIME of OLSRv2 and represents the period after receipt of a message that is forwarded by this router for which that infor… |
| 1.3.6.1.2.1.219.1.1.13 | Scalarolsrv2TpMaxJitter | read-write | current | olsrv2TpMaxJitter corresponds to TP_MAXJITTER of OLSRv2 and represents the value of MAXJITTER used in RFC 5148 for periodically generated TC messages sent by t… |
| 1.3.6.1.2.1.219.1.1.14 | Scalarolsrv2TtMaxJitter | read-write | current | olsrv2TtMaxJitter corresponds to TT_MAXJITTER of OLSRv2 and represents the value of MAXJITTER used in RFC 5148 for externally triggered TC messages sent by thi… |
| 1.3.6.1.2.1.219.1.1.15 | Scalarolsrv2FMaxJitter | read-write | current | olsrv2FMaxJitter corresponds to F_MAXJITTER of OLSRv2 and represents the default value of MAXJITTER used in RFC 5148 for messages forwarded by this router. For… |
| 1.3.6.1.2.1.219.1.1.16 | Scalarolsrv2TcHopLimit | read-write | current | olsrv2TcHopLimit corresponds to TC_HOP_LIMIT of OLSRv2. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), whic… |
| 1.3.6.1.2.1.219.1.1.17 | Scalarolsrv2WillRouting | read-write | current | olsrv2WillRouting corresponds to WILL_ROUTING of OLSRv2. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), whi… |
| 1.3.6.1.2.1.219.1.1.18 | Scalarolsrv2WillFlooding | read-write | current | olsrv2WillFlooding corresponds to WILL_FLOODING of OLSRv2. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), w… |
| 1.3.6.1.2.1.219.1.1.19 | Scalarolsrv2LinkMetricType | read-write | current | olsrv2LinkMetricType corresponds to LINK_METRIC_TYPE of OLSRv2. If olsrv2LinkMetricType changes, then all link metric information recorded by this router is in… |
| 1.3.6.1.2.1.219.1.2 | Nodeolsrv2StateGroup | |||
| 1.3.6.1.2.1.219.1.2.1 | Tableolsrv2IibLinkSetTable | not-accessible | current | A Link Set of an interface records all links from other routers that are, or recently were, 1-hop neighbors. |
| 1.3.6.1.2.1.219.1.2.1.1 | Rowolsrv2IibLinkSetEntry | not-accessible | current | A Link Set consists of Link Tuples, each representing a single link indexed by the local and remote interface pair. Each Link Set from NHDP is extended by OLSR… |
| 1.3.6.1.2.1.219.1.2.1.1.1 | Columnolsrv2IibLinkSetInMetricValue | read-only | current | olsrv2IibLinkSetInMetricValue is the metric of the link from the OLSRv2 interface with addresses L_neighbor_iface_addr_list to this OLSRv2 interface. The L_nei… |
| 1.3.6.1.2.1.219.1.2.1.1.2 | Columnolsrv2IibLinkSetOutMetricValue | read-write | current | olsrv2IibLinkSetOutMetricValue is the metric of the link to the OLSRv2 interface with addresses L_neighbor_iface_addr_list from this OLSRv2 interface. The L_ne… |
| 1.3.6.1.2.1.219.1.2.1.1.3 | Columnolsrv2IibLinkSetMprSelector | read-only | current | olsrv2IibLinkSetMprSelector is a boolean flag, recording whether this neighbor has selected this router as a flooding MPR, i.e., is a flooding MPR selector of … |
| 1.3.6.1.2.1.219.1.2.2 | Tableolsrv2Iib2HopSetTable | not-accessible | current | A 2-Hop Set of an interface records network addresses of symmetric 2-hop neighbors, and the symmetric links to symmetric 1-hop neighbors through which these sy… |
| 1.3.6.1.2.1.219.1.2.2.1 | Rowolsrv2Iib2HopSetEntry | not-accessible | current | olsrv2Iib2HopSetTable consists of 2-Hop Tuples, each representing a single network address of a symmetric 2-hop neighbor and a single MANET interface of a symm… |
| 1.3.6.1.2.1.219.1.2.2.1.1 | Columnolsrv2Iib2HopSetInMetricValue | read-only | current | olsrv2Iib2HopSetInMetricValue is the neighbor metric from the router with address N2_2hop_iface_addr to the router with OLSRv2 interface addresses N2_neighbor_… |
| 1.3.6.1.2.1.219.1.2.2.1.2 | Columnolsrv2Iib2HopSetOutMetricValue | read-only | current | olsrv2Iib2HopSetOutMetricValue is the neighbor metric to the router with address N2_2hop_iface_addr from the router with OLSRv2 interface addresses N2_neighbor… |
| 1.3.6.1.2.1.219.1.2.3 | Tableolsrv2LibOrigSetTable | not-accessible | current | A router's Originator Set records addresses that were recently used as originator addresses by this router. |
| 1.3.6.1.2.1.219.1.2.3.1 | Rowolsrv2LibOrigSetEntry | not-accessible | current | A router's Originator Set consists of Originator Tuples: (O_orig_addr (olsrv2LibOrigSetIpAddrType and olsrv2LibOrigSetIpAddr), O_time (olsrv2LibOrigSetExpireTi… |
| 1.3.6.1.2.1.219.1.2.3.1.1 | Columnolsrv2LibOrigSetIpAddrType | not-accessible | current | The type of the olsrv2LibOrigSetIpAddr, as defined in the InetAddress MIB (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.3.1.2 | Columnolsrv2LibOrigSetIpAddr | not-accessible | current | An originator address recently employed by this router. |
| 1.3.6.1.2.1.219.1.2.3.1.3 | Columnolsrv2LibOrigSetExpireTime | read-only | current | olsrv2LibOrigSetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2LibOrigSetTable. This time is determine… |
| 1.3.6.1.2.1.219.1.2.4 | Tableolsrv2LibLocAttNetSetTable | not-accessible | current | A router's Local Attached Network Set records its local non-OLSRv2 interfaces via which it can act as a gateway to other networks. |
| 1.3.6.1.2.1.219.1.2.4.1 | Rowolsrv2LibLocAttNetSetEntry | not-accessible | current | The entries include the Local Attached Network Tuples: (AL_net_addr (olsrv2LibLocAttNetSetIpAddr), AL_dist (olsrv2LibLocAttNetSetDistance), AL_metric (olsrv2Li… |
| 1.3.6.1.2.1.219.1.2.4.1.1 | Columnolsrv2LibLocAttNetSetIpAddrType | not-accessible | current | The type of the olsrv2LibLocAttNetSetIpAddr, as defined in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.4.1.2 | Columnolsrv2LibLocAttNetSetIpAddr | not-accessible | current | This is the network address of an attached network that can be reached via this router. |
| 1.3.6.1.2.1.219.1.2.4.1.3 | Columnolsrv2LibLocAttNetSetIpAddrPrefixLen | not-accessible | current | Indicates the number of leading one bits that form the mask to be logically ANDed with the destination address before being compared to the value in the olsrv2… |
| 1.3.6.1.2.1.219.1.2.4.1.4 | Columnolsrv2LibLocAttNetSetDistance | read-only | current | This object specifies the number of hops to the network with address olsrv2LibLocAttNetSetIpAddr from this router. |
| 1.3.6.1.2.1.219.1.2.4.1.5 | Columnolsrv2LibLocAttNetSetMetricValue | read-only | current | This object specifies the metric of the link to the attached network with address AL_net_addr from this router. The AL_net_addr is defined by the tuple (olsrv2… |
| 1.3.6.1.2.1.219.1.2.5 | Tableolsrv2NibNeighborSetTable | not-accessible | current | A router's Neighbor Set records all network addresses of each 1-hop neighbor. It consists of Neighbor Tuples, each representing a single 1-hop neighbor. |
| 1.3.6.1.2.1.219.1.2.5.1 | Rowolsrv2NibNeighborSetEntry | not-accessible | current | Each Neighbor Tuple in the Neighbor Set, defined in RFC 6130, has these additional elements: N_orig_addr (olsrv2NibNeighborSetNOrigIpAddrType, olsrv2NibNeighbo… |
| 1.3.6.1.2.1.219.1.2.5.1.1 | Columnolsrv2NibNeighborSetNOrigIpAddrType | read-only | current | The type of the olsrv2NibNeighborSetNOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.5.1.2 | Columnolsrv2NibNeighborSetNOrigIpAddr | read-only | current | This is the originator IP address of the neighbor represented by this table entry. |
| 1.3.6.1.2.1.219.1.2.5.1.3 | Columnolsrv2NibNeighborSetNInMetricValue | read-only | current | This object is the neighbor metric of any link from this neighbor to an OLSRv2 interface of this router, i.e., the minimum of all corresponding L_in_metric (ol… |
| 1.3.6.1.2.1.219.1.2.5.1.4 | Columnolsrv2NibNeighborSetNOutMetricValue | read-only | current | This object is the neighbor metric of any link from an OLSRv2 interface of this router to this neighbor, i.e., the minimum of all corresponding L_out_metric (o… |
| 1.3.6.1.2.1.219.1.2.5.1.5 | Columnolsrv2NibNeighborSetNWillFlooding | read-only | current | This object is the neighbor's willingness to be selected as a flooding MPR, in the range from WILL_NEVER to WILL_ALWAYS, both inclusive, taking the value WILL_… |
| 1.3.6.1.2.1.219.1.2.5.1.6 | Columnolsrv2NibNeighborSetNWillRouting | read-only | current | This object is the neighbor's willingness to be selected as a routing MPR, in the range from WILL_NEVER to WILL_ALWAYS, both inclusive, taking the value WILL_N… |
| 1.3.6.1.2.1.219.1.2.5.1.7 | Columnolsrv2NibNeighborSetNFloodingMpr | read-only | current | This object is a boolean flag, recording whether this neighbor is selected as a flooding MPR by this router. |
| 1.3.6.1.2.1.219.1.2.5.1.8 | Columnolsrv2NibNeighborSetNRoutingMpr | read-only | current | This object is a boolean flag, recording whether this neighbor is selected as a routing MPR by this router. |
| 1.3.6.1.2.1.219.1.2.5.1.9 | Columnolsrv2NibNeighborSetNMprSelector | read-only | current | This object is a boolean flag, recording whether this neighbor has selected this router as a routing MPR, i.e., is a routing MPR selector of this router. When … |
| 1.3.6.1.2.1.219.1.2.5.1.10 | Columnolsrv2NibNeighborSetNAdvertised | read-only | current | This object, N_mpr_selector (olsrv2NibNeighborSetNMprSelector), is a boolean flag, recording whether this router has elected to advertise a link to this neighb… |
| 1.3.6.1.2.1.219.1.2.6 | Scalarolsrv2NibNeighborSetTableAnsn | read-only | current | Advertised Neighbor Sequence Number (ANSN), is a variable, whose value is included in TC messages to indicate the freshness of the information transmitted. |
| 1.3.6.1.2.1.219.1.2.7 | Tableolsrv2TibAdRemoteRouterSetTable | not-accessible | current | A router's Advertising Remote Router Set records information describing each remote router in the network that transmits TC messages. |
| 1.3.6.1.2.1.219.1.2.7.1 | Rowolsrv2TibAdRemoteRouterSetEntry | not-accessible | current | A router's Advertised Neighbor Set Table entry consists of Advertising Remote Router Tuples: (AR_orig_addr (olsrv2TibAdRemoteRouterSetIpAddrType, olsrv2TibAdRe… |
| 1.3.6.1.2.1.219.1.2.7.1.1 | Columnolsrv2TibAdRemoteRouterSetIpAddrType | not-accessible | current | The type of the olsrv2TibAdRemoteRouterSetIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.7.1.2 | Columnolsrv2TibAdRemoteRouterSetIpAddr | not-accessible | current | This is the originator address of a received TC message. |
| 1.3.6.1.2.1.219.1.2.7.1.3 | Columnolsrv2TibAdRemoteRouterSetMaxSeqNo | read-only | current | This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address olsrv2TibAdR… |
| 1.3.6.1.2.1.219.1.2.7.1.4 | Columnolsrv2TibAdRemoteRouterSetExpireTime | read-only | current | olsrv2TibAdRemoteRouterSetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibAdRemoteRouterSetTable. |
| 1.3.6.1.2.1.219.1.2.8 | Tableolsrv2TibRouterTopologySetTable | not-accessible | current | A router's Router Topology Set records topology information about the network. |
| 1.3.6.1.2.1.219.1.2.8.1 | Rowolsrv2TibRouterTopologySetEntry | not-accessible | current | It consists of Router Topology Tuples: (TR_from_orig_addr (olsrv2TibRouterTopologySetFromOrigIpAddrType, olsrv2TibRouterTopologySetFromOrigIpAddr), TR_to_orig_… |
| 1.3.6.1.2.1.219.1.2.8.1.1 | Columnolsrv2TibRouterTopologySetFromOrigIpAddrType | not-accessible | current | The type of the olsrv2TibRouterTopologySetFromOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are suppo… |
| 1.3.6.1.2.1.219.1.2.8.1.2 | Columnolsrv2TibRouterTopologySetFromOrigIpAddr | not-accessible | current | This is the originator address of a router that can reach the router with originator address TR_to_orig_addr in one hop. |
| 1.3.6.1.2.1.219.1.2.8.1.3 | Columnolsrv2TibRouterTopologySetToOrigIpAddrType | not-accessible | current | The type of the olsrv2TibRouterTopologySetToOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are support… |
| 1.3.6.1.2.1.219.1.2.8.1.4 | Columnolsrv2TibRouterTopologySetToOrigIpAddr | not-accessible | current | This is the originator address of a router that can be reached by the router with originator address TR_to_orig_addr in one hop. |
| 1.3.6.1.2.1.219.1.2.8.1.5 | Columnolsrv2TibRouterTopologySetSeqNo | read-only | current | This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address TR_from_orig… |
| 1.3.6.1.2.1.219.1.2.8.1.6 | Columnolsrv2TibRouterTopologySetMetricValue | read-only | current | This is the neighbor metric from the router with originator address TR_from_orig_addr (olsrv2TibRouterTopologySetFromOrigIpAddrType, olsrv2TibRouterTopologySet… |
| 1.3.6.1.2.1.219.1.2.8.1.7 | Columnolsrv2TibRouterTopologySetExpireTime | read-only | current | olsrv2TibRouterTopologySetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibRouterTopologySetTable. |
| 1.3.6.1.2.1.219.1.2.9 | Tableolsrv2TibRoutableAddressTopologySetTable | not-accessible | current | A router's Routable Address Topology Set records topology information about the routable addresses within the MANET, including via which routers they may be re… |
| 1.3.6.1.2.1.219.1.2.9.1 | Rowolsrv2TibRoutableAddressTopologySetEntry | not-accessible | current | It consists of Router Topology Tuples: (TA_from_orig_addr (olsrv2TibRoutableAddressTopologySetFromOrigIpAddrType olsrv2TibRoutableAddressTopologySetFromOrigIpA… |
| 1.3.6.1.2.1.219.1.2.9.1.1 | Columnolsrv2TibRoutableAddressTopologySetFromOrigIpAddrType | not-accessible | current | The type of the olsrv2TibRoutableAddressTopologySetFromOrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)'… |
| 1.3.6.1.2.1.219.1.2.9.1.2 | Columnolsrv2TibRoutableAddressTopologySetFromOrigIpAddr | not-accessible | current | This is the originator address of a router that can reach the router with routable address TA_dest_addr in one hop. |
| 1.3.6.1.2.1.219.1.2.9.1.3 | Columnolsrv2TibRoutableAddressTopologySetDestIpAddrType | not-accessible | current | The type of the olsrv2TibRouterTopologySetToOrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are suppor… |
| 1.3.6.1.2.1.219.1.2.9.1.4 | Columnolsrv2TibRoutableAddressTopologySetDestIpAddr | not-accessible | current | This is a routable address of a router that can be reached by the router with originator address TA_from_orig_addr in one hop. The TA_from_orig_addr is defined… |
| 1.3.6.1.2.1.219.1.2.9.1.5 | Columnolsrv2TibRoutableAddressTopologySetSeqNo | read-only | current | This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address TA_from_orig… |
| 1.3.6.1.2.1.219.1.2.9.1.6 | Columnolsrv2TibRoutableAddressTopologySetMetricValue | read-only | current | This is the neighbor metric from the router with originator address TA_from_orig_addr (defined by the tuple (olsrv2TibRoutableAddressTopologySetFromOrigIpAddrT… |
| 1.3.6.1.2.1.219.1.2.9.1.7 | Columnolsrv2TibRoutableAddressTopologySetExpireTime | read-only | current | olsrv2TibRoutableAddressTopologySetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibRoutableAddressTo… |
| 1.3.6.1.2.1.219.1.2.10 | Tableolsrv2TibAttNetworksSetTable | not-accessible | current | A router's Attached Network Set records information about networks (which may be outside the MANET) attached to other routers and their routable addresses. |
| 1.3.6.1.2.1.219.1.2.10.1 | Rowolsrv2TibAttNetworksSetEntry | not-accessible | current | It consists of Attached Network Tuples: (AN_orig_addr (olsrv2TibAttNetworksSetOrigIpAddrType, olsrv2TibAttNetworksSetOrigIpAddr), AN_net_addr (olsrv2TibAttNetw… |
| 1.3.6.1.2.1.219.1.2.10.1.1 | Columnolsrv2TibAttNetworksSetOrigIpAddrType | not-accessible | current | The type of the olsrv2TibAttNetworksSetOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.10.1.2 | Columnolsrv2TibAttNetworksSetOrigIpAddr | not-accessible | current | This is the originator address, of type olsrv2TibAttNetworksSetOrigIpAddrType, of a router that can act as gateway to the network with address AN_net_addr. The… |
| 1.3.6.1.2.1.219.1.2.10.1.3 | Columnolsrv2TibAttNetworksSetNetIpAddrType | not-accessible | current | The type of the olsrv2TibAttNetworksSetNetIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.10.1.4 | Columnolsrv2TibAttNetworksSetNetIpAddr | not-accessible | current | This is the network address, of type olsrv2TibAttNetworksSetNetIpAddrType, of an attached network, that may be reached via the router with originator address A… |
| 1.3.6.1.2.1.219.1.2.10.1.5 | Columnolsrv2TibAttNetworksSetNetIpAddrPrefixLen | not-accessible | current | Indicates the number of leading one bits that form the mask to be logically ANDed with the destination address before being compared to the value in the olsrv2… |
| 1.3.6.1.2.1.219.1.2.10.1.6 | Columnolsrv2TibAttNetworksSetSeqNo | read-only | current | This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address AN_orig_addr… |
| 1.3.6.1.2.1.219.1.2.10.1.7 | Columnolsrv2TibAttNetworksSetDist | read-only | current | The number of hops to the network with address AN_net_addr from the router with originator address AN_orig_addr. The AN_orig_addr is defined by the tuple (olsr… |
| 1.3.6.1.2.1.219.1.2.10.1.9 | Columnolsrv2TibAttNetworksSetMetricValue | read-only | current | The metric of the link from the router with originator address AN_orig_addr to the attached network with address AN_net_addr. The AN_net_addr is defined by the… |
| 1.3.6.1.2.1.219.1.2.10.1.10 | Columnolsrv2TibAttNetworksSetExpireTime | read-only | current | olsrv2TibAttNetworksSetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibAttNetworksSetTable. |
| 1.3.6.1.2.1.219.1.2.11 | Tableolsrv2TibRoutingSetTable | not-accessible | current | A router's Routing Set records the first hop along a selected path to each destination for which any such path is known. |
| 1.3.6.1.2.1.219.1.2.11.1 | Rowolsrv2TibRoutingSetEntry | not-accessible | current | It consists of Routing Tuples: (R_dest_addr, R_next_iface_addr, R_local_iface_addr, R_dist, R_metric) |
| 1.3.6.1.2.1.219.1.2.11.1.1 | Columnolsrv2TibRoutingSetDestIpAddrType | not-accessible | current | The type of the olsrv2TibRoutingSetDestIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.11.1.2 | Columnolsrv2TibRoutingSetDestIpAddr | not-accessible | current | This is the address of the destination, either the address of an interface of a destination router or the network address of an attached network. |
| 1.3.6.1.2.1.219.1.2.11.1.3 | Columnolsrv2TibRoutingSetDestIpAddrPrefixLen | not-accessible | current | Indicates the number of leading one bits that form the mask to be logically ANDed with the destination address before being compared to the value in the olsrv2… |
| 1.3.6.1.2.1.219.1.2.11.1.4 | Columnolsrv2TibRoutingSetNextIfIpAddrType | read-only | current | The type of the olsrv2TibRoutingSetNextIfIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. |
| 1.3.6.1.2.1.219.1.2.11.1.5 | Columnolsrv2TibRoutingSetNextIfIpAddr | read-only | current | This object is the OLSRv2 interface address of the next hop on the selected path to the destination. |
| 1.3.6.1.2.1.219.1.2.11.1.6 | Columnolsrv2TibRoutingSetLocalIfIpAddrType | read-only | current | The type of the olsrv2TibRoutingSetLocalIfIpAddr and olsrv2TibRoutingSetNextIfIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv… |
| 1.3.6.1.2.1.219.1.2.11.1.7 | Columnolsrv2TibRoutingSetLocalIfIpAddr | read-only | current | This object is the address of the local OLSRv2 interface over which a packet must be sent to reach the destination by the selected path. |
| 1.3.6.1.2.1.219.1.2.11.1.8 | Columnolsrv2TibRoutingSetDist | read-only | current | This object is the number of hops on the selected path to the destination. |
| 1.3.6.1.2.1.219.1.2.11.1.9 | Columnolsrv2TibRoutingSetMetricValue | read-only | current | This object is the metric of the route to the destination with address R_dest_addr. The maximum value of this object can be 256 times MAXIMUM_METRIC, as repres… |
| 1.3.6.1.2.1.219.1.3 | Nodeolsrv2PerformanceObjGrp | |||
| 1.3.6.1.2.1.219.1.3.1 | Tableolsrv2InterfacePerfTable | not-accessible | current | This table summarizes performance objects that are measured per each active local OLSRv2 interface. If the olsrv2InterfaceAdminStatus of the interface changes … |
| 1.3.6.1.2.1.219.1.3.1.1 | Rowolsrv2InterfacePerfEntry | not-accessible | current | A single entry contains performance counters for each active local OLSRv2 interface. |
| 1.3.6.1.2.1.219.1.3.1.1.1 | Columnolsrv2IfTcMessageXmits | read-only | current | A counter is incremented each time a TC message has been transmitted on that interface. |
| 1.3.6.1.2.1.219.1.3.1.1.2 | Columnolsrv2IfTcMessageRecvd | read-only | current | A counter is incremented each time a TC message has been received on that interface. This excludes all messages that are ignored due to OLSRv2 protocol procedu… |
| 1.3.6.1.2.1.219.1.3.1.1.3 | Columnolsrv2IfTcMessageXmitAccumulatedSize | read-only | current | A counter is incremented by the number of octets in a TC message each time a TC message has been sent. |
| 1.3.6.1.2.1.219.1.3.1.1.4 | Columnolsrv2IfTcMessageRecvdAccumulatedSize | read-only | current | A counter is incremented by the number of octets in a TC message each time a TC message has been received. This excludes all messages that are ignored due to O… |
| 1.3.6.1.2.1.219.1.3.1.1.5 | Columnolsrv2IfTcMessageTriggeredXmits | read-only | current | A counter is incremented each time a triggered TC message has been sent. |
| 1.3.6.1.2.1.219.1.3.1.1.6 | Columnolsrv2IfTcMessagePeriodicXmits | read-only | current | A counter is incremented each time a periodic TC message has been sent. |
| 1.3.6.1.2.1.219.1.3.1.1.7 | Columnolsrv2IfTcMessageForwardedXmits | read-only | current | A counter is incremented each time a TC message has been forwarded. |
| 1.3.6.1.2.1.219.1.3.1.1.8 | Columnolsrv2IfTcMessageXmitAccumulatedMPRSelectorCount | read-only | current | A counter is incremented by the number of advertised MPR selectors in a TC each time a TC message has been sent. |
| 1.3.6.1.2.1.219.1.3.2 | Scalarolsrv2RoutingSetRecalculationCount | read-only | current | This counter increments each time the Routing Set has been recalculated. |
| 1.3.6.1.2.1.219.1.3.3 | Scalarolsrv2MPRSetRecalculationCount | read-only | current | This counter increments each time the MPRs of this router have been recalculated for any of its interfaces. |
| 1.3.6.1.2.1.219.2 | Nodeolsrv2MIBConformance | |||
| 1.3.6.1.2.1.219.2.1 | Nodeolsrv2Compliances | |||
| 1.3.6.1.2.1.219.2.1.1 | Complianceolsrv2BasicCompliance | current | The basic implementation requirements for managed network entities that implement the OLSRv2 routing process. | |
| 1.3.6.1.2.1.219.2.1.2 | Complianceolsrv2FullCompliance | current | The full implementation requirements for managed network entities that implement the OLSRv2 routing process. | |
| 1.3.6.1.2.1.219.2.2 | Nodeolsrv2MIBGroups | |||
| 1.3.6.1.2.1.219.2.2.1 | Groupolsrv2ConfigObjectsGroup | current | Objects to permit configuration of OLSRv2. All of these SHOULD be backed by non-volatile storage. | |
| 1.3.6.1.2.1.219.2.2.2 | Groupolsrv2StateObjectsGroup | current | Objects to permit monitoring of OLSRv2 state. | |
| 1.3.6.1.2.1.219.2.2.3 | Groupolsrv2PerfObjectsGroup | current | Objects to support monitoring of OLSRv2 performance. | |
| 1.3.6.1.2.1.219.2.2.4 | Groupolsrv2NotificationsObjectsGroup | current | Objects to support the notification types in the olsrv2NotificationsGroup. Some of these appear in notification payloads, others serve to control notification … | |
| 1.3.6.1.2.1.219.2.2.5 | Groupolsrv2NotificationsGroup | current | Notification types to support management of OLSRv2. |
Type Definitions
| Name | Syntax | Status | Description |
|---|---|---|---|
| Olsrv2MetricValueCompressedFormTC | Unsigned32 (0..16776960) | current | OLSRv2 Metrics are expressed in terms of a Link Metric Compressed Form within the OLSRv2 protocol. This textual convention defines the syntax of the metric objects consistent with the definitions of the OLSRv2 Link Metr… |
| Olsrv2StatusTC | INTEGER { enabled (1), disabled (2) } | current | Controls the operation of the OLSRv2 protocol on the device or a specific interface. For example, for an interface, 'enabled' indicates that OLSRv2 is permitted to operate, and 'disabled' indicates that it is not. |
| Olsrv2TimeValueCompressedForm32TC | Unsigned32 (1..3932160000) | current | OLSRv2 time values may be expressed in terms of a compressed form within the OLSRv2 protocol. This textual convention defines the syntax of the time objects defined in terms of an integer number of milliseconds, consist… |
| WillingnessTC | Unsigned32 (0..15) | current | A willingness value that evaluates to the device's interest in participating in a particular function, process, or behavior. The willingness ranges from a low value of WILL_NEVER(0) to a high value of WILL_ALWAYS(15). F… |