MIB Viewer

DOCS-MCAST-MIB

64 objects
This MIB module contains the management objects for the management of Multicast over DOCSIS to support Multicast DSID forwarding and or bonded multicast.
Imported Objects
CLAB-DEF-MIBclabProjDocsis
DOCS-IETF-BPI2-MIB-- RFC 2863 DocsBpkmDataEncryptAlg DocsSAId
DOCS-IF3-MIB-- RFC 4131 ChSetId Dsid
IF-MIB-- RFC 4001 InterfaceIndex ifIndex
INET-ADDRESS-MIB-- RFC 3411 InetAddressType InetAddress InetAddressPrefixLength
SNMP-FRAMEWORK-MIB-- RFC 2580 SnmpAdminString
SNMPv2-CONF-- RFC 2579 OBJECT-GROUP MODULE-COMPLIANCE
SNMPv2-SMIMODULE-IDENTITY OBJECT-TYPE Unsigned32
SNMPv2-TC-- RFC 2578 RowStatus TruthValue
OIDNameAccessStatusDescription
1.3.6.1.4.1.4491.2.1.18IdentitydocsMcastMibThis MIB module contains the management objects for the management of Multicast over DOCSIS to support Multicast DSID forwarding and or bonded multicast.
1.3.6.1.4.1.4491.2.1.18.1NodedocsMcastMibObjects
1.3.6.1.4.1.4491.2.1.18.1.1TabledocsMcastCmtsGrpCfgTablenot-accessiblecurrentThis object controls the QoS, PHS and encryption settings for downstream forwarding of IP multicast sessions. An IP multicast session is replicated to one or m…
1.3.6.1.4.1.4491.2.1.18.1.1.1RowdocsMcastCmtsGrpCfgEntrynot-accessiblecurrentThe conceptual row of docsMcastCmtsGrpCfg. The CMTS persists all instances of the CmtsGrpConfig object across system reinitializations.
1.3.6.1.4.1.4491.2.1.18.1.1.1.1ColumndocsMcastCmtsGrpCfgIdnot-accessiblecurrentThis attribute represents the unique identifier of instances of this object. This attribute is the key that identifies unique instances of the CmtsGrpConfig ob…
1.3.6.1.4.1.4491.2.1.18.1.1.1.2ColumndocsMcastCmtsGrpCfgRulePriorityread-createcurrentThis attribute indicates the priority of this entry used to resolve which instance of this object apply when a newly replicated multicast session matches multi…
1.3.6.1.4.1.4491.2.1.18.1.1.1.3ColumndocsMcastCmtsGrpCfgPrefixAddrTyperead-createcurrentThis attribute identifies the address family for the multicast session (S,G) of the GC which corresponds to the SrcPrefixAddr and GrpPrefixAddr attributes resp…
1.3.6.1.4.1.4491.2.1.18.1.1.1.4ColumndocsMcastCmtsGrpCfgSrcPrefixAddrread-createcurrentThis attribute defines the IP source address prefix of the IP multicast session. Source prefix addresses are unicast host addresses.
1.3.6.1.4.1.4491.2.1.18.1.1.1.5ColumndocsMcastCmtsGrpCfgSrcPrefixLenread-createcurrentThis attribute identifies the prefix of a range of Source (S) IP multicast group addresses. For Group or ASM based sessions this attribute is set to 0.
1.3.6.1.4.1.4491.2.1.18.1.1.1.6ColumndocsMcastCmtsGrpCfgGrpPrefixAddrread-createcurrentThis attribute identifies the prefix of a range of destination IP multicast group addresses.
1.3.6.1.4.1.4491.2.1.18.1.1.1.7ColumndocsMcastCmtsGrpCfgGrpPrefixLenread-createcurrentThis attribute identifies the prefix of a range of IP multicast group addresses.
1.3.6.1.4.1.4491.2.1.18.1.1.1.8ColumndocsMcastCmtsGrpCfgTosLowread-createcurrentThis attribute identifies the low value of a range of the TOS byte value to be defined in a packet classifier this GC instantiates in the GCR in order to limit…
1.3.6.1.4.1.4491.2.1.18.1.1.1.9ColumndocsMcastCmtsGrpCfgTosHighread-createcurrentThis attribute identifies the high value of a range of the TOS byte value to be defined in a packet classifier this GC instantiates in the GCR in order to limi…
1.3.6.1.4.1.4491.2.1.18.1.1.1.10ColumndocsMcastCmtsGrpCfgTosMaskread-createcurrentThis attribute identifies the mask value bitwise ANDed with a TOS byte value to be defined in a packet classifier this GC instantiates in the GCR in order to l…
1.3.6.1.4.1.4491.2.1.18.1.1.1.11ColumndocsMcastCmtsGrpCfgQosConfigIdread-createcurrentThis attribute identifies an instance in CmtsGrpQosCfg for configuring the QoS for the replication of the sessions matching this CmtsGrpCfg instance. The value…
1.3.6.1.4.1.4491.2.1.18.1.1.1.12ColumndocsMcastCmtsGrpCfgEncryptConfigIdread-createcurrentThis attribute identifies an instance in CmtsGrpEncryptionCfg for configuring the encryption of replicationsderived from this GC. The value 0 indicates no encr…
1.3.6.1.4.1.4491.2.1.18.1.1.1.13ColumndocsMcastCmtsGrpCfgPhsConfigIdread-createcurrentThis attribute identifies an instance in CmtsGrpPhsCfg that configures DSID-indexed PHS compression for all replications derived from this GC. The value 0 indi…
1.3.6.1.4.1.4491.2.1.18.1.1.1.14ColumndocsMcastCmtsGrpCfgRowStatusread-createcurrentThe status of this instance.
1.3.6.1.4.1.4491.2.1.18.1.2TabledocsMcastCmtsGrpEncryptCfgTablenot-accessiblecurrentThis object controls the configuration of the Security Association (SA) and the encryption algorithm used for multicast sessions. This object supports the crea…
1.3.6.1.4.1.4491.2.1.18.1.2.1RowdocsMcastCmtsGrpEncryptCfgEntrynot-accessiblecurrentThe conceptual row of docsMcastCmtsGrpEncryptCfg. The CMTS persists all instances of the CmtsGrpEncryptionConfig object across system reinitializations.
1.3.6.1.4.1.4491.2.1.18.1.2.1.1ColumndocsMcastCmtsGrpEncryptCfgIdnot-accessiblecurrentThis attribute specifies the unique identifier of instances of this object
1.3.6.1.4.1.4491.2.1.18.1.2.1.2ColumndocsMcastCmtsGrpEncryptCfgCtrlread-createcurrentThis attribute controls whether the CMTS can select the encryption algorithm or if this can be set manually using the Alg attribute. If this attribute is set t…
1.3.6.1.4.1.4491.2.1.18.1.2.1.3ColumndocsMcastCmtsGrpEncryptCfgAlgread-createcurrentThis attribute defines which encryption algorithm will be used for an SA referenced by this object when the Ctrl is set to 'mgmt'.
1.3.6.1.4.1.4491.2.1.18.1.2.1.4ColumndocsMcastCmtsGrpEncryptCfgRowStatusread-createcurrentThe status of this instance.
1.3.6.1.4.1.4491.2.1.18.1.3TabledocsMcastCmtsGrpPhsCfgTablenot-accessiblecurrentThis object controls the configuration of DSID-indexed PHS for multicast sessions. Configuration of PHS Rules via this table must not be based on the configura…
1.3.6.1.4.1.4491.2.1.18.1.3.1RowdocsMcastCmtsGrpPhsCfgEntrynot-accessiblecurrentThe conceptual row of docsMcastCmtsGrpPhsCfg. The CMTS persists all instances of the CmtsGrpPhsConfig object across system reinitializations.
1.3.6.1.4.1.4491.2.1.18.1.3.1.1ColumndocsMcastCmtsGrpPhsCfgIdnot-accessiblecurrentThis attribute identifies the unique identifier of a PHS rule that is referenced by the GrpConfig object.
1.3.6.1.4.1.4491.2.1.18.1.3.1.2ColumndocsMcastCmtsGrpPhsCfgPhsFieldread-createcurrentThis attribute defines the bytes of the DOCSIS header which must be suppressed/restored by the sending/receiving device.
1.3.6.1.4.1.4491.2.1.18.1.3.1.3ColumndocsMcastCmtsGrpPhsCfgPhsMaskread-createcurrentThis attribute defines the bit mask which is used in combination with the PhsField to define which bytes in header must be suppressed/restored by the sending o…
1.3.6.1.4.1.4491.2.1.18.1.3.1.4ColumndocsMcastCmtsGrpPhsCfgPhsSizeread-createcurrentThis attribute specifies the number of bytes in the header to be suppressed and restored. The value of this object matches the number of bytes the bits indicat…
1.3.6.1.4.1.4491.2.1.18.1.3.1.5ColumndocsMcastCmtsGrpPhsCfgPhsVerifyread-createcurrentThis attribute specifies the Payload Header Suppression verification value of 'true' the sender must verify PhsField is the same as what is contained in the pa…
1.3.6.1.4.1.4491.2.1.18.1.3.1.6ColumndocsMcastCmtsGrpPhsCfgRowStatusread-createcurrentThe status of this instance.
1.3.6.1.4.1.4491.2.1.18.1.4TabledocsMcastCmtsGrpQosCfgTablenot-accessiblecurrentThis object configures the QoS configured for Multicast sessions replicated to any Downstream Channel Set. It does not control which particular DCSs to which t…
1.3.6.1.4.1.4491.2.1.18.1.4.1RowdocsMcastCmtsGrpQosCfgEntrynot-accessiblecurrentThe conceptual row of docsMcastCmtsGrpQosCfg. The CMTS persists all instances of the CmtsGrpQosConfig object across system reinitialization.
1.3.6.1.4.1.4491.2.1.18.1.4.1.1ColumndocsMcastCmtsGrpQosCfgIdnot-accessiblecurrentThis attribute identifies a unique Group QoS Configuration object instance.
1.3.6.1.4.1.4491.2.1.18.1.4.1.2ColumndocsMcastCmtsGrpQosCfgServiceClassNameread-createcurrentThis attribute identifies the Service Class Name reference for the set of QoS parameters for this GQC.
1.3.6.1.4.1.4491.2.1.18.1.4.1.3ColumndocsMcastCmtsGrpQosCfgQosCtrlread-createcurrentThis attribute identifies how Group Classifier Rules (GCRs) and Group Service Flows (GSFs) are instantiated when multiple sessions match the (S,G) criteria of …
1.3.6.1.4.1.4491.2.1.18.1.4.1.4ColumndocsMcastCmtsGrpQosCfgAggSessLimitread-createcurrentThis attribute identifies the maximum number of sessions that may be aggregated in an aggregated Service Flow. This value is ignored in case of a GQC entry wit…
1.3.6.1.4.1.4491.2.1.18.1.4.1.5ColumndocsMcastCmtsGrpQosCfgAppIdread-createcurrentThis attribute configures an application identifier that an operator configures to enable special features for QoS admission control or other policies. The beh…
1.3.6.1.4.1.4491.2.1.18.1.4.1.6ColumndocsMcastCmtsGrpQosCfgRowStatusread-createcurrentThe status of this instance.
1.3.6.1.4.1.4491.2.1.18.1.5TabledocsMcastCmtsReplSessTablenot-accessiblecurrentThis object describes the replication of IP Multicast sessions onto the different Downstream Channel Sets of a CMTS. Each DCS may be either a single downstream…
1.3.6.1.4.1.4491.2.1.18.1.5.1RowdocsMcastCmtsReplSessEntrynot-accessiblecurrentThe conceptual row of docsMcastCmtsReplSess.
1.3.6.1.4.1.4491.2.1.18.1.5.1.1ColumndocsMcastCmtsReplSessPrefixAddrTypenot-accessiblecurrentThis atrribute defines the address type for the GrpPrefix and SrcPrefix addresses.
1.3.6.1.4.1.4491.2.1.18.1.5.1.2ColumndocsMcastCmtsReplSessGrpPrefixnot-accessiblecurrentThis attribute defines the group G of a particular (S,G) IP multicast session.
1.3.6.1.4.1.4491.2.1.18.1.5.1.3ColumndocsMcastCmtsReplSessSrcPrefixnot-accessiblecurrentThis attribute identifies a specific Multicast Source Address. A Source Address that is all zeros is defined as 'all source addresses (*, G)'.
1.3.6.1.4.1.4491.2.1.18.1.5.1.4ColumndocsMcastCmtsReplSessMdIfIndexnot-accessiblecurrentThis attribute defines the MAC Domain Interface index of the channel to which the (S,G) session is replicated.
1.3.6.1.4.1.4491.2.1.18.1.5.1.5ColumndocsMcastCmtsReplSessDcsIdnot-accessiblecurrentThis attribute provides the reference for the Downstream Channel Set within a MAC Domain that the multicast session (S,G) is replicated to.
1.3.6.1.4.1.4491.2.1.18.1.5.1.6ColumndocsMcastCmtsReplSessServiceFlowIdnot-accessiblecurrentThis attribute indicates the service flow into which packets are classified for this replication of the multicast session (S,G).
1.3.6.1.4.1.4491.2.1.18.1.5.1.7ColumndocsMcastCmtsReplSessDsidread-onlycurrentThis attribute defines the Downstream Service ID (DSID) label with which the CMTS labels all packets of the (S,G) session on the DCS of a MAC Domain. The DSID …
1.3.6.1.4.1.4491.2.1.18.1.5.1.8ColumndocsMcastCmtsReplSessSaidread-onlycurrentThis attribute defines the Security Association ID (SAID) of this multicast replication session. The value 0 indicates no SAID assocated with this session.
1.3.6.1.4.1.4491.2.1.18.1.6NodedocsMcastDefGrpSvcClass
1.3.6.1.4.1.4491.2.1.18.1.6.1ScalardocsMcastDefGrpSvcClassDefread-writecurrentThis attribute references an instance of the SNMP table docsIetfQosServiceClassName object. This attribute is used to expand the QoS parameter Set of QoS for m…
1.3.6.1.4.1.4491.2.1.18.1.7TabledocsMcastDsidPhsTablenot-accessiblecurrentThis object reports the set of DSID-Indexed PHS rules that are signaled between the CMTS and CMs as part of the Multicast Sessions setup. The attributes PhsMas…
1.3.6.1.4.1.4491.2.1.18.1.7.1RowdocsMcastDsidPhsEntrynot-accessiblecurrentThe conceptual row of docsMcastDsidPhs. The ifIndex key corresponds to the MAC Domain interface where the PHSI-Indexed DSID is configured.
1.3.6.1.4.1.4491.2.1.18.1.7.1.1ColumndocsMcastDsidPhsDsidnot-accessiblecurrentThis attribute represents the 20-bit DSID associated with this PHS rule.
1.3.6.1.4.1.4491.2.1.18.1.7.1.2ColumndocsMcastDsidPhsPhsFieldread-onlycurrentThis attribute defines the bytes of the header which must be suppressed/restored by the sending/receiving device.
1.3.6.1.4.1.4491.2.1.18.1.7.1.3ColumndocsMcastDsidPhsPhsMaskread-onlycurrentThis attribute defnes the Payload Header Suppression mask in the header to be suppressed and restored.
1.3.6.1.4.1.4491.2.1.18.1.7.1.4ColumndocsMcastDsidPhsPhsSizeread-onlycurrentThis attribute defines the the number of bytes in the header to be suppressed and restored.
1.3.6.1.4.1.4491.2.1.18.1.7.1.5ColumndocsMcastDsidPhsPhsVerifyread-onlycurrentThis attribute, when set to 'true', indicates that the sender must verify that the PHS Field attribute value is the same is the same as what is contained in th…
1.3.6.1.4.1.4491.2.1.18.2NodedocsMcastMibConformance
1.3.6.1.4.1.4491.2.1.18.2.1NodedocsMcastMibCompliances
1.3.6.1.4.1.4491.2.1.18.2.1.1CompliancedocsMcastCompliancecurrentThe compliance statement for devices that implement the DOCSIS Multicast MIB.
1.3.6.1.4.1.4491.2.1.18.2.2NodedocsMcastMibGroups
1.3.6.1.4.1.4491.2.1.18.2.2.1GroupdocsMcastGroupcurrentGroup of objects implemented in the CMTS.