MPLS-TE-EXT-STD-MIB
41 objects
This MIB module contains generic object definitions for extending the MPLS Traffic Engineering tunnels in transport networks. Copyright (c) 2015 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
Imported Objects
| DIFFSERV-MIB | -- RFC 2579 IndexIntegerNextFree |
| MPLS-TC-EXT-STD-MIB | -- RFC 3289 MplsGlobalId MplsCcId MplsIccId MplsNodeId |
| MPLS-TC-STD-MIB | MplsExtendedTunnelId mplsStdMIB MplsTunnelIndex MplsTunnelInstanceIndex |
| MPLS-TE-STD-MIB | -- RFC 3811 mplsTunnelIndex mplsTunnelEgressLSRId mplsTunnelIngressLSRId mplsTunnelInstance |
| SNMPv2-CONF | -- RFC 2578 MODULE-COMPLIANCE OBJECT-GROUP |
| SNMPv2-SMI | MODULE-IDENTITY OBJECT-TYPE |
| SNMPv2-TC | -- RFC 2580 TruthValue RowPointer RowStatus StorageType |
| OID | Name | Access | Status | Description |
|---|---|---|---|---|
| 1.3.6.1.2.1.10.166.20 | IdentitymplsTeExtStdMIB | This MIB module contains generic object definitions for extending the MPLS Traffic Engineering tunnels in transport networks. Copyright (c) 2015 IETF Trust and… | ||
| 1.3.6.1.2.1.10.166.20.0 | NodemplsTeExtObjects | |||
| 1.3.6.1.2.1.10.166.20.0.1 | ScalarmplsTunnelExtNodeConfigLocalIdNext | read-only | current | This object contains an unused value for mplsTunnelExtNodeConfigLocalId, or a zero to indicate that none exist. Negative values are not allowed, as they do not… |
| 1.3.6.1.2.1.10.166.20.0.2 | TablemplsTunnelExtNodeConfigTable | not-accessible | current | This table allows the operator to map a node or LSR identifier (IP-compatible [Global_ID::Node_ID] or ICC-based [ICC_Operator_ID::Node_ID]) with a local identi… |
| 1.3.6.1.2.1.10.166.20.0.2.1 | RowmplsTunnelExtNodeConfigEntry | not-accessible | current | An entry in this table represents a mapping identification for the operator or service provider to a node or an LSR. As per RFC 6370, IP-compatible mapping is … |
| 1.3.6.1.2.1.10.166.20.0.2.1.1 | ColumnmplsTunnelExtNodeConfigLocalId | not-accessible | current | This object is used in accommodating the bigger- size Global_ID::Node_ID and/or the ICC_Operator_ID::Node_ID with the smaller-size LSR identifier in order to i… |
| 1.3.6.1.2.1.10.166.20.0.2.1.2 | ColumnmplsTunnelExtNodeConfigGlobalId | read-create | current | This object indicates the Global Operator Identifier. This object has no meaning when mplsTunnelExtNodeConfigIccValid is set true. |
| 1.3.6.1.2.1.10.166.20.0.2.1.3 | ColumnmplsTunnelExtNodeConfigCcId | read-create | current | This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Country Code (CC) either for Ingress ID or Egress ID. This object has n… |
| 1.3.6.1.2.1.10.166.20.0.2.1.4 | ColumnmplsTunnelExtNodeConfigIccId | read-create | current | This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Carrier Code (ICC) either for Ingress ID or Egress ID. This object has … |
| 1.3.6.1.2.1.10.166.20.0.2.1.5 | ColumnmplsTunnelExtNodeConfigNodeId | read-create | current | This object indicates the Node_ID within the scope of a Global_ID or ICC_Operator_ID. |
| 1.3.6.1.2.1.10.166.20.0.2.1.6 | ColumnmplsTunnelExtNodeConfigIccValid | read-create | current | Denotes whether or not this entry uses mplsTunnelExtNodeConfigCcId, mplsTunnelExtNodeConfigIccId, and mplsTunnelExtNodeConfigNodeId for mapping the ICC-based i… |
| 1.3.6.1.2.1.10.166.20.0.2.1.7 | ColumnmplsTunnelExtNodeConfigStorageType | read-create | current | This variable indicates the storage type for this object. Conceptual rows having the value 'permanent' need not allow write-access to any columnar objects in t… |
| 1.3.6.1.2.1.10.166.20.0.2.1.8 | ColumnmplsTunnelExtNodeConfigRowStatus | read-create | current | This object allows the operator to create, modify, and/or delete a row in this table. |
| 1.3.6.1.2.1.10.166.20.0.3 | TablemplsTunnelExtNodeIpMapTable | not-accessible | current | This read-only table allows the operator to retrieve the local identifier for a given Global_ID::Node_ID in an IP-compatible operator environment. This table M… |
| 1.3.6.1.2.1.10.166.20.0.3.1 | RowmplsTunnelExtNodeIpMapEntry | not-accessible | current | An entry in this table represents a mapping of Global_ID::Node_ID with the local identifier. An entry in this table is created automatically when the local ide… |
| 1.3.6.1.2.1.10.166.20.0.3.1.1 | ColumnmplsTunnelExtNodeIpMapGlobalId | not-accessible | current | This object indicates the Global_ID. |
| 1.3.6.1.2.1.10.166.20.0.3.1.2 | ColumnmplsTunnelExtNodeIpMapNodeId | not-accessible | current | This object indicates the Node_ID within the operator. |
| 1.3.6.1.2.1.10.166.20.0.3.1.3 | ColumnmplsTunnelExtNodeIpMapLocalId | read-only | current | This object contains an IP-compatible local identifier that is defined in mplsTunnelExtNodeConfigTable. |
| 1.3.6.1.2.1.10.166.20.0.4 | TablemplsTunnelExtNodeIccMapTable | not-accessible | current | This read-only table allows the operator to retrieve the local identifier for a given ICC_Operator_ID::Node_ID in an ICC operator environment. This table MAY b… |
| 1.3.6.1.2.1.10.166.20.0.4.1 | RowmplsTunnelExtNodeIccMapEntry | not-accessible | current | An entry in this table represents a mapping of ICC_Operator_ID::Node_ID with the local identifier. An entry in this table is created automatically when the loc… |
| 1.3.6.1.2.1.10.166.20.0.4.1.1 | ColumnmplsTunnelExtNodeIccMapCcId | not-accessible | current | This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Country Code (CC) either for Ingress or Egress LSR ID. The CC is a stri… |
| 1.3.6.1.2.1.10.166.20.0.4.1.2 | ColumnmplsTunnelExtNodeIccMapIccId | not-accessible | current | This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Carrier Code (ICC) either for Ingress or Egress LSR ID. The ICC is a st… |
| 1.3.6.1.2.1.10.166.20.0.4.1.3 | ColumnmplsTunnelExtNodeIccMapNodeId | not-accessible | current | This object indicates the Node_ID within the ICC-based operator. |
| 1.3.6.1.2.1.10.166.20.0.4.1.4 | ColumnmplsTunnelExtNodeIccMapLocalId | read-only | current | This object contains an ICC-based local identifier that is defined in mplsTunnelExtNodeConfigTable. |
| 1.3.6.1.2.1.10.166.20.0.5 | TablemplsTunnelExtTable | not-accessible | current | This table represents extensions to mplsTunnelTable in order to support MPLS-TP Tunnels. As per MPLS-TP Identifiers (RFC 6370), LSP_ID for IP-based co-routed b… |
| 1.3.6.1.2.1.10.166.20.0.5.1 | RowmplsTunnelExtEntry | not-accessible | current | An entry in this table represents additional MPLS-TP- specific tunnel configurations. |
| 1.3.6.1.2.1.10.166.20.0.5.1.1 | ColumnmplsTunnelExtOppositeDirPtr | read-create | current | This object points to the opposite-direction tunnel entry. |
| 1.3.6.1.2.1.10.166.20.0.5.1.2 | ColumnmplsTunnelExtOppositeDirTnlValid | read-create | current | Denotes whether or not this tunnel uses mplsTunnelExtOppositeDirPtr for identifying the opposite- direction tunnel information. Note that if this variable is s… |
| 1.3.6.1.2.1.10.166.20.0.5.1.3 | ColumnmplsTunnelExtDestTnlIndex | read-create | current | This object is applicable only for the bidirectional tunnel that has the forward and reverse LSPs in the different tunnel entries. The values of this object an… |
| 1.3.6.1.2.1.10.166.20.0.5.1.4 | ColumnmplsTunnelExtDestTnlLspIndex | read-create | current | This object is applicable only for the bidirectional tunnel that has the forward and reverse LSPs in the different tunnel entries. This object holds the instan… |
| 1.3.6.1.2.1.10.166.20.0.5.1.5 | ColumnmplsTunnelExtDestTnlValid | read-create | current | Denotes whether or not this tunnel uses mplsTunnelExtDestTnlIndex and mplsTunnelExtDestTnlLspIndex for identifying the opposite-direction tunnel information. N… |
| 1.3.6.1.2.1.10.166.20.0.5.1.6 | ColumnmplsTunnelExtIngressLSRLocalIdValid | read-create | current | This object denotes whether the mplsTunnelIngressLSRId contains the local value that is used to reference the complete Ingress Global_ID::Node_ID or ICC_Operat… |
| 1.3.6.1.2.1.10.166.20.0.5.1.7 | ColumnmplsTunnelExtEgressLSRLocalIdValid | read-create | current | This object denotes whether the mplsTunnelEgressLSRId contains the local value, which is used to reference the complete Egress Global_ID::Node_ID or ICC_Operat… |
| 1.3.6.1.2.1.10.166.20.1 | NodemplsTeExtConformance | |||
| 1.3.6.1.2.1.10.166.20.1.1 | NodemplsTeExtCompliances | |||
| 1.3.6.1.2.1.10.166.20.1.1.1 | CompliancemplsTeExtModuleFullCompliance | current | Compliance statement for agents that provide full support the MPLS-TE-EXT-STD-MIB module. | |
| 1.3.6.1.2.1.10.166.20.1.1.2 | CompliancemplsTeExtModuleReadOnlyCompliance | read-only | current | Compliance statement for agents that only provide read-only support for the MPLS-TE-EXT-STD-MIB module. |
| 1.3.6.1.2.1.10.166.20.1.2 | NodemplsTeExtGroups | |||
| 1.3.6.1.2.1.10.166.20.1.2.1 | GroupmplsTunnelExtGroup | current | Necessary, but not sufficient, set of objects to implement tunnels. In addition, depending on the operating environment, the following groups are mandatory. | |
| 1.3.6.1.2.1.10.166.20.1.2.2 | GroupmplsTunnelExtIpOperatorGroup | current | Object(s) needed to implement IP-compatible tunnels. | |
| 1.3.6.1.2.1.10.166.20.1.2.3 | GroupmplsTunnelExtIccOperatorGroup | current | Object(s) needed to implement ICC-based tunnels. |